Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-24-2010, 08:56 AM   #1
TheLordChesterfield
Scooby Newbie
 
Member#: 234539
Join Date: Jan 2010
Chapter/Region: South East
Location: Asheville, NC
Vehicle:
2004
Blue

Default Blue wire on STI Alternator -> STI ECU

On STI's alternator you find a third blue wire that runs to the ECU.

Does anyone know what this does? The alternator I have lacks this wire - is this a problem? I can't find a CEL for the generator either.

I'm finishing up the wiring on a swap and I'm not sure what to do?
* Registered users of the site do not see these ads.
TheLordChesterfield is offline   Reply With Quote
Old 11-27-2010, 02:58 PM   #2
TheLordChesterfield
Scooby Newbie
 
Member#: 234539
Join Date: Jan 2010
Chapter/Region: South East
Location: Asheville, NC
Vehicle:
2004
Blue

Default

Bump.

Anyone? I may just leave it open and see what happens, but I would prefer not to....
TheLordChesterfield is offline   Reply With Quote
Old 11-28-2010, 11:25 AM   #3
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

I'm reviewing a manual and have yet to locate this particular circuit on the ECU.

But for now, that blue wire is listed as for the STI only.

Also note that the STI is drive-by-wire, as well as for having the DCCD, electronic gauge cluster, and a host of other electronic items not normally found on non-STI models. So this may be a signal wire to the ECU to tell it if the alternator is charging or not. If not, then this may signal the ECU to shut the car down to prevent any possible damage to the electrical system and/or electronic items and components as a whole.
Big-E is offline   Reply With Quote
Old 11-30-2010, 02:46 PM   #4
atm92484
Scooby Newbie
 
Member#: 213374
Join Date: Jun 2009
Chapter/Region: MAIC
Vehicle:
2009 STi

Default

On a lot of newer cars, the computer controls the alternator output. I'd be willing to bet that is the wire that does it.

I vote for finding the correct alternator. Even though a 2 wire one should work without the ECU, its hard to say whether or not something will get damaged.
atm92484 is offline   Reply With Quote
Old 12-03-2010, 12:39 PM   #5
Britain
Scooby Newbie
 
Member#: 247604
Join Date: May 2010
Chapter/Region: NWIC
Location: Hillsboro, OR
Vehicle:
1974 Porsche 914
1700lb AX Car w/ Spec-C

Default

Yes, the Blue wire is the alternator output control wire from the ECU.

-Britain
Britain is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 smaller wires coming from alternator? 06 sti jasv11 Electrical & Lighting 0 06-09-2010 07:28 PM
Blue wheels on an 06 CGM STi? suby_dude Member's Car Gallery 28 06-26-2008 06:41 PM
newb wiring question: 4 AWG -> small terminal on Basslink marsh Car Audio, Video & Security 16 05-10-2007 10:55 AM
RPM sensor wire on STI ecu ? The Donnn Electrical & Lighting 1 10-13-2003 11:11 PM
Sighting: BLUE WRX on La Puente Rd -> Nogales... Onderboy?? karazyman Southern California Impreza Club Forum -- SCIC 5 02-17-2002 09:41 PM


All times are GMT -4. The time now is 08:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.