Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-06-2010, 10:55 AM   #1
savs165
Scooby Newbie
 
Member#: 263764
Join Date: Nov 2010
Default Cruise control blinking, check engine light on.

Hello - I have a 2008 Impreza, and I just got new tires put on 2 days ago, and ever since the CEL has been on and Cruise control blinking. About a year ago, I got stuck in a snow bank, and the CEL and cruise were on for a while, but then stopped. Im assuming because one tire was spinning different than the others.

Since, I git new tires, is this why those lights are on? Because they were balanced?
* Registered users of the site do not see these ads.
savs165 is offline   Reply With Quote
Old 12-06-2010, 12:45 PM   #2
Csquared33
Scooby Specialist
 
Member#: 198053
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: Danbury, CT
Vehicle:
93 2JZ something

Default

get it scanned
Csquared33 is offline   Reply With Quote
Old 12-06-2010, 04:02 PM   #3
savs165
Scooby Newbie
 
Member#: 263764
Join Date: Nov 2010
Default

Quote:
Originally Posted by Csquared33 View Post
get it scanned

Care to elaborate?
savs165 is offline   Reply With Quote
Old 12-06-2010, 04:44 PM   #4
whtscoobplk
Scooby Newbie
 
Member#: 195400
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Round Lake, IL
Vehicle:
2004 WRX STi
White

Default

Get a scanner that reads the Check Engine Light codes, or just stop by autozone, they can do it.


Quote:
Originally Posted by savs165 View Post
Care to elaborate?
whtscoobplk is offline   Reply With Quote
Old 12-06-2010, 04:46 PM   #5
savs165
Scooby Newbie
 
Member#: 263764
Join Date: Nov 2010
Default

Oh ok! I didnt know what he meant. Im just concerened because it went on after they put new tires on, and was never really on before.
savs165 is offline   Reply With Quote
Old 12-06-2010, 04:47 PM   #6
whtscoobplk
Scooby Newbie
 
Member#: 195400
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Round Lake, IL
Vehicle:
2004 WRX STi
White

Default

Well not sure if tires have anything to do with it, but yeah, get it scanned and let us know what code you get and go from there.
whtscoobplk is offline   Reply With Quote
Old 12-07-2010, 08:17 PM   #7
feint05
Scooby Specialist
 
Member#: 152984
Join Date: Jul 2007
Chapter/Region: SCIC
Location: san diego
Vehicle:
2004 jewbaru
jewbuilt, polish tuned

Default

you screwed up, thats an oh **** code
feint05 is offline   Reply With Quote
Old 12-15-2010, 11:46 AM   #8
xreaction122
Scooby Newbie
 
Member#: 264419
Join Date: Nov 2010
Chapter/Region: Tri-State
Location: Buffalo/Albany
Vehicle:
2004 RSTi
Plasma Blue Pearl

Default

Subarus disable the cruise function when the cel trips Thats why the cruise indicator is flashing
xreaction122 is offline   Reply With Quote
Old 12-15-2010, 01:01 PM   #9
Tubbs540
Scooby Specialist
 
Member#: 197216
Join Date: Dec 2008
Chapter/Region: South East
Location: Madison, WI --- Nashville, TN
Vehicle:
2002 WRX WHITEEEE
98 Jeep Grand Cherokee

Default

Quote:
Originally Posted by feint05 View Post
you screwed up, thats an oh **** code
Hahaha

Let us know what code it is throwing.
Tubbs540 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
flashing cruise control and check engine light themiggyman Southern California Impreza Club Forum -- SCIC 9 09-14-2010 02:35 PM
Check engine light on and cruise control blinking 06EzSTI Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 05-13-2008 10:10 PM
HELP! Check Engine light on & Cruise Control Light Blinking STiURBO Southern California Impreza Club Forum -- SCIC 21 03-15-2007 01:54 AM
Cruise Control and Check Engine Light.. i need help!! PhatAsiankid03 Electrical & Lighting 9 04-02-2004 03:07 PM
Blinking Check Engine Light on MY00 RS with MY02 WRX Swap Sunrise City Rider Subaru Conversions 2 09-01-2003 12:54 AM


All times are GMT -4. The time now is 12:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.