Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-13-2011, 07:53 PM   #1
TheLordChesterfield
Scooby Newbie
 
Member#: 234539
Join Date: Jan 2010
Chapter/Region: South East
Location: Asheville, NC
Vehicle:
2004
Blue

Default 06 WRX - Driver side oil feed leak? Cam position sensor?

I'm finishing up a swap with what was supposed to be a 06 wrx engine, trying to get it to run. I have ALMOST everything nailed down but now I'm really confused.

First, what is this? (red cap, top right, metal block, driver head) \/



I'm referring to the metal block towards the front of the driver side head...
It has an oil feed line that comes from the front of the head.

I have a blue connector that is hanging out, not connected to anything and I foolishly thought this block was the spot for the cam position sensor, but now I'm pretty positive they are located towards the back of the heads.

I thought everything was good to go - I have spark, fuel pump was on, continuity to the injectors, and the oil pump was on AND OIL was seeping out of the back of this metal block from (what I thought was) a sensor sized hole.

The connector looks like this:


This is from a 08 STI and my wires are YB and LB (yellow/black and blue/black).

I'm looking through diagrams for what it could be - but all three have no connectors that are specifically blue....

Any ideas??? I'm ready to freak out - after all of the wiring work this should be the least of my worries!
* Registered users of the site do not see these ads.

Last edited by TheLordChesterfield; 06-13-2011 at 07:56 PM. Reason: Tried to line up arrow
TheLordChesterfield is offline   Reply With Quote
Old 06-19-2011, 07:28 PM   #2
TheLordChesterfield
Scooby Newbie
 
Member#: 234539
Join Date: Jan 2010
Chapter/Region: South East
Location: Asheville, NC
Vehicle:
2004
Blue

Default

As usual, no one on this site was helpful in the slightest.

For anyone who has this question in the future - it is the AVCS solenoid aka "Oil control valve" used to monitor pressure and allow activation of variable valve timing.

Decent help is hard to find - especially on this forum
TheLordChesterfield is offline   Reply With Quote
Old 08-09-2011, 12:54 AM   #3
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim TQ monster

Default

Might be too late to answer, but it is your AVCS sensor.
gabedude is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fs: knock sensor, oil press. switch, cam position sensor, water temp sensor, ex mani jakesurfin Engine/Power/Exhaust 9 06-15-2009 01:28 PM
fs: knock sensor, oil press. switch, cam position sensor, water temp sensor jakesurfin TXIC Private Classifieds 4 06-15-2009 01:28 PM
WTB: 06 WRX front driver side axle ohxietviet TXIC Private Classifieds 3 12-28-2007 03:24 PM
WTB: 06 wrx/sti driver side fender, Crystal Gray Metallic DarkDvr SCIC Private Classifieds 0 04-13-2007 03:29 PM
WRX vs. 2.5L STi crank and cam position sensors - the same? Red Rocket Factory 2.0L Turbo Powertrain 10 10-24-2003 09:35 AM


All times are GMT -4. The time now is 11:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.