Welcome to the North American Subaru Impreza Owners Club Monday September 15, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-05-2011, 10:03 AM   #1
ToxicCrucible
Scooby Newbie
 
Member#: 254200
Join Date: Aug 2010
Location: Minneapolis, MN
Vehicle:
2008 WRX - 316hp
Rally Blue

Default Help getting rid of CEL

Im at wits end here.

It was a pretty cold night (-1) and I got a CEL. Wasnt to bothered because I usually get them when its cold and then the next time I start my car it gone. I try to pull the code and get no code. Ok, no big deal. I just figured it was because of the cold

My newest CEL wont go away. I tried to pull the code with 2 different readers (accessport and a stand alone code reader I have) every time, 0 Codes. I tried to reset the ECU via the AP and my other reader, plus undoing the neg battery terminal. The light is still there. I even re-flased the ECU with my AP, still the CEl is on.

Any suggestions?
* Registered users of the site do not see these ads.
ToxicCrucible is offline   Reply With Quote
Old 01-05-2011, 10:54 AM   #2
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2007 Lotus Elise
(From General)

Default

Open the hood and look for mice eating your wiring harness. (no, I'm not kidding)

http://forums.nasioc.com/forums/show....php?t=2091074
Jack is offline   Reply With Quote
Old 01-05-2011, 11:00 AM   #3
ToxicCrucible
Scooby Newbie
 
Member#: 254200
Join Date: Aug 2010
Location: Minneapolis, MN
Vehicle:
2008 WRX - 316hp
Rally Blue

Default

Holy crap!

I have a feeling they would freeze. It is so damn cold up in Minnesota right now
ToxicCrucible is offline   Reply With Quote
Old 01-05-2011, 11:22 AM   #4
xrwsubaru08
Scooby Newbie
 
Member#: 249410
Join Date: Jun 2010
Chapter/Region: MAIC
Location: NC / PA
Vehicle:
2008 WRX

Default

are you still covered under warranty? If so, drum roll.... take it to a dealer. If you have aftermarket parts or your warranty is up, take it to a local subaru shop and have them figure it out if you have exhausted all other options.
xrwsubaru08 is offline   Reply With Quote
Old 01-05-2011, 11:36 AM   #5
ToxicCrucible
Scooby Newbie
 
Member#: 254200
Join Date: Aug 2010
Location: Minneapolis, MN
Vehicle:
2008 WRX - 316hp
Rally Blue

Default

I just hit 30K I think I am out of warranty
ToxicCrucible is offline   Reply With Quote
Old 01-05-2011, 01:46 PM   #6
MonsterSubie
Scooby Newbie
 
Member#: 246931
Join Date: May 2010
Chapter/Region: TXIC
Location: De Queen
Vehicle:
2006 Impreza WRX
OBP

Default

Try some other readers. Take it to Autozone to get the codes read. Thats at least one more chance to get the code read. you might get lucky and get the code and someone might be able to interpret/give you a quick fix. Its Worth a shot.
MonsterSubie is offline   Reply With Quote
Old 01-05-2011, 01:48 PM   #7
ToxicCrucible
Scooby Newbie
 
Member#: 254200
Join Date: Aug 2010
Location: Minneapolis, MN
Vehicle:
2008 WRX - 316hp
Rally Blue

Default

Yeah, great point.
ToxicCrucible is offline   Reply With Quote
Old 01-05-2011, 02:46 PM   #8
ChrisTahoe
Scooby Specialist
 
Member#: 244749
Join Date: Apr 2010
Chapter/Region: MWSOC
Location: Middle of nowhere
Vehicle:
14 Fiesta ST
"Race" Red

Default

Is your gas cap tight? That can throw a CEL... might take a few drive cycles to go away if that ends up being the case.
ChrisTahoe is offline   Reply With Quote
Old 01-05-2011, 02:48 PM   #9
ToxicCrucible
Scooby Newbie
 
Member#: 254200
Join Date: Aug 2010
Location: Minneapolis, MN
Vehicle:
2008 WRX - 316hp
Rally Blue

Default

Ill check tonight. Good call

But like I said, every time I try to pull the code the reader reads 0 codes. Hopefully it is a short in the light
ToxicCrucible is offline   Reply With Quote
Old 01-05-2011, 03:14 PM   #10
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2007 Lotus Elise
(From General)

Default

Quote:
Originally Posted by ToxicCrucible View Post
I just hit 30K I think I am out of warranty
Could be up based on time (36 months) but isn't by mileage (36k bumper to bumper, 60k power train)

I have an 08 that's way over mileage (75k) but just barely out by date (in service December 21, 2007)

Oh....also emissions equip is waranteed for 80k miles and I belive no time limit. (wife just had 2 cats replaced free under warantee at 50k miles)
Jack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help getting rid of ECUTEK flash NJHK Tri-State Area Forum 18 01-22-2011 01:06 PM
help getting rid of knock opensource 06-wrx-tr Rocky Mountains Impreza Club Forum -- RMIC 3 12-30-2008 03:05 AM
Some help getting rid of this eff'in spyware/adware :mad: DrDRum Off-Topic 22 03-12-2008 08:27 AM
Need some help getting rid of this noise... MitchGT Legacy Forum 8 03-20-2007 03:26 AM
no cat. how get rid of cel 2.5racer Normally Aspirated Powertrain 3 08-10-2002 07:58 PM


All times are GMT -4. The time now is 05:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.