Welcome to the North American Subaru Impreza Owners Club Friday January 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-23-2011, 12:11 AM   #1
prezarevo
Scooby Specialist
 
Member#: 266930
Join Date: Dec 2010
Chapter/Region: Tri-State
Location: Pennsylvania
Vehicle:
2004 WRX
PSM

Default Power loss then power gain.

I have a 2000 outback sport wagon 2.2 auto. The issue I'm having is at times the car picks up as if it should WOT, Then at times it'll scream and just crawl. Also at times it feels like its ready to take off, then go's turtle on me, then go's road runner, then go's turtle. As if it grabs and then doesn't grab. Off and on. Like some thing is holding it back. It crossed my mind that maybe it's the torque converter. But not sure. This happens when its cold and warm. I noticed after long road trips on the high way it won't do it. Once I drive around the city it will start doing it again. If anyone has an idea or a suggestion please post.

Thanks.
Revo
* Registered users of the site do not see these ads.
prezarevo is offline   Reply With Quote
Old 01-23-2011, 04:06 AM   #2
tylerq219
Scooby Newbie
 
Member#: 68213
Join Date: Aug 2004
Chapter/Region: NESIC
Location: milf
Vehicle:
92? justy rally car
white/blue/mud #44

Default

transmission or torque converter. most likely the first one.
tylerq219 is offline   Reply With Quote
Old 01-23-2011, 01:21 PM   #3
prezarevo
Scooby Specialist
 
Member#: 266930
Join Date: Dec 2010
Chapter/Region: Tri-State
Location: Pennsylvania
Vehicle:
2004 WRX
PSM

Default

When it shifts it doesn't slam or anything. It's quite smooth really.
prezarevo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noise then loss of power flyingtaco Transmission (AT/MT) & Driveline 35 09-27-2010 11:47 AM
tune= no power gain/loss of power? :( junior1023 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 13 08-17-2010 01:29 AM
Car cuts off- total loss of power for ~1 second, then resumes MK19_ Electrical & Lighting 8 11-04-2005 01:51 PM
04 Silver STi wheels, my loss is your gain..good price with PICS MtnManWRX Private 'For Sale' Classifieds 10 11-04-2004 11:09 AM
New In Box... Perrin FMIC - My Loss is your gain. Stang2WRX Private 'For Sale' Classifieds 13 08-30-2004 12:52 AM


All times are GMT -4. The time now is 04:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.