Welcome to the North American Subaru Impreza Owners Club Monday August 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-23-2011, 11:02 PM   #1
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Exclamation SPT Boost Gauge Back Light Failure for 2011 WRX

So the other week my boost gauge back light started flickering like crazy. It was worse when the interior lighting was switched all the way up, but got better when it was turned down. That lasted for about two days until it finally just stopped coming on. The replacement part came in last week and I'm getting it installed under warranty tomorrow.

Note: The SPT gauge currently mounted is from my pre-ordered WRX Limited. Shortly after receiving my car Subaru stopped allowing this boost gauge and issued a different one later.

Has anyone else had any issues with their SPT boost gauge?
* Registered users of the site do not see these ads.
chanomatik is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-24-2011, 07:19 AM   #2
climbhigh09
Scooby Specialist
 
Member#: 254163
Join Date: Aug 2010
Chapter/Region: MAIC
Location: MD
Vehicle:
2011 WRX 20GXTR
Black

Default

Mine jiggles like mad when the bass is turned up
climbhigh09 is offline   Reply With Quote
Old 01-25-2011, 08:26 PM   #3
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Well all 2011 WRX/STi with SPT boost gage have the same problem. I am still waiting for the fix.
Let me know if fix is available.
2011WRX is offline   Reply With Quote
Old 01-28-2011, 02:44 AM   #4
larkdemon
Scooby Newbie
 
Member#: 260917
Join Date: Oct 2010
Chapter/Region: SCIC
Location: High Desert, CA
Vehicle:
2011 WRX
Spark Silver

Default

According to my dealership, they installed a 2010 SPT boost gauge on my 2011 WRX, and if they got replacement parts it would probably also result in the backlight shorting out/excessive needle vibration anyway.

They should be showing up sometime in March this year. If you you've stopped by the dealership anytime lately, look up a 2011 WRX accessories brochure and it says there.
larkdemon is offline   Reply With Quote
Old 01-29-2011, 12:28 PM   #5
darren94
Scooby Newbie
 
Member#: 138697
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Charlottesville, VA
Vehicle:
11 WRX Limited 5DR
Satin Pearl

Default

my 09 has the 10 model gauge and nor backlight problems but, it does rattle and the needle vibrates. This is common?
darren94 is offline   Reply With Quote
Old 02-01-2011, 08:25 PM   #6
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Yeah, I remember reading that the proper 2011 boost gauge wouldn't be available until March. I got one replaced under warranty and it's cool, so far. I wonder if it'd be too far out of bounds for me to request the proper one once it arrives in March?
chanomatik is offline   Reply With Quote
Old 02-04-2011, 02:41 AM   #7
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Discovered that the 2010 SPT boost gauge was installed, not the 2011 that comes out in March. They're looking to see if they can be swapped eventually.
chanomatik is offline   Reply With Quote
Old 02-11-2011, 11:05 AM   #8
Gone Subin'
Scooby Newbie
 
Member#: 124328
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Marion, Iowa
Vehicle:
2011 SWP STI Sedan
ex. '06 STI, '08 STI

Default

Crazy, mine started doing the exact same thing last night. Flickering like crazy unless the illumination was down very low. It didn't reenact this morning, but took video of it last night to show to service.

So it's probably safe to say the 2010 gauge is what I got...hopefully get a proper replacement when those come out.
Gone Subin' is offline   Reply With Quote
Old 02-11-2011, 07:18 PM   #9
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Quote:
Originally Posted by darren94 View Post
my 09 has the 10 model gauge and nor backlight problems but, it does rattle and the needle vibrates. This is common?
I have HKS boost gage on my other ride and never did that (neddle vibrate)

Still waiting for the new gage for my 11WRX
2011WRX is offline   Reply With Quote
Old 02-24-2011, 01:34 PM   #10
Gone Subin'
Scooby Newbie
 
Member#: 124328
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Marion, Iowa
Vehicle:
2011 SWP STI Sedan
ex. '06 STI, '08 STI

Default

I am on the waiting list for the '11 model accessory boost gauge to become available. Boost gauge has since stopped back-lighting completely. Thankfully it's mechanical so I can still get a reading!
Gone Subin' is offline   Reply With Quote
Old 03-02-2011, 05:26 PM   #11
SwordVan
Scooby Newbie
 
Member#: 260540
Join Date: Oct 2010
Chapter/Region: TXIC
Vehicle:
2011 STI 5-Door
WRB

Default

Just took mine in to get replaced and the dealership instead put in a order for a new bulb. I quipped but they insisted that this would fix it. Cant wait to make 3 trips to the dealership instead of 1. Thanks Subaru!
SwordVan is offline   Reply With Quote
Old 03-02-2011, 09:13 PM   #12
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Quote:
Originally Posted by SwordVan View Post
Just took mine in to get replaced and the dealership instead put in a order for a new bulb. I quipped but they insisted that this would fix it. Cant wait to make 3 trips to the dealership instead of 1. Thanks Subaru!
I am not sure if the new bulb will fix the issue. It's has something to do with interaction between 11MY electrical with boost gage circuit board.
2011WRX is offline   Reply With Quote
Old 03-09-2011, 09:11 PM   #13
Ellery
Scooby Newbie
 
Member#: 267484
Join Date: Dec 2010
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
2011 Impreza WRX STI
Plasma Blue Pearl

Default

Hmm I was wondering why the Boost Gage Option was being delayed - I got my 2011 in early Dec and was never given a time or reason when I should be getting the Options I ordered installed. I ordered the Homelink Mirrors, Boost gage, and short shift kit. So I guess the long lead is the Boost gage per all the notes above. I figure I'll bring it to the dealer once instead of 3 separate times. I just hope to confirm it through the dealer I'm working with .. and he wonders why I gave him a 3.8/10 rating.
Ellery is offline   Reply With Quote
Old 09-16-2011, 04:32 PM   #14
The1SloR/T
Scooby Specialist
 
Member#: 251879
Join Date: Jul 2010
Chapter/Region: MAIC
Location: Pittsburgh (South Hills)
Vehicle:
1998 Neon R/T 178whp
2010 Wrx Sedan WRB

Default

It's the bulb, Just had this problem. 194 LED bulb. you can get a ricer one from pep boys or get a quality one from superbrightleds.com
The1SloR/T is offline   Reply With Quote
Old 10-08-2011, 10:31 PM   #15
DeRock25
Scooby Newbie
 
Member#: 284715
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Calumet City, IL
Vehicle:
2011 impreza WRX
Dark Gray Metallic

Default

So, is this issue resolved or what!? i want to get a boost gauge for my car.. i believe i actually need one as i am about to get it tuned... but i want the stock one... Can i e-bay it and just replace the bulb and roll with it or what?? or do i have to wait as the dealership told me if i ordered it now i would get it on new years..
DeRock25 is offline   Reply With Quote
Old 10-17-2011, 10:17 AM   #16
climbhigh09
Scooby Specialist
 
Member#: 254163
Join Date: Aug 2010
Chapter/Region: MAIC
Location: MD
Vehicle:
2011 WRX 20GXTR
Black

Default

Quote:
Originally Posted by DeRock25
So, is this issue resolved or what!? i want to get a boost gauge for my car.. i believe i actually need one as i am about to get it tuned... but i want the stock one... Can i e-bay it and just replace the bulb and roll with it or what?? or do i have to wait as the dealership told me if i ordered it now i would get it on new years..
Buy mine... And a bulb. PM me if you're serious.
climbhigh09 is offline   Reply With Quote
Old 01-03-2012, 11:57 AM   #17
climbhigh09
Scooby Specialist
 
Member#: 254163
Join Date: Aug 2010
Chapter/Region: MAIC
Location: MD
Vehicle:
2011 WRX 20GXTR
Black

Default

meant to post this a while ago... took 5 min and 5$ to fix. Get at least 90* led, white or red. The face of the gauge is red tinted, so you can't change the color by altering the led.

pry old out

new in, old on dash

new in, about to throw cover on and reinstall gauge

bam! done. Took longer to write the post.
climbhigh09 is offline   Reply With Quote
Old 02-17-2012, 04:42 PM   #18
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Having this issue again and had a friend at Subaru dealer find this thread and remind me that I started it. How's the replacement bulb holding up?

Thanks for this, btw. I'm sick of bringing the car in for warranty repair of this one part.
chanomatik is offline   Reply With Quote
Old 02-17-2012, 04:49 PM   #19
Lrn2Corner
Scooby Specialist
 
Member#: 246224
Join Date: May 2010
Chapter/Region: MAIC
Location: Chesapeake
Vehicle:
2012 WRX Sedan
12 Rav4 V6

Default

Great Chano lol
So having to swap a bulb out in 5 minutes is what i have to look forward to? Well that will be simple. Screw taking it to a dealer.
Lrn2Corner is offline   Reply With Quote
Old 02-17-2012, 05:06 PM   #20
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

I realized I had never kept track of this thread because I forgot to subscribe to it... haha I did now, though, and can add it to some other discussions.
chanomatik is offline   Reply With Quote
Old 02-17-2012, 05:18 PM   #21
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

So to clarify: The SPT gauge that is flickering now is the "...500" part number that was released in March of last year. Apparently there's another SPT boost gauge revision being made available this March? Seems kinda silly that the bulb just gives out after a while.
chanomatik is offline   Reply With Quote
Old 02-17-2012, 05:54 PM   #22
rmj
Scooby Specialist
 
Member#: 276611
Join Date: Mar 2011
Chapter/Region: MWSOC
Location: Eau Claire, WI
Vehicle:
2011 STi 5-Door
Plasma Blue Pearl

Default

Quote:
Originally Posted by chanomatik
So to clarify: The SPT gauge that is flickering now is the "...500" part number that was released in March of last year. Apparently there's another SPT boost gauge revision being made available this March? Seems kinda silly that the bulb just gives out after a while.
Aw shoot, that's probably one I have maybe? I wasn't able to get my gauge until mid-summer.
rmj is offline   Reply With Quote
Old 02-17-2012, 05:57 PM   #23
Doberzus
Scooby Newbie
 
Member#: 275480
Join Date: Mar 2011
Default

My 2012 WRX is doing the same thing. Pretty irritating. So I guess they stil have not revised it yet?
Doberzus is offline   Reply With Quote
Old 02-20-2012, 04:24 PM   #24
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Got it switched out with a 194 non-LED for the moment. I plan on changing it out tonight with an actual LED bulb.

Easy breezy.
chanomatik is offline   Reply With Quote
Old 02-21-2012, 10:07 PM   #25
rx7scott
Scooby Newbie
 
Member#: 295111
Join Date: Sep 2011
Chapter/Region: South East
Vehicle:
2012 WRX STI
Pearl White

Default

Just changed mine out with WLED-NW5 from superbrightleds.com and it fixed it , I will update if it gives me anymore problems in the future.
rx7scott is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light on for 2011 WRX pushatam Newbies & FAQs 15 07-29-2011 10:22 AM
FS : for sale 08-2011 wrx and sti spt boost gauge setup! felixwankel88 Interior/Dressup/Audio & Security 7 01-13-2011 06:26 PM
SPT boost gauge 2008/2009 WRX/STI rexbanner Interior/Dressup/Audio & Security 4 07-24-2009 10:41 PM
SPT boost gauge on 09 wrx brandon_bxtr Newbies & FAQs 0 06-14-2009 01:23 PM
09 wrx spt boost gauge question Drew303 Newbies & FAQs 7 04-28-2009 06:17 PM


All times are GMT -4. The time now is 01:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.