Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-27-2011, 11:06 PM   #1
alejo
Scooby Newbie
 
Member#: 170081
Join Date: Jan 2008
Location: Tegucigalpa
Vehicle:
2004 2.5RS
blue

Default 02 sensor fitment?

I just received a new O2 sensor I bought from amazon. I used the "make sure it fits" feature, and it said it would. Now, this sensor only has 3 lines, two white a one black. I beleive mine has 4!! havenīt checked due to lack of time. Will it fit? It`s a 99 OBS. thanx a lot, cheers
* Registered users of the site do not see these ads.
alejo is offline   Reply With Quote
Old 01-29-2011, 10:29 AM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

as far as i know, the front is a 5 wire, rear is 4.
yarrgh is offline   Reply With Quote
Old 01-29-2011, 10:57 AM   #3
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

I've not had much luck with aftermarket sensors.

I gave up and now only buy oem

Sounds like you've got the wrong sensor.

I would not install it as if it doesn't work, they likely will not take it back.
Subie Gal is offline   Reply With Quote
Old 01-29-2011, 11:16 AM   #4
Wrencher86
Scooby Newbie
 
Member#: 250463
Join Date: Jun 2010
Location: Evanston, Il
Vehicle:
2010 Impreza 2.5i
Silver

Default

There is the possibility that they were just lazy in designing/manufacturing the sensor and instead of running a ground wire they just ground the heater circuit through the pipe. That's kind of a big if though. And even if it still works with the three wires do you really want to trust a sensor from a company that's too lazy to put in the proper number of wires?
Wrencher86 is offline   Reply With Quote
Old 01-29-2011, 06:41 PM   #5
alejo
Scooby Newbie
 
Member#: 170081
Join Date: Jan 2008
Location: Tegucigalpa
Vehicle:
2004 2.5RS
blue

Default

what color is the ground that comes from the harness to the sensor?
alejo is offline   Reply With Quote
Old 01-30-2011, 01:29 AM   #6
Wrencher86
Scooby Newbie
 
Member#: 250463
Join Date: Jun 2010
Location: Evanston, Il
Vehicle:
2010 Impreza 2.5i
Silver

Default

No idea.
Wrencher86 is offline   Reply With Quote
Old 01-31-2011, 12:15 PM   #7
alejo
Scooby Newbie
 
Member#: 170081
Join Date: Jan 2008
Location: Tegucigalpa
Vehicle:
2004 2.5RS
blue

Default

anyone?
alejo is offline   Reply With Quote
Old 01-31-2011, 04:02 PM   #8
Wrencher86
Scooby Newbie
 
Member#: 250463
Join Date: Jun 2010
Location: Evanston, Il
Vehicle:
2010 Impreza 2.5i
Silver

Default

An auto parts store should be able to print you a wiring diagram. (Act like you want to buy something first)
Wrencher86 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted: MAF mass air sensor. 02 sensors. EGT sensor timing cover. tscott915 Private 'Wanted' Classifieds 10 10-07-2009 01:26 AM
Front 02 Sensor,Rear 02 Sensor,MAF Sensor,Blox Shift Knob,SPT Oil Cap, bunch of stuff TopEndPull Engine/Power/Exhaust 11 08-14-2009 05:48 PM
WTB: 02-07 Maf Sensor, 04-07 Sti or 06-07 WRX 02 Sensor. TopEndPull TXIC Private Classifieds 1 07-26-2008 09:54 AM
Oem 02 front sensor Or Wideband 02 sensor Fast_Wrx62 Factory 2.0L Turbo Powertrain 4 10-06-2006 09:58 AM
Defi EGT sensor fitment problem kyo Factory 2.0L Turbo Powertrain 4 09-13-2005 11:02 AM


All times are GMT -4. The time now is 02:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.