Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-12-2002, 12:03 PM   #1
phatroksek
Scooby Specialist
 
Member#: 7397
Join Date: Jun 2001
Location: NJ
Default solutions please

I'm just gonna go ahead and list a few things that the dealer never fixed for me and see if anyone knows what to do.

I have a sulfur smell that comes from even low rpms. I have switched to premium gas, and the smell has stopped coming from 3 rpm, but let's just say 4 rpms instead
I brought it to the dealer and twice they put in new cats, which did nothing, but then it somehow created a new sound that does not sound right. After the first time bringing it back from the dealer, the sound was at 3.5k rpm and 4.2k rpm, and after the second time, it was only at 3.5k. I really don't feel like bringing it back to the dealer cause I don't think they'll fix it anyway...
Also, I believe my car has that famous "clutch shudder" problem, and the dealer tells me, "we could not duplicate", is there something I can do about that?
And recently, on my way to a stop, when I put it in first, it grinds its way in. Is it because my clutch is wearing?

Thanks in advance,
Jesse
* Registered users of the site do not see these ads.
phatroksek is offline   Reply With Quote
Old 07-12-2002, 01:28 PM   #2
goobie
Scooby Specialist
 
Member#: 8273
Join Date: Jul 2001
Location: White Rock BC, Canada
Vehicle:
2006 WRX Wagon
WRB

Default Hey give me back my car!!!

Either you stole my car or you have the EXACT same problems I was having, except for the sulfer smell. Mine only does that on regular fuel and I use premium.
I had more problems with clutch shudder than I could shake a pressure plate at! Do a search on my username and "clutch" You should find a bunch of threads on the my clutch saga. I had 2 OEM clutches replaced in under warranty at a local dealer and within days, they had the same symptoms. The solution: Aftermarket clutch. I went with an Exedy unit, It's nice!
I also ran into the "grinding first gear" (and second, and third...) problem. I went to a great dealership that replaced 1st, 2nd, and 3rd syncros for me under warranty (Thanks Subaru Lachute!). That fixed that problem.

Hope this info helps and you get your car working properly. Believe me I know how frustrating it is when you can't get something fixed when you know it's broken!

Good Luck!
Chad
goobie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
To the powers of OT: Please fill this out for me. Pea-Ta Off-Topic 10 06-02-2010 07:03 AM
delete please norcalwrx816 AccessPort 3 06-01-2010 03:08 PM
My wheel problem and suggest a solution please! Chandy69 Tire & Wheel 15 04-10-2007 01:30 AM
Digital Video and DVD Editing Solutions...Please Help... xfactor834 Off-Topic 2 09-05-2003 03:18 PM
Solution for the name game... Please Read. webkris New England Impreza Club Forum -- NESIC 11 03-15-2000 07:34 AM


All times are GMT -4. The time now is 08:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.