Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-06-2011, 02:46 PM   #1
RR
Scooby Specialist
 
Member#: 48191
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Little Rhody
Vehicle:
2012 WRX
Ducati Monster

Default Need help identifying a plug and a hose

I've been having problems with idle, hesitation, and fuel economy since reinstalling this engine. There are a couple things I am unclear on, and need help figuring out what they are and how they should be connected.

First up, what is this plug?


Currently, it is plugged into this:



Which then goes nowhere, this has to be a problem.



On the original (to me) setup this was connecting to a home depot style CAI. At first I had this connecting to the airbox but in troubleshooting, I pulled it off to connect the hose in the last picture of this thread. Symptoms remained the same with either configuration.

Next up, I am looking for the correct plumbing for this valve:



Currently I have it running like this:



In case its not clear, the valve at the top of the engine bock splits to connect to the air box and to a metal valve (PCV?) on the intake manifold.
* Registered users of the site do not see these ads.

Last edited by RR; 02-07-2011 at 08:34 AM.
RR is offline   Reply With Quote
Old 02-06-2011, 05:14 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

Your PCV hose is correct. What does the part inside the hose look like? As you can probably tell, subaru give you just enough wire to connect things, try looking in the radius of the plug/mystery piece.

See where the vacuum hose goes to the fuel pressure regulator? Look underneath there. There is a valve that does....something for emissions. It's bolted to the underside of the intake manifold, is that it?
yarrgh is offline   Reply With Quote
Old 02-06-2011, 05:35 PM   #3
RR
Scooby Specialist
 
Member#: 48191
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Little Rhody
Vehicle:
2012 WRX
Ducati Monster

Default

Quote:
Originally Posted by yarrgh View Post
Your PCV hose is correct. What does the part inside the hose look like? As you can probably tell, subaru give you just enough wire to connect things, try looking in the radius of the plug/mystery piece.

See where the vacuum hose goes to the fuel pressure regulator? Look underneath there. There is a valve that does....something for emissions. It's bolted to the underside of the intake manifold, is that it?
I replaced the PCV valve a couple weeks ago, i'm just not sure that hose should be splitting and going to the airbox or if it should just be running from the block to PCV.
RR is offline   Reply With Quote
Old 02-08-2011, 10:19 AM   #4
RR
Scooby Specialist
 
Member#: 48191
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Little Rhody
Vehicle:
2012 WRX
Ducati Monster

Default

bump, still trying to figure this out.
RR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help identifying hose. SLOMatt Factory 2.0L Turbo Powertrain 6 11-07-2008 12:36 AM
Exhaust I need help identifying this and its for sale. robsta1 SCIC Private Classifieds 6 01-15-2008 12:55 PM
Need help identifying springs and tophats jameslippert Brakes, Steering & Suspension 10 07-23-2006 06:07 PM
I need help identifying a song. (in New Jack city and I think in CB4) Eric SS Off-Topic 18 09-25-2002 11:17 PM
Need help identifying a hose. SleeperWRX Factory 2.0L Turbo Powertrain 4 09-01-2002 07:39 PM


All times are GMT -4. The time now is 01:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.