Welcome to the North American Subaru Impreza Owners Club Wednesday April 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-01-2012, 12:34 PM   #12951
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by 2012ruimpreza

Yea I'm not worried I'm at 6k and I haven't used a drop, I think people on here are freaking out over a couple of lemons.
While I'm glad to hear that you and others here aren't having any consumption issues, I believe this is a bigger issue than just "a couple of lemons". Not to start anything, but it seems like the only ones saying not to worry about it are the ones who, luckily, haven't experienced any oil consumption problems. I know its not doing any good to get worked up about it, but this isn't something that should just be ignored.
* Registered users of the site do not see these ads.
jr0bb5 is online now   Reply With Quote
Old 07-01-2012, 01:26 PM   #12952
subiedude676
Scooby Newbie
 
Member#: 241369
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Emmaus, PA
Vehicle:
2012 2.0i Premium
Ice Silver Metallic

Default

I'm at 2,300 miles on my car from new and I haven't had any oil consumption issues at all.
subiedude676 is offline   Reply With Quote
Old 07-01-2012, 01:47 PM   #12953
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2015 WRX CVT
White

Default

If the engine is broken in and not currently using oil it is pretty unlikely the rings are going to fail and the engine is going to start consuming oil, at least not during the next 150,000-200,000 miles.

Now I have seen some ringland failures in STI's, but in the new 2.0i engine? I doubt it is going to start happening.

If your engine is using oil, sorry, it is not that common. Half the people jumping on the worry train don't even know if their car is using oil. Do you want to know how to discern if yours is?

Do your own oil change, measure the oil you put back in the car, check the dipstick, and see if the level drops over time.
Zeeper is offline   Reply With Quote
Old 07-01-2012, 02:06 PM   #12954
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default Antenna and car wash

I was looking through the owner's manual for my 2012 Impreza 5-door, and noticed it says that you should remove the antenna rod before driving the car through a car wash.

Do others do this? Golly, that's inconvenient. Makes me wonder why Subaru didn't use one of those shark-fin styled antennas instead.
sgoldste01 is offline   Reply With Quote
Old 07-01-2012, 02:42 PM   #12955
G-Omaha
Scooby Specialist
 
Member#: 209172
Join Date: Apr 2009
Location: Omaha, NE
Vehicle:
2012 Impreza CLL
BL2

Default

Quote:
Originally Posted by sgoldste01 View Post
Makes me wonder why Subaru didn't use one of those shark-fin styled antennas instead.
Cost...

I leave mine on; however, I also go to a touch-less wash facility.
G-Omaha is offline   Reply With Quote
Old 07-01-2012, 06:20 PM   #12956
Xarthan
Scooby Newbie
 
Member#: 312318
Join Date: Mar 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 Impreza Sport
ISM

Default

Shark fin antenna, hmm...
Xarthan is offline   Reply With Quote
Old 07-01-2012, 06:43 PM   #12957
Haunty
Scooby Newbie
 
Member#: 319378
Join Date: May 2012
Chapter/Region: MWSOC
Location: West Central MN
Vehicle:
2012 2.0i Sport Ltd.
Satin White Pearl

Default

Quote:
Originally Posted by sgoldste01 View Post
I was looking through the owner's manual for my 2012 Impreza 5-door, and noticed it says that you should remove the antenna rod before driving the car through a car wash.

Do others do this? Golly, that's inconvenient. Makes me wonder why Subaru didn't use one of those shark-fin styled antennas instead.
I saw that too, but I think it's just nonsense to protect themselves from complaints in case the antenna is actually broken by a car wash.
Haunty is online now   Reply With Quote
Old 07-01-2012, 07:31 PM   #12958
thom52
Scooby Newbie
 
Member#: 309257
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Kirkland WA
Vehicle:
2012 Imp 5D Prem CVT
Marine Blue

Cool visual garage shark fin antenna

Quote:
Originally Posted by Xarthan View Post
Shark fin antenna, hmm...
Elsewhere on this forum, the Visual Garage Shark Fin antenna seems to receive praise.
A bit spendy at $69, but its color matched to your car.

Catch is, I noticed on the site, that they only go up to 2009 Impreza for what they list as available. Not sure if its different for 2012.
http://visualgarage.com/

I am debating something like that. The stock antenna is pretty darn ugly.
thom52 is offline   Reply With Quote
Old 07-01-2012, 10:19 PM   #12959
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by G-Omaha

Cost...

I leave mine on; however, I also go to a touch-less wash facility.
Same here
jr0bb5 is online now   Reply With Quote
Old 07-01-2012, 11:10 PM   #12960
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by Haunty View Post
I saw that too, but I think it's just nonsense to protect themselves from complaints in case the antenna is actually broken by a car wash.
The concern in the owner's manual isn't that the antenna will break. It's that the antenna might be bent and scratch the car's paint.
sgoldste01 is offline   Reply With Quote
Old 07-02-2012, 02:06 AM   #12961
Xarthan
Scooby Newbie
 
Member#: 312318
Join Date: Mar 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 Impreza Sport
ISM

Default

Quote:
Originally Posted by thom52 View Post
Elsewhere on this forum, the Visual Garage Shark Fin antenna seems to receive praise.
A bit spendy at $69, but its color matched to your car.

Catch is, I noticed on the site, that they only go up to 2009 Impreza for what they list as available. Not sure if its different for 2012.
http://visualgarage.com/

I am debating something like that. The stock antenna is pretty darn ugly.
I could be wrong, dosen't the Legacy have a shark fin antenna? Could get a color matching one if so.

Oh wow that's pretty easy (the VG shark) but not sure if it's worth 70 bucks. lol
Xarthan is offline   Reply With Quote
Old 07-02-2012, 08:42 AM   #12962
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by G-Omaha View Post
Cost...

I leave mine on; however, I also go to a touch-less wash facility.
My car wash facility is "touchless" too, but it still has these big moppy strips that hang down, and the car gets pushed through them. They don't spin, and they don't move side to side, but the antenna would get pressed against them.
sgoldste01 is offline   Reply With Quote
Old 07-02-2012, 09:15 AM   #12963
John451
Scooby Newbie
 
Member#: 321966
Join Date: Jun 2012
Location: Sydneys South, Australia
Vehicle:
2012 Impreza 2.0i H
Black Pearl

Default

Has anyone else noticed their Impreza CVT sounds a bit like a vacuum cleaner when reversing past them ?

Have read in a few areas where the CVT is naturally noisier than normal autos when under load ( it is ) but has anyone listed to one to one reversing past them that the CVT sounds moderately like vacuum cleaner from the outside, just wondering if it's normal ?
John451 is offline   Reply With Quote
Old 07-02-2012, 09:20 AM   #12964
SleepNMnky
Scooby Specialist
 
Member#: 302491
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Buffalo, NY
Vehicle:
2012 Impreza 2.0i Pr
Dark Grey Metallic CVT

Default

Quote:
Originally Posted by sgoldste01

My car wash facility is "touchless" too, but it still has these big moppy strips that hang down, and the car gets pushed through them. They don't spin, and they don't move side to side, but the antenna would get pressed against them.
I have the same type of touch less wash with the big, mop-like strips at Delta Sonic. I've gone through several time without removing my antenna & it's fine. I don't mind the look of the little antenna but wish it had a hinge so it could be bent downward like the 08-11 models have.

Last edited by SleepNMnky; 07-02-2012 at 09:41 AM.
SleepNMnky is offline   Reply With Quote
Old 07-02-2012, 03:03 PM   #12965
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by SleepNMnky

I have the same type of touch less wash with the big, mop-like strips at Delta Sonic. I've gone through several time without removing my antenna & it's fine. I don't mind the look of the little antenna but wish it had a hinge so it could be bent downward like the 08-11 models have.
The touchless car wash near me uses only high pressure water to clean the car so its truely touchless. It also uses filtered water for the rinse and forced air to dry so you get minimal water spots. It works surprisingly well.
jr0bb5 is online now   Reply With Quote
Old 07-02-2012, 03:16 PM   #12966
Furiousd1983
Scooby Newbie
 
Member#: 295099
Join Date: Sep 2011
Chapter/Region: South East
Location: Cackalack
Vehicle:
2013 Not so Hot HB

Default

Took the car back in to do the 2nd 1200 mile mark of the consumption test. The car went thru 1qt of oil in 2367 miles. Also while I was there I showed them the squeaky driver seat. Instead of waiting 3-4 months for a new seat back. They are going to give me a loaner when I go in for the final mark of the consumption test. They are going to open the seat up and fix the squeak with the DIY fix.
Furiousd1983 is online now   Reply With Quote
Old 07-02-2012, 03:29 PM   #12967
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by Furiousd1983
Took the car back in to do the 2nd 1200 mile mark of the consumption test. The car went thru 1qt of oil in 2367 miles. Also while I was there I showed them the squeaky driver seat. Instead of waiting 3-4 months for a new seat back. They are going to give me a loaner when I go in for the final mark of the consumption test. They are going to open the seat up and fix the squeak with the DIY fix.
Did the techs make any comments about your oil consumption? When I brought my car to the dealer because of oil consumption, they told me there was no test that they could perform to measure oil consumption. Guess they just really wanted me out of their hair.
jr0bb5 is online now   Reply With Quote
Old 07-02-2012, 03:34 PM   #12968
Furiousd1983
Scooby Newbie
 
Member#: 295099
Join Date: Sep 2011
Chapter/Region: South East
Location: Cackalack
Vehicle:
2013 Not so Hot HB

Default

I'm 2400 miles into a consumption test. SOA ordered it. The dealers hands are tied as the car only burn about 1/2qt of oil per 1200. That's about 1/2 what it needs to be for SOA to do anything about. As much as it blows. I'm going to have to carry extra oil with me or change it every 3000 miles to keep the low oil light off. (which aint happening!) In all honesty I'm not really sure what is my next move.
Furiousd1983 is online now   Reply With Quote
Old 07-02-2012, 04:20 PM   #12969
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by Furiousd1983 View Post
I'm 2400 miles into a consumption test. SOA ordered it. The dealers hands are tied as the car only burn about 1/2qt of oil per 1200. That's about 1/2 what it needs to be for SOA to do anything about. As much as it blows. I'm going to have to carry extra oil with me or change it every 3000 miles to keep the low oil light off. (which aint happening!) In all honesty I'm not really sure what is my next move.
i would start running a higher weight oil and see what that does for your consumption. I know people say it voids your warrenty but if it fixes the problem and they wont find out i dont see what the deal is.
auskip07 is offline   Reply With Quote
Old 07-02-2012, 04:35 PM   #12970
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by auskip07 View Post
i would start running a higher weight oil and see what that does for your consumption. I know people say it voids your warrenty but if it fixes the problem and they wont find out i dont see what the deal is.
assuming SOA is not going to do anything to help you saying 1 qt for 2400mi is ok, i agree with this suggestion. first try would be to just go for a heavier viscosity when cold, oil like 5w20 or 10w20. hopefully that will cure your problem. if not, step it up to a 5w30.
nubsub is online now   Reply With Quote
Old 07-02-2012, 05:01 PM   #12971
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by Furiousd1983
I'm 2400 miles into a consumption test. SOA ordered it. The dealers hands are tied as the car only burn about 1/2qt of oil per 1200. That's about 1/2 what it needs to be for SOA to do anything about. As much as it blows. I'm going to have to carry extra oil with me or change it every 3000 miles to keep the low oil light off. (which aint happening!) In all honesty I'm not really sure what is my next move.
I know how you feel. Personally, I may end up getting a different car. I like the Impreza and all, but I don't like it enough to keep it if its going to continue to consume oil at the rate it is. I will contact SOA eventually and see what they have to say, but if they tell me I just have to live with it, then I'll be shopping at one of their competitors.
jr0bb5 is online now   Reply With Quote
Old 07-02-2012, 05:04 PM   #12972
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by jr0bb5 View Post
I know how you feel. Personally, I may end up getting a different car. I like the Impreza and all, but I don't like it enough to keep it if its going to continue to consume oil at the rate it is. I will contact SOA eventually and see what they have to say, but if they tell me I just have to live with it, then I'll be shopping at one of their competitors.
You would rather get a whole new car than to try out a higher weight oil?
auskip07 is offline   Reply With Quote
Old 07-02-2012, 05:28 PM   #12973
Furiousd1983
Scooby Newbie
 
Member#: 295099
Join Date: Sep 2011
Chapter/Region: South East
Location: Cackalack
Vehicle:
2013 Not so Hot HB

Default

Well, I was gonna type out a message about waiting to see what SOA had to say and Chris @ SOA called me.

As I fully expected "something something within tolerances. Something something keep an eye on the dipstick.". Frustrating. Ill talk to the dealer about running a 5w in the next cycle if that won't dick with my warranty. I'm not going to take a hit by dumping the car just because of this. I'll just be unhappy until something comes along in the future.
Furiousd1983 is online now   Reply With Quote
Old 07-02-2012, 05:30 PM   #12974
TObject
Scooby Newbie
 
Member#: 320185
Join Date: May 2012
Vehicle:
2012 Impreza 2.0i

Default

There is also RedLine 0W20 motor oil, which is officially 0W20, but is more like light 30-weight oil.
TObject is offline   Reply With Quote
Old 07-02-2012, 05:39 PM   #12975
Furiousd1983
Scooby Newbie
 
Member#: 295099
Join Date: Sep 2011
Chapter/Region: South East
Location: Cackalack
Vehicle:
2013 Not so Hot HB

Default

Quote:
Originally Posted by TObject
There is also RedLine 0W20 motor oil, which is officially 0W20, but is more like light 30-weight oil.
For the time being. I'm not doing anything outside of subaru's normal recommendations. That way there's nothing they can say when/if a warranty claim pops up.
Furiousd1983 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Impreza STI concept art khaki_man Member's Car Gallery 37 03-15-2011 02:02 AM
Newsflash: 2012 Impreza looks like BigElm's Butt WagonMonster Off-Topic 4 02-28-2011 07:11 PM
2012 Impreza Concept Zakster87 General Community 14 11-17-2010 04:09 PM
Possibly looking into a 2011 or 2012 Impreza? xenonk Mid Atlantic Impreza Club -- MAIC 1 08-05-2010 09:48 PM


All times are GMT -4. The time now is 12:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.