Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-05-2013, 07:17 PM   #18626
garamas
Scooby Newbie
 
Member#: 169194
Join Date: Jan 2008
Chapter/Region: SCIC
Location: Ballin Park
Vehicle:
04 STI
WRB

Default

all those cars have modified hubs to get crazy camber most have setups like this



for anyone running any wheel larger then a 8.5 the car will camber enough to fit a 9.5 with out having to get camber plates/adj LCA's

but theres no way u can run 0 camber with a 9.5 wheel so thats why his car sits like that
* Registered users of the site do not see these ads.
garamas is offline   Reply With Quote
Old 08-05-2013, 10:52 PM   #18627
ST Eye
Scooby Specialist
 
Member#: 73068
Join Date: Oct 2004
Location: MD
Vehicle:
2008 STI Boost Wagon
2014 Honda Accord Hybrid

Default

I used to run -3.5 degrees of camber in the front on my STI when I was autocrossing it. The aggressive camber really gave good turn in response and the contact patch was larger when the wheel was turned.
ST Eye is offline   Reply With Quote
Old 08-06-2013, 01:10 AM   #18628
Vjaramillo
Scooby Newbie
 
Member#: 359666
Join Date: Jun 2013
Location: California
Vehicle:
2013 Impreza limited
Ice silver

Default

Hey Dijma...I was thinking of doing the same thing for the roof. Black carbon fiber wrap but wasn't sure how it would look like. What are your thoughts on carbon wrapping the boot, roof and hood. Anyone have any thoughts.
Vjaramillo is offline   Reply With Quote
Old 08-06-2013, 08:44 AM   #18629
foghelmut
Scooby Newbie
 
Member#: 328414
Join Date: Aug 2012
Location: South Jersey
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

I prefer wood grain wrap.
foghelmut is offline   Reply With Quote
Old 08-06-2013, 09:29 AM   #18630
Dirt Bringer
Scooby Newbie
 
Member#: 340297
Join Date: Dec 2012
Chapter/Region: MWSOC
Location: Cincinnati
Vehicle:
2013 Impreza 5sp Prm
Ice Silver

Default Spring Ride Quality Swap

So someone recently confirmed that our Impreza shares struts with the 08 series WRX, such that springs and struts from that specific series are interchangeable. I was looking at stiffening the ride up slightly, as it feels a bit too soft and comfort oriented for my tastes. Does anyone know the spring rate on the stock springs and the 08 WRX springs? I was wondering if swapping out for WRX springs might improve the ride somewhat. I also heard that swapping springs shortens strut life. Is that because the ride height is lowered or because the springs overdrive the struts?
Dirt Bringer is offline   Reply With Quote
Old 08-06-2013, 11:23 AM   #18631
Dijm8
Scooby Newbie
 
Member#: 337144
Join Date: Nov 2012
Chapter/Region: International
Location: Adelaide, Australia
Vehicle:
2012 Impreza Hatch
Ice Silver

Default

Quote:
Originally Posted by Vjaramillo View Post
Hey Dijma...I was thinking of doing the same thing for the roof. Black carbon fiber wrap but wasn't sure how it would look like. What are your thoughts on carbon wrapping the boot, roof and hood. Anyone have any thoughts.
only reason i wanna carbon wrap my roof is to match the front lip, i think either way, its going to look good..hopefully next month ill have it done, (cost around $4-500 here in Australia for just the roof)
Dijm8 is offline   Reply With Quote
Old 08-06-2013, 07:04 PM   #18632
G2Spfld
Scooby Specialist
 
Member#: 354284
Join Date: Apr 2013
Location: Midwest
Vehicle:
2013 Imp Sport CVT
SWP

Default

Quote:
Originally Posted by Dijm8 View Post

only reason i wanna carbon wrap my roof is to match the front lip, i think either way, its going to look good..hopefully next month ill have it done, (cost around $4-500 here in Australia for just the roof)
I'm wrapping an impreza sport for the business. Thinking about doing the full 3M Carbon Wrap then add business logo. That way its cool looking and when I cycle cars every few years I can unwrap it for nice clean paint for the sale. I wanted to know if anyone here has experience with the full 3M wrap
G2Spfld is offline   Reply With Quote
Old 08-07-2013, 05:33 PM   #18633
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

So off and on for the past month sometimes while braking my Abs, traction light, and hill holder assist light all come on at the same time and stay on until i restart the car. Whats going on? Car performs totally normal while lights are on. I usually will stop...restart and the lights go away until the next time i press on the brakes.
n00b on demand is offline   Reply With Quote
Old 08-07-2013, 07:13 PM   #18634
soobie doo
Scooby Newbie
 
Member#: 324017
Join Date: Jun 2012
Location: Philly Burbs
Vehicle:
2012 Impreza 2.0i
Ice Silver Metallic

Default

Quote:
Originally Posted by n00b on demand View Post
So off and on for the past month sometimes while braking my Abs, traction light, and hill holder assist light all come on at the same time and stay on until i restart the car. Whats going on? Car performs totally normal while lights are on. I usually will stop...restart and the lights go away until the next time i press on the brakes.
No idea, but I'd guess there's a problem with one of your wheel speed sensors or the computer that controls the brakes for those functions. You probably oughtta just take it into the dealer. But next time it happens, try seeing if the hill holder still functions. Or the ABS and traction control, if you're on a loose surface and/or feeling adventurous.
soobie doo is offline   Reply With Quote
Old 08-07-2013, 10:11 PM   #18635
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Quote:
Originally Posted by soobie doo View Post
No idea, but I'd guess there's a problem with one of your wheel speed sensors or the computer that controls the brakes for those functions. You probably oughtta just take it into the dealer. But next time it happens, try seeing if the hill holder still functions. Or the ABS and traction control, if you're on a loose surface and/or feeling adventurous.
will do. Its so finicky...cant get it to happen whenever i want...just happens randomly. Ive noticed that when it does happen its when i brake hard.
n00b on demand is offline   Reply With Quote
Old 08-08-2013, 08:12 AM   #18636
sharco
Scooby Newbie
 
Member#: 334052
Join Date: Oct 2012
Location: Scranton/Pittsburgh PA
Vehicle:
04 STI
WRB

Default

Recently sold my 2012 Impreza, if anyone is looking for roof racks, factory subwoofer, all weather trunk mat, or a 2011 STI 19mm rear sway bar feel free to PM me.

link to thread
sharco is online now   Reply With Quote
Old 08-10-2013, 09:43 PM   #18637
KickPaintz
Scooby Newbie
 
Member#: 363043
Join Date: Jul 2013
Default

Quote:
Originally Posted by sharco View Post
Recently sold my 2012 Impreza, if anyone is looking for roof racks, factory subwoofer, all weather trunk mat, or a 2011 STI 19mm rear sway bar feel free to PM me.

link to thread
How much for the racks
KickPaintz is offline   Reply With Quote
Old 08-11-2013, 02:04 AM   #18638
Dijm8
Scooby Newbie
 
Member#: 337144
Join Date: Nov 2012
Chapter/Region: International
Location: Adelaide, Australia
Vehicle:
2012 Impreza Hatch
Ice Silver

Default

some pics from over the weekend



subi stance port adel by Dijm8, on Flickr


subi stance port adel 2 by Dijm8, on Flickr


subi stance port adel 3 by Dijm8, on Flickr


subi stance port adel 4 by Dijm8, on Flickr
Dijm8 is offline   Reply With Quote
Old 08-11-2013, 02:18 AM   #18639
garamas
Scooby Newbie
 
Member#: 169194
Join Date: Jan 2008
Chapter/Region: SCIC
Location: Ballin Park
Vehicle:
04 STI
WRB

Default

looks good man needs more low tho
garamas is offline   Reply With Quote
Old 08-11-2013, 02:19 AM   #18640
Dijm8
Scooby Newbie
 
Member#: 337144
Join Date: Nov 2012
Chapter/Region: International
Location: Adelaide, Australia
Vehicle:
2012 Impreza Hatch
Ice Silver

Default

Quote:
Originally Posted by garamas View Post
looks good man needs more low tho
going for a service end of the month, so it'll get a touch more lower then
Dijm8 is offline   Reply With Quote
Old 08-11-2013, 12:23 PM   #18641
apexracer
Scooby Newbie
 
Member#: 257754
Join Date: Sep 2010
Chapter/Region: NWIC
Location: Vancouver
Vehicle:
2012 Impreza Sport P
Camilla Red Pearl

Default

Quote:
Originally Posted by n00b on demand View Post
So off and on for the past month sometimes while braking my Abs, traction light, and hill holder assist light all come on at the same time and stay on until i restart the car. Whats going on? Car performs totally normal while lights are on. I usually will stop...restart and the lights go away until the next time i press on the brakes.
You've blown a fuse. It's on the right (separate) side of the main fuse block in the dash. I think fifth from the bottom. 7.5 amp fuse. It's the fuse you disable to turn off VDC.
apexracer is offline   Reply With Quote
Old 08-11-2013, 12:31 PM   #18642
apexracer
Scooby Newbie
 
Member#: 257754
Join Date: Sep 2010
Chapter/Region: NWIC
Location: Vancouver
Vehicle:
2012 Impreza Sport P
Camilla Red Pearl

Default

Quote:
Originally Posted by n00b on demand View Post
So off and on for the past month sometimes while braking my Abs, traction light, and hill holder assist light all come on at the same time and stay on until i restart the car. Whats going on? Car performs totally normal while lights are on. I usually will stop...restart and the lights go away until the next time i press on the brakes.
I cut a ring connector and filed it to match as much as I could to the fuse. Better Option is the GTC fuse connector These are the lights that come on when you flip the switch and apply the brake. You also lose cruise control, but you don't need it anyway when this is activated. Inline fuse, one end to fuse slot, other side to switch (RED). All black wire is straight from the switch to the fuse slot. Left is inline fuse wire, right side is straight wire to switch. Doesn't matter what sides you use by the way. This is the switch, I'd recommend just a plain switch or some OEM subaru switch you could pop in. The light function doesn't work like you'd want it to. If I grounded the switch the light would come on when I pressed the brake (pointless).
apexracer is offline   Reply With Quote
Old 08-11-2013, 03:59 PM   #18643
garamas
Scooby Newbie
 
Member#: 169194
Join Date: Jan 2008
Chapter/Region: SCIC
Location: Ballin Park
Vehicle:
04 STI
WRB

Default

Sorry I must have missed something but what does the wiring you did there do for the car??
garamas is offline   Reply With Quote
Old 08-11-2013, 04:17 PM   #18644
apexracer
Scooby Newbie
 
Member#: 257754
Join Date: Sep 2010
Chapter/Region: NWIC
Location: Vancouver
Vehicle:
2012 Impreza Sport P
Camilla Red Pearl

Default

Quote:
Originally Posted by garamas View Post
Sorry I must have missed something but what does the wiring you did there do for the car??
. It was a reply to the guy with the lights going off on his dash. There's a pic in there that shows the location of said fuse. As well, it's a DIY post on how to disable vdc with fuse bypass switch.
apexracer is offline   Reply With Quote
Old 08-11-2013, 05:18 PM   #18645
garamas
Scooby Newbie
 
Member#: 169194
Join Date: Jan 2008
Chapter/Region: SCIC
Location: Ballin Park
Vehicle:
04 STI
WRB

Default

ohh nice ok i was thinking something else...

is there a write up to enable the foglights to be on with driving lights?
garamas is offline   Reply With Quote
Old 08-11-2013, 08:20 PM   #18646
ronjr8102
Scooby Newbie
 
Member#: 216040
Join Date: Jul 2009
Chapter/Region: NESIC
Location: Worcester, MA
Vehicle:
2013 Impreza 2.0i5dr
dark metallic grey

Default

Quote:
Originally Posted by sharco View Post
Recently sold my 2012 Impreza, if anyone is looking for roof racks, factory subwoofer, all weather trunk mat, or a 2011 STI 19mm rear sway bar feel free to PM me.

link to thread
PMed u
ronjr8102 is offline   Reply With Quote
Old 08-13-2013, 08:05 AM   #18647
foghelmut
Scooby Newbie
 
Member#: 328414
Join Date: Aug 2012
Location: South Jersey
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

Last night, I filled up my tank. The fuel gauge didn't fill up. I turned the car off and on several times. This morning, I started the car and the fuel gauge was full. I dropped it off at the dealer for a separate check engine light, and the service department guy said that it was a normal complaint but wasn't an issue. Uhhhh???? What?
foghelmut is offline   Reply With Quote
Old 08-13-2013, 08:16 AM   #18648
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

did you leave the key in the ignition switch while pumping gas?
79letour is offline   Reply With Quote
Old 08-13-2013, 08:24 AM   #18649
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by 79letour View Post
did you leave the key in the ignition switch while pumping gas?
Or more specifically, did you leave the key in the ignition with the engine off but the key in the RUN position with all of the dashboard lights lit?

Simply leaving the key in the ignition while pumping gas but with the dashboard powered off is normal and certainly not a problem.
sgoldste01 is offline   Reply With Quote
Old 08-13-2013, 09:00 AM   #18650
foghelmut
Scooby Newbie
 
Member#: 328414
Join Date: Aug 2012
Location: South Jersey
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

I turn the car fully off with the key still in when its being filled. I live in NJ and we are all dumb babies here who aren't allowed to pump our own gas.

I started it up, and the fuel gauge had only one bar. Then I turned it off, and started it again, and it was still listing as empty. The fuel light on and everything. I was late for my softball game, so I just drove there. We had a double header, so my car sat in the parking lot for 3 hours turned off.

When I left, the fuel gauge had bumped up from 1 bar to 2 bars. I drove home. When I started it this morning, all of the bars were full.

The service guy said it was a "common complaint" and that it had to do with the sensors needing time to reset themselves, which sounds really weird, and that I shouldn't worry about it.

So either they really don't think it's a big deal, or they don't know how to fix it, or they're trying not to have to do work under warranty.
foghelmut is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Impreza STI concept art khaki_man Member's Car Gallery 37 03-15-2011 02:02 AM
Newsflash: 2012 Impreza looks like BigElm's Butt WagonMonster Off-Topic 4 02-28-2011 07:11 PM
2012 Impreza Concept Zakster87 General Community 14 11-17-2010 04:09 PM
Possibly looking into a 2011 or 2012 Impreza? xenonk Mid Atlantic Impreza Club -- MAIC 1 08-05-2010 09:48 PM


All times are GMT -4. The time now is 11:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.