Welcome to the North American Subaru Impreza Owners Club Friday May 6, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-13-2013, 10:48 AM   #18651
jay25RS
Scooby Specialist
 
Member#: 4273
Join Date: Feb 2001
Chapter/Region: NESIC
Location: CT
Vehicle:
2015 Taco
& 2015 Legacy Ltd.

Default

Quote:
Originally Posted by foghelmut View Post
I turn the car fully off with the key still in when its being filled. I live in NJ and we are all dumb babies here who aren't allowed to pump our own gas.

I started it up, and the fuel gauge had only one bar. Then I turned it off, and started it again, and it was still listing as empty. The fuel light on and everything. I was late for my softball game, so I just drove there. We had a double header, so my car sat in the parking lot for 3 hours turned off.

When I left, the fuel gauge had bumped up from 1 bar to 2 bars. I drove home. When I started it this morning, all of the bars were full.

The service guy said it was a "common complaint" and that it had to do with the sensors needing time to reset themselves, which sounds really weird, and that I shouldn't worry about it.

So either they really don't think it's a big deal, or they don't know how to fix it, or they're trying not to have to do work under warranty.
The only time that this happened to me is when I turned my key to the ACC position from OFF while fueling up.
* Registered users of the site do not see these ads.
jay25RS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-13-2013, 04:11 PM   #18652
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Hanging out at dealer, hoping they at least clean my a/c since it stinks.

Complaints:
1. Weak, hardly can keep up when 90+ even with tinted Windows and recirc mode on.
2. Stinks
flyboy1100 is online now   Reply With Quote
Old 08-13-2013, 04:50 PM   #18653
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by flyboy1100 View Post
Hanging out at dealer, hoping they at least clean my a/c since it stinks.

Complaints:
1. Weak, hardly can keep up when 90+ even with tinted Windows and recirc mode on.
2. Stinks
Warranty doesn't cover odors I guess, so I am buying the kit and bringing it home.

They also said the air bring output on fan 2 w/ recirc on is 41f, and the minimum spec per Subaru is 52f
flyboy1100 is online now   Reply With Quote
Old 08-13-2013, 04:50 PM   #18654
foghelmut
Scooby Newbie
 
Member#: 328414
Join Date: Aug 2012
Location: Southern California
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

In 90+, I have to have the AC fan on at least 3, after 20 minutes I can go down to 2 sometimes. These cars are greenhouses.
foghelmut is offline   Reply With Quote
Old 08-13-2013, 04:55 PM   #18655
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by foghelmut View Post
In 90+, I have to have the AC fan on at least 3, after 20 minutes I can go down to 2 sometimes. These cars are greenhouses.
That sounds about right. On my last roadtrip I hadn't even noticed the temp rose from 77 to 94 over about 30 minutes until I saw the temp display. But that was after about 8 hours of driving. 1 with recirc was more than adequate.

It just seems on the short trips (less than 30min) I have problems.

Oh well I will get over it
flyboy1100 is online now   Reply With Quote
Old 08-13-2013, 05:13 PM   #18656
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by flyboy1100 View Post
That sounds about right. On my last roadtrip I hadn't even noticed the temp rose from 77 to 94 over about 30 minutes until I saw the temp display. But that was after about 8 hours of driving. 1 with recirc was more than adequate.

It just seems on the short trips (less than 30min) I have problems.

Oh well I will get over it
i'm slowly learning that maybe i should have reconsidered my thought on have a dark interior car, not to mention the DGM paint not helping either.

are you in Premium Sport? how many fan speeds do you have?

i have many (8?) on the Limited and the first 4 don't do much if the car has been sitting in the sun. but i do agree: for all cars i've owned, there is no problem keeping up with hot weather if it starts and stays cool. the problem is if you let it bake in the sun and then try to cool it off.

my strategy which always works is to keep all the windows rolled down initially to flush out that hot air that has accumulated and wait until i feel cold air coming through the vents using "non-recirc" mode at max fan. then, i close the windows and after a little while, hit the recirc button to get the full max cooling effect. it still takes a while though (10-15min until its comfortable and i can back off the fan), but i have had that work on a 100+ oF day after the car had been sitting for several hours.
nubsub is offline   Reply With Quote
Old 08-13-2013, 06:25 PM   #18657
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

I see best performance with the fan on 2 and recirculation mode. Speeds 3 and 4 move more air, but the vent temps start to rise.

Mine used to stink. Try changing the cabin filter to something that will resist mold. Also avoid running the A/C with fresh air mode. I never use the defog mode for this reason. Running the A/C with recirculation mode does just as well.
Commander Keen is offline   Reply With Quote
Old 08-13-2013, 07:25 PM   #18658
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by Commander Keen View Post
I see best performance with the fan on 2 and recirculation mode. Speeds 3 and 4 move more air, but the vent temps start to rise.

Mine used to stink. Try changing the cabin filter to something that will resist mold. Also avoid running the A/C with fresh air mode. I never use the defog mode for this reason. Running the A/C with recirculation mode does just as well.
I have a new cabin filter, that isn't the problem. The smell only comes when ac is enabled.

I bought the Subaru ac cleaner kit and will do it tomorrow when I rotate my tires as you need the front off the ground to really access the evap drain.

And I have a sport premium dgm w/ black interior, 4 fan speeds

I also have the Subaru windshield visor and use it when I park in the sun, it helps, but still takes a while to get the residual heat out.

Last edited by flyboy1100; 08-13-2013 at 09:17 PM.
flyboy1100 is online now   Reply With Quote
Old 08-14-2013, 09:09 AM   #18659
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

What were the wiper sizes again? 24 & 16?

My car is at home so I can't just go measure it...
flyboy1100 is online now   Reply With Quote
Old 08-14-2013, 09:26 AM   #18660
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by flyboy1100 View Post
What were the wiper sizes again? 24 & 16?

My car is at home so I can't just go measure it...
You actually want 26 and 16. 24 will work, but 26 fits and will give you more wiping coverage.
sgoldste01 is offline   Reply With Quote
Old 08-14-2013, 10:21 AM   #18661
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by sgoldste01 View Post

You actually want 26 and 16. 24 will work, but 26 fits and will give you more wiping coverage.
Thanks. I'm gong to try Goodyear blades
flyboy1100 is online now   Reply With Quote
Old 08-14-2013, 11:09 AM   #18662
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

This is the blade I'm currently running:

http://www.amazon.com/gp/product/B007TG7IJY/ref=oh_details_o00_s00_i01?ie=UTF8&psc=1http://www.amazon.com/gp/product/B007TG7IJY/ref=oh_details_o00_s00_i01?ie=UTF8&psc=1


Disregard Amazon's product compatibility database, which says the 26" blade doesn't fit on our Imprezas.
sgoldste01 is offline   Reply With Quote
Old 08-14-2013, 11:56 AM   #18663
lumpy
Scooby Specialist
 
Member#: 28410
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: Cleveland, OH
Vehicle:
2012 Impreza Sport
SWP

Default

Quote:
Originally Posted by flyboy1100 View Post
I bought the Subaru ac cleaner kit and will do it tomorrow when I rotate my tires as you need the front off the ground to really access the evap drain.

I used this on my Baja. It was a piece of cake to do and it worked well.
lumpy is offline   Reply With Quote
Old 08-14-2013, 12:21 PM   #18664
79letour
*** Banned ***
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I will be picking up one of these down the road. I use the ac a lot. Usually on 4, then after ten mins or so down to 2.
my Impreza had a very musty smellimg ac system since it was practically new.
So far so good with the XV. Still smells new. This car has an extra
dank new car smell to it. I do love the new car smell. Its addictive.
79letour is offline   Reply With Quote
Old 08-14-2013, 01:08 PM   #18665
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by lumpy View Post

I used this on my Baja. It was a piece of cake to do and it worked well.
I learned 4 things this morning......

1. Do NOT use entire can, it will flood out everything and leak all over your carpet
2. It smells like Resolve carpet cleaner and those areas of my carpet are now very clean.


And for those who complain the vents are loud on high fan settings..

3. The fan itself moves a lot of air, and when on the highest settings it is loud. It also dries the carpet nicely when removed from housing to dry off (I'm hoping the actual motor didn't get wet, doesn't appear to have)

4. Fan removal/installation is very easy in this car
flyboy1100 is online now   Reply With Quote
Old 08-14-2013, 01:27 PM   #18666
79letour
*** Banned ***
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

my fan only makes whining/whistling noise on 3. odd.
Good thing 4 and 2 are where its at.
79letour is offline   Reply With Quote
Old 08-14-2013, 01:54 PM   #18667
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

sorry for the lines on the first pic, the camera did it and i don't know why, didn't notice it until it was on the computer



and what came out of the evap, this stuff went in perfectly clear and came out like this, and this is only after 1.3 years of use/29,000 miles



so far, it smells much better, and I will replace the cabin filter tomorrow too, it is dusty, but no mildew/mold i can see on it.
flyboy1100 is online now   Reply With Quote
Old 08-14-2013, 02:05 PM   #18668
79letour
*** Banned ***
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

nice post! thanks man!
79letour is offline   Reply With Quote
Old 08-14-2013, 02:18 PM   #18669
myrt1987
Scooby Specialist
 
Member#: 323103
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Maple Shade NJ
Vehicle:
2012 Limited 2.0i
Dreamy Gray Mistress

Default

flyboy, product? price? level of difficulty involved?
myrt1987 is offline   Reply With Quote
Old 08-14-2013, 02:31 PM   #18670
Xafen
Scooby Newbie
 
Member#: 306398
Join Date: Jan 2012
Location: Omaha, NE
Vehicle:
2012 Impreza Premium
Camellia Red

Default

And link to where you got it from!
Xafen is offline   Reply With Quote
Old 08-14-2013, 03:12 PM   #18671
LGA2011
Scooby Newbie
 
Member#: 321173
Join Date: May 2012
Default

Quote:
Originally Posted by flyboy1100 View Post
What were the wiper sizes again? 24 & 16?

My car is at home so I can't just go measure it...
You can always go at the dealer & only change the Teflon.
LGA2011 is offline   Reply With Quote
Old 08-14-2013, 03:26 PM   #18672
fistv
Scooby Newbie
 
Member#: 350063
Join Date: Mar 2013
Location: Effort Pa
Vehicle:
2013 Impreza sport
White

Default

Quote:
Originally Posted by nubsub View Post
i'm slowly learning that maybe i should have reconsidered my thought on have a dark interior car, not to mention the DGM paint not helping either.

are you in Premium Sport? how many fan speeds do you have?

i have many (8?) on the Limited and the first 4 don't do much if the car has been sitting in the sun. but i do agree: for all cars i've owned, there is no problem keeping up with hot weather if it starts and stays cool. the problem is if you let it bake in the sun and then try to cool it off.

my strategy which always works is to keep all the windows rolled down initially to flush out that hot air that has accumulated and wait until i feel cold air coming through the vents using "non-recirc" mode at max fan. then, i close the windows and after a little while, hit the recirc button to get the full max cooling effect. it still takes a while though (10-15min until its comfortable and i can back off the fan), but i have had that work on a 100+ oF day after the car had been sitting for several hours.
I always leave my front windows cracked when I park in the morning at work, just a 1/2 inch but it's enough to let the super heated stuff out.
fistv is offline   Reply With Quote
Old 08-14-2013, 03:56 PM   #18673
jay25RS
Scooby Specialist
 
Member#: 4273
Join Date: Feb 2001
Chapter/Region: NESIC
Location: CT
Vehicle:
2015 Taco
& 2015 Legacy Ltd.

Default

Quote:
Originally Posted by flyboy1100 View Post
Hanging out at dealer, hoping they at least clean my a/c since it stinks.

Complaints:
1. Weak, hardly can keep up when 90+ even with tinted Windows and recirc mode on.
2. Stinks
1. I think my Impreza Sport has a great A/C system and is icy cold. I thought the same about my STI compared to my '06 WRX and my Impreza is even more powerful than the STI's.

2. I've used the 1Z Einszett Klima Cleaner A/C odor and Bacteria cleaner on my 1998 Outback that had a funky smell to it. This fixed the problem and left behind a pleasant apple scent! http://www.detailersdomain.com/1Z-ei...aner_p_78.html
jay25RS is offline   Reply With Quote
Old 08-14-2013, 04:07 PM   #18674
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by myrt1987 View Post
flyboy, product? price? level of difficulty involved?

SOA868V9315, 19.95 + tax at my local dealer. it is hazmat so AFAIK none of the online sellers will ship this one. MAKE SURE YOU GET THE HOSE! the larger can come exactly as in the picture, so w/o the hose i don't know how you would realistically spray this stuff


Difficulty? 1.5/10 as long as you only spray 1/2 the can, let it drain, then spray the other 1/2. if you spray it all at once and then have to remove the blower I would say 2/10.

the only thing i did other than what the directions on the can say to do is pull the drain tube out of the clip and spray from the top of the engine bay. otherwise follow the directions

and to disable the compressor just unclip the single wire on top of it
flyboy1100 is online now   Reply With Quote
Old 08-14-2013, 04:09 PM   #18675
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by LGA2011 View Post
You can always go at the dealer & only change the Teflon.
i already had them replaced under warranty, they are just as crappy as before no way i would pay the nearly 30-40.00 price for the refills
flyboy1100 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Impreza STI concept art khaki_man Member's Car Gallery 37 03-15-2011 02:02 AM
Newsflash: 2012 Impreza looks like BigElm's Butt WagonMonster Off-Topic 4 02-28-2011 07:11 PM
2012 Impreza Concept Zakster87 General Community 14 11-17-2010 04:09 PM
Possibly looking into a 2011 or 2012 Impreza? xenonk Mid Atlantic Impreza Club -- MAIC 1 08-05-2010 09:48 PM

All times are GMT -4. The time now is 05:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.