Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-09-2011, 10:10 AM   #1
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Question Starting/stalling and rough idle issues

2003 Baja 2.5SOHC Manual Transmission 195k miles. Head gaskets, oil seals, spark plugs, timing belt, fuel filter, water pump, engine oil, oil filter all replaced about 5k miles ago.

This week I started experiencing problems starting the engine. The first day, teh car sat at work for 8 hours. Drove to work just fine and started up just fine that morning. After work, cold start, engine cranks but does not start. Gave it 30 seconds between each attempt. Lights and acc. all working and bright, so not a battery problem, and the engine cranks/turns over. After about 5 minutes, it starts up as if nothing is wrong. No CEL, no codes.

The next day, starts up perfectly first thing in the morning, starts up again that evening after work no problem. Got home, ate dinner, went to leave for my second job, engine not hot but still warm, engine feels like its going to stall but stays running and drives fine. Noticing on my way to work that the idle is fluctuating at stoplights but otherwise runs and drives fine. No CEL, no codes.

Next day starts up fine in the morning, but after picking up my son at daycare and then restarting the engine (still hot) it stalls completely, but starts up on the second attempt but will only stay running if I keep my foot on the gas. Once I get on the road it runs fine and doesnt need intervention to keep running at idle. Again, no CEL, no codes.

From the research I have done, I am thinking its the coil pack, fuel pump, or IACV. I recently cleaned the IACV (5k miles ago) and the plug wires were replaced last year.

I am out of ideas, and I know without a CEL or codes a mechanic is just going to be able to take guesses and throw parts at it. I'd rather try to diagnose it myself.

Thanks!!
* Registered users of the site do not see these ads.
Samirr76 is offline   Reply With Quote
Old 02-09-2011, 10:11 AM   #2
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

Oh yeah it did it again this morning on a cold start. Stalled on the first attempt but was fine after restarting.
Samirr76 is offline   Reply With Quote
Old 02-09-2011, 10:53 AM   #3
T Wrex--OH
Scooby Specialist
 
Member#: 179478
Join Date: May 2008
Chapter/Region: MWSOC
Location: Cleveland<OH>
Vehicle:
2000 Impreza 2.5 RS
Sedona Red Pearl

Default

I have a hunch, cheap part to replace. Camshaft posistion sensor.
T Wrex--OH is offline   Reply With Quote
Old 02-09-2011, 10:55 AM   #4
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

I thought of that too...but why wouldnt it throw a CEL/DTC?
Samirr76 is offline   Reply With Quote
Old 02-09-2011, 08:02 PM   #5
T Wrex--OH
Scooby Specialist
 
Member#: 179478
Join Date: May 2008
Chapter/Region: MWSOC
Location: Cleveland<OH>
Vehicle:
2000 Impreza 2.5 RS
Sedona Red Pearl

Default

I read it again and retract my previous statement. ha ha

Could be a vacuum leak.
T Wrex--OH is offline   Reply With Quote
Old 02-09-2011, 08:43 PM   #6
Wrencher86
Scooby Newbie
 
Member#: 250463
Join Date: Jun 2010
Location: Evanston, Il
Vehicle:
2010 Impreza 2.5i
Silver

Default

Quote:
Originally Posted by Samirr76 View Post
I am out of ideas, and I know without a CEL or codes a mechanic is just going to be able to take guesses and throw parts at it. I'd rather try to diagnose it myself.

Thanks!!
Then your mechanic sucks.

Kind of sounds like a fueling problem. Intermittently stuck injector maybe. Maybe a fuel pump. Things like this are tricky, especially when you don't have the car in front of you. Any shop worth its salt should be able to run some tests and figure it out. At the very least start heading in the right direction.
Wrencher86 is offline   Reply With Quote
Old 02-09-2011, 09:52 PM   #7
T Wrex--OH
Scooby Specialist
 
Member#: 179478
Join Date: May 2008
Chapter/Region: MWSOC
Location: Cleveland<OH>
Vehicle:
2000 Impreza 2.5 RS
Sedona Red Pearl

Default

Here's straight out of the FSM for engine stalling during idling:

1) Idle air control solenoid valve
2) Mass air flow sensor
3) Intake manifold pressure sensor
4) Intake air temperature sensor
5) Ignition parts
6) Engine coolant temperature sensor
7) Crankshaft position sensor
8) Camshaft position sensor
9) Fuel injection parts

With #1 being the most likely, #9 being the least likely.


Hope this helps you!
T Wrex--OH is offline   Reply With Quote
Old 02-09-2011, 10:00 PM   #8
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

Yeah im tired of guessing.....and im not a fan of throwing parts at a problem either. I'll swing by the repair shop. I am leaning towards some type of fueling problem too though. I thought a bad fuel pump would affect the engine at all times not just when starting. And a bad injector I would think would most certainly throw a misfire code/CEL.
Samirr76 is offline   Reply With Quote
Old 02-09-2011, 10:03 PM   #9
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

Thanks T!
Samirr76 is offline   Reply With Quote
Old 02-11-2011, 10:38 AM   #10
Samirr76
Scooby Guru
 
Member#: 4835
Join Date: Mar 2001
Chapter/Region: Tri-State
Location: Fl33tw00d, PA
Vehicle:
2003 Baja 5MT
Yellow w/ 220,000 miles

Default

One thing I did not mention is that right before this issue began, I had filled up on gas about 30-40 miles prior, Sunoco 87 octane. Could a bad tank of gas cause stalling issues without and driveability issues or loss in MPG? So far the MPG has not changed, and currently at about 300 miles on the same tank.
Samirr76 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stalling and rough idling issue nJDMmaster Factory 2.0L Turbo Powertrain 9 08-20-2008 11:46 AM
Rough idle issue solved via TSB sticky!!! Gregmatic Baja Forum 0 03-07-2006 11:49 PM
stumble on cold start with CIL rough idle Deity Normally Aspirated Powertrain 7 11-05-2004 02:44 PM
Hard starts and rough idle Brooke Legacy Forum 3 12-12-2003 07:00 PM
help/comments w/rough idle issues? Benjamin Tang Legacy Forum 14 10-01-2003 05:55 AM


All times are GMT -4. The time now is 09:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.