Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-11-2002, 06:45 PM   #1
AudioFan
Scooby Newbie
 
Member#: 1380
Join Date: Apr 2000
Location: Maracaibo, Zulia, Venezuela
Vehicle:
2005 SRT4
Orange Blast

Default Power chips and Ignition?

I had some problem with my car, so I took it to the mechanich, Took the ProECM out, so That they wonīt say that it was the reason of the problem.

I had 2 spark plugs wires really bad, So new set had to come, but I also had to replace the ignition coil? that thing that is up in the motor where the cables get connected (coil tower, I think). they told me that since the cables were bad, The ignition/spark wasnīt happening where it should. Could this be true? Well this is not the real question, because I already replaced both things, and my car is runnnig like it should

The question is, Could the chip ProECM, since it is said to change and play with fuel and timing, have caused this problem?

I need sincere answer. Iīm debating inside me wheter to put the chip back on or not! The chip really made a difference, I felt it when I installed, and now that it is not connected, I can also feel how the car is "slower". But I donīt want to spend another (around $250 for parts plus labor) for just weeks or months of more "fun" in my car.

Thanks for your replys.
* Registered users of the site do not see these ads.
AudioFan is offline   Reply With Quote
Old 07-12-2002, 09:47 AM   #2
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

Personally.....I don't see how the chip could cause that. As the chip doesn't do anything to raise ignition juice and such. I would say it's more or less a coincidence.
Legacy777 is offline   Reply With Quote
Old 07-12-2002, 04:36 PM   #3
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

The ProECM does advance the ignition timing but that has nothing to do with life expectancy of the coil/wires/plugs... just changes the timing of the ignition event. As for bad coil pack/bad wires, I know several RS owners that have had coils and wires fail (myself included). If they were stock then it was just probably normal wear.
BOY is offline   Reply With Quote
Old 07-12-2002, 05:08 PM   #4
jeffg
Scooby Guru
 
Member#: 2958
Join Date: Nov 2000
Chapter/Region: NWIC
Vehicle:
2001 WRX (GC8)

Default

plug wire and coil pack problems are pretty common on subaru's. I dont think the ProECM had anything to do with it.

J
jeffg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
XS Engineering Power Pack II Ignition Amplifier System mycotopian Private 'For Sale' Classifieds 3 07-23-2006 06:58 PM
XS Engineering Power Pack II Ignition Amplifier System Shabib67 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 13 06-21-2006 04:08 AM
torque/power chip SoCalScooby Normally Aspirated Powertrain 40 04-12-2002 02:00 PM
Cobb Air Intake and ProEcm Power Chip? Mr. Rogers Newbies & FAQs 4 04-03-2002 11:22 PM
jc sports torque power chip phildawg Newbies & FAQs 1 06-24-2001 09:05 PM


All times are GMT -4. The time now is 08:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.