Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-16-2011, 12:41 AM   #1
zephyr2oo5
Scooby Newbie
 
Member#: 273251
Join Date: Feb 2011
Default Hard start after fuel fill up

So I've Been experiencing an issue after filling up each time when I go to leave the pump and the car won't fire. It only doesn't the first time I go to start it and on the second attempt it starts up every time. I've got 800cc injectors and a walbro 255 any ideas? Thanks
* Registered users of the site do not see these ads.
zephyr2oo5 is offline   Reply With Quote
Old 02-16-2011, 02:17 AM   #2
pnuts1986
Scooby Newbie
 
Member#: 269594
Join Date: Jan 2011
Chapter/Region: MWSOC
Location: mad-town wiscompton
Vehicle:
02 wrx stage 2
silver

Default

i think fuel vapors are going into your intake during fill up. Making it very rich, do you have a air/fuel gauge?

i bet your evaporative purge solenoid is stuck open some how.....is ur check engine light on?
pnuts1986 is offline   Reply With Quote
Old 02-18-2011, 10:52 AM   #3
BKscooby
Scooby Specialist
 
Member#: 163601
Join Date: Nov 2007
Chapter/Region: Tri-State
Location: Brooklyn. NY
Vehicle:
2002 WRX
PSM

Default

evap isn't the culprit of this issue. Most likely a clogged fuel filter, or a bad fuel pump. What year is the car, miles, mods?
BKscooby is offline   Reply With Quote
Old 02-19-2011, 01:56 AM   #4
pnuts1986
Scooby Newbie
 
Member#: 269594
Join Date: Jan 2011
Chapter/Region: MWSOC
Location: mad-town wiscompton
Vehicle:
02 wrx stage 2
silver

Default

Quote:
Originally Posted by BKscooby View Post
evap isn't the culprit of this issue. Most likely a clogged fuel filter, or a bad fuel pump. What year is the car, miles, mods?

evap isnt the cluprit??? little do you know.

u think a fuel filter can make a car not start? even if the filter was clogged fuel will still flow, if the pump was bad it would be acting up on WOT not during starting.

Well maybe the check valve might be bad, but he said only after filling up.

so lets not just jump on the filter idea cuz thats not the issue.
pnuts1986 is offline   Reply With Quote
Old 02-25-2011, 07:24 PM   #5
zephyr2oo5
Scooby Newbie
 
Member#: 273251
Join Date: Feb 2011
Default

any ideas?
zephyr2oo5 is offline   Reply With Quote
Old 02-26-2011, 02:33 PM   #6
02_blue_u_away
Scooby Newbie
 
Member#: 99375
Join Date: Oct 2005
Chapter/Region: MWSOC
Location: Waterford, MI
Vehicle:
2002 Subaru WRX
World Rally Blue

Default

Check all of your vacuum lines and especially around the evap lines near the manifold. mines did this and found bad connection, more so, a bad line. Hard start would happen to me right after i fuel up. but it'll be find until the next fill up. hope this helps.
02_blue_u_away is offline   Reply With Quote
Old 02-26-2011, 06:45 PM   #7
maloz129
Scooby Newbie
 
Member#: 242227
Join Date: Mar 2010
Chapter/Region: Tri-State
Location: nj 08731
Vehicle:
04 impreza wrx
san ramo red

Default

run some injector cleaner thru it
maloz129 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Starting after fueling up zedman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 12-09-2010 03:00 PM
2000RS--Odd Starts directly after fuel fill-up snoopyone8 Normally Aspirated Powertrain 14 08-23-2010 10:16 AM
After I filled up some gas, the car won't start zac5 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 11-17-2009 07:19 PM
won't start after a fill up John Kerr Normally Aspirated Powertrain 5 07-15-2008 02:12 AM
Car wont start after tank fill up!! SSsleeper96 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 12-22-2005 11:05 AM


All times are GMT -4. The time now is 07:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.