Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-18-2011, 12:58 PM   #1
dux10
NASIOC Supporter
 
Member#: 235338
Join Date: Jan 2010
Chapter/Region: South East
Location: Georgia
Vehicle:
2002 Faggin Wagon
srp

Default And I Thought Ringland Failures were for the 2.5 motors...

well, within 24 hrs of spining a bearing in my 02 wagon, Dads sedan lost all compression on cylinder #3. We took our time over the last couple weeks pulling it out and apart (school + work = little free time) and this is what we found:





the car has 125k miles and is a typical stage 2 setup (UP, TBE, K&N, crank pulley, Walbro 255) on a conservative tune. While tuning it was requiring an unusually large amount of fuel to keep the motor happy. About a week after tuning (getting ready for a wideband install and re-tune) it started running horribly, blowing lots of smoke, and throwing misfire CELs. Compression test showed ZERO psi in cylinder #3 and the spark plug was covered in oil. We suspect an injector failed and caused a lean condition and this was the result.
He's in the process of deciding what he wants to do, but in the meantime, we all love destruction (especially when its somebody elses motor. lol) so i thought I'd share...
* Registered users of the site do not see these ads.
dux10 is offline   Reply With Quote
Old 02-18-2011, 01:32 PM   #2
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

That's too bad! Are you both getting rebuilds then?

Mike
GrimmSpeed is offline   Reply With Quote
Old 02-18-2011, 01:48 PM   #3
dux10
NASIOC Supporter
 
Member#: 235338
Join Date: Jan 2010
Chapter/Region: South East
Location: Georgia
Vehicle:
2002 Faggin Wagon
srp

Default

hahaha I am and hopefully he will too. I'm doing a brand new 257 shortblock/hybrid. He will either do a 205 short block or just another 205 motor.
I just placed my first order for my build the begining of the week. Oddly enough it was with you guys. lol
dux10 is offline   Reply With Quote
Old 02-18-2011, 04:16 PM   #4
mneste8718
Scooby Specialist
 
Member#: 51562
Join Date: Dec 2003
Chapter/Region: South East
Location: Raleigh NC/High Point NC
Vehicle:
2004 WRX Sedan PSM
EJ205 VF39@22psi 300whp

Default

so were you getting tuned without a wideband present?
mneste8718 is offline   Reply With Quote
Old 02-18-2011, 04:32 PM   #5
dux10
NASIOC Supporter
 
Member#: 235338
Join Date: Jan 2010
Chapter/Region: South East
Location: Georgia
Vehicle:
2002 Faggin Wagon
srp

Default

Yes. it was a mild tune. We thought the wideband would've been delivered before the tune, but it didn't happen.
Although not having a wideband did not cause this, it could have prevented it. Tuned or not, the injector was failing either way and it would've happened anyway.
dux10 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how strong/well built is the 2.5 motor? Scott_2.5TS Normally Aspirated Powertrain 14 11-15-2007 04:35 PM
Will intakes for the 2.5 fit the 2.2? Husker05 Normally Aspirated Powertrain 3 11-11-2005 10:46 AM
What's the best color and MY for the 2.5 RS? -=C=- Off-Topic 34 03-19-2003 08:11 PM
I NEED: Anybody have the clutch alignment tool? I need this for a 2.5 motor.......... mcu81 Tri-State Area Forum 2 08-27-2002 11:01 PM


All times are GMT -4. The time now is 05:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.