Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-24-2011, 09:55 PM   #1
haze89
Scooby Newbie
 
Member#: 275036
Join Date: Feb 2011
Default Car wont start some times.

I buy a 1998 subaru impreza L 1.8 awd. I was having a problem with engine hesitation when the car was at low revs. I replaced spark plugs and wired, the ignition seems to be working fine. Some times the car wont start. It cranks strong, I havent figured if it sparks when this problem happens but Im sure there is spark inside the chamber because plugs and wires are new and ignition works ok. After a couple of tries it will start. Sometimes I think it may be fuel not reaching the chamber. When i put my ignition in ON I barely hear the fuel pump and it only buzzes for like 1 second and turns off. I have a Nissan 300zx and I used to have this issue and it was the fuel pump relay but I couldn't hear the fuel pump. In my subaru I can hear the fuel pump but weak. Does somebody have an idea about what this could be?
* Registered users of the site do not see these ads.
haze89 is offline   Reply With Quote
Old 02-25-2011, 11:53 AM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

mileage? mods? all maintenence up to date? The reason the fuel pump stops after a second is that it's priming itself, it's supposed to stop and wait for you to turn the key just a tad further. Make sure that all electrical connections and grounds are clean in the engine bay. It's definitely possible that your fuel pump is on its way out, but I have no experience with symptoms.
yarrgh is offline   Reply With Quote
Old 02-25-2011, 01:13 PM   #3
Jessekrs123
Scooby Specialist
 
Member#: 236927
Join Date: Jan 2010
Chapter/Region: NESIC
Location: Oakville CT
Vehicle:
1993 Legacy Sedan
1984 BRAT

Default

Hesistation at low revs and inability to start at times sounds like a coolant temp sensor or an IACV problem.

When it doesn't start check for:
-Spark
-Fuel
-Timing (this should be fine if it runs)
-Compession

Also check your vacuum hoses for tears/disconnection.
Jessekrs123 is offline   Reply With Quote
Old 02-25-2011, 05:14 PM   #4
renyo
Scooby Newbie
 
Member#: 93577
Join Date: Aug 2005
Chapter/Region: MAIC
Location: Orlando, unfortunately
Vehicle:
98 Impreza

Default

I'm going to throw MAF sensor into the ring... If you unplug it and it starts right up, there's your problem. There's probably a few more likely causes though.

Afterthought: Have you replaced your fuel filter recently?
renyo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
car wont start after timing belt install jobxiii Normally Aspirated Powertrain 16 01-17-2011 08:55 PM
for some reason my car wont start (pics inside) quicksubie General Community 9 07-20-2010 06:25 PM
Alarm wont stop going off, car wont start!! felixk Car Audio, Video & Security 3 08-20-2009 05:10 PM
Parking lights wont work now car wont start inevitable_101 Electrical & Lighting 0 07-21-2009 04:51 PM
02 wrx wont start after timing please help ej20wagon02 Service & Maintenance 6 04-03-2009 02:05 PM


All times are GMT -4. The time now is 12:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.