Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-06-2011, 08:00 AM   #1
Niblaze
Scooby Newbie
 
Member#: 167644
Join Date: Dec 2007
Location: NYC
Vehicle:
2007 WRX
UGM

Default Is it my tranny or clutch?

Alright so tonight I stretched my 07's legs a bit but I did it all smoothly and only launched at like 4k. I was smelling burnt clutch and was really wondering why because it seemed like it came from just fast acceleration in like 3rd and 4th.

Now what it does is it seems to go between the gears but I have to rev to 4 or 5000 to get moving. In first girl i was at 2000 and floored it and the revs shot up but the car didn't go anywhere. I could even have it in 5th gear and rev up to like 5000 and the car will move. The fastest I was eblt to drive home regardless of the gear like 40mph or else it'd be revving at 6000 and not even going faster.

So what you guys think clutch or tranny? It's only got 21k miles 07 Wrx
* Registered users of the site do not see these ads.
Niblaze is offline   Reply With Quote
Old 03-06-2011, 08:16 AM   #2
Niblaze
Scooby Newbie
 
Member#: 167644
Join Date: Dec 2007
Location: NYC
Vehicle:
2007 WRX
UGM

Default

After I assume it's clutch after watching some youtube vids.
Niblaze is offline   Reply With Quote
Old 03-06-2011, 08:20 AM   #3
Jessekrs123
Scooby Specialist
 
Member#: 236927
Join Date: Jan 2010
Chapter/Region: NESIC
Location: Oakville CT
Vehicle:
1993 Legacy Sedan
1984 BRAT

Default

Your clutch is slipping. That would explain the raise in rpms without the power going to the wheels even if you've let the clutch all the way out.

Are you the first owner? If so you definitely need to improve your skills with a stick.

I've seen clutches last 3 times as long as yours has.
Jessekrs123 is offline   Reply With Quote
Old 03-06-2011, 09:58 AM   #4
Niblaze
Scooby Newbie
 
Member#: 167644
Join Date: Dec 2007
Location: NYC
Vehicle:
2007 WRX
UGM

Default

Quote:
Originally Posted by Jessekrs123 View Post
Your clutch is slipping. That would explain the raise in rpms without the power going to the wheels even if you've let the clutch all the way out.

Are you the first owner? If so you definitely need to improve your skills with a stick.

I've seen clutches last 3 times as long as yours has.

I mean I did learn on this car but I learned quick. As i said it i would start to smell the burnt clutch in 3rd and 4th gear when I would not have been holding it longer than a second. I also didn't do high rpm launches. I usually baby her but like to open her up once and a while. I've heard subaru replacing clutches under 3k/36k though I mean I am only at 21 and I'm not modded.

Have others experienced clutches failing early which would mean it's very possible it's due to the manufacturing. I even paid a good amount for extended warranty so I guess It just depends if my dealer is a sick or not I guess.
Niblaze is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it my tranny? Soukyoku Transmission (AT/MT) & Driveline 1 02-09-2009 11:15 PM
Is it my imagination or is this racist? (pic inside) edkwon Off-Topic 28 06-09-2008 12:20 PM
Is it my alternator or my battery...? brent_G Electrical & Lighting 7 02-04-2008 06:20 PM
Is it my connection or is youtube slow today? Snoopy Off-Topic 11 08-27-2007 11:44 AM
is it my driving or my car? lazyblue General Community 12 04-26-2007 08:54 PM


All times are GMT -4. The time now is 12:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.