Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-06-2011, 10:32 PM   #1
95imprezagc8
Scooby Newbie
 
Member#: 218001
Join Date: Jul 2009
Chapter/Region: Tri-State
Location: New York
Vehicle:
1995 impreza
carriban green

Default OBD1 CEL Flashes.

Hey what's up guys? I have a 95 impreza L the car usto be auto and FWD, and I converted it last summer to AWD and 5 Speed. It still has the auto comp in there, and the car starts and runs fine, drives reves everything. But when your driving thr cel comes on and off rndomly, with certain rpms. Its not the TPS bc I changed it 3 times. But the damn light won't stay on so I can check the code. It just flashses as I accelerate. But the car feels like its bogging sometimes and missfires at 4 k if heald steady. I don't know guys. Some help please.
* Registered users of the site do not see these ads.
95imprezagc8 is offline   Reply With Quote
Old 03-06-2011, 10:44 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

w/o the code, all I can do is speculate. but blinking (on OBD II) means misfire that is damaging to the cat. as a precaution, check your ignition system, plugs, wires, grounds....and the like.
yarrgh is offline   Reply With Quote
Old 03-07-2011, 06:49 AM   #3
95imprezagc8
Scooby Newbie
 
Member#: 218001
Join Date: Jul 2009
Chapter/Region: Tri-State
Location: New York
Vehicle:
1995 impreza
carriban green

Default

But OBD1 comps don't have a designated misfire code. And 95 EJ18's don't have knock sensors. Still stumped....
95imprezagc8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! OBD1 CEL electrical problem! imprezaL2345 Electrical & Lighting 0 04-22-2009 07:54 PM
Need a NoVA shop to read an OBD1 CEL Mikey52 Mid Atlantic Impreza Club -- MAIC 6 03-14-2008 04:08 PM
How to check OBD1 CEL? Lachlan Subaru Conversions 3 10-29-2005 11:02 AM
will the CEL flash when detonation occurs even if the CEL is already lit? x12oyx316x Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 05-17-2004 08:02 PM
('93-'01) HELP HELP - CEL Flashing and Fans Cycling GarySheehan Impreza Forum 5 05-04-2001 05:03 AM


All times are GMT -4. The time now is 12:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.