Welcome to the North American Subaru Impreza Owners Club Monday August 29, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-26-2010, 10:24 PM   #1
Jamil7
Scooby Newbie
 
Member#: 129033
Join Date: Oct 2006
Chapter/Region: TXIC
Location: Amarillo, TX
Vehicle:
. 95 Impreza
. 04 Ninja ZX6RR

Default Rough idle, gas smell, & out of ideas

My fiance's 97 L 2.2 is not cooperating at the moment. In the past, it would idle rough and hesitate while accelerating for a few days everyonce in a blue moon. Now it is constant. I start the car and it dies unless I feather the throttle. Then it idles really rough and hesitates to the point where its undriveable. We've replaced both O2 sensors, the cam/crank position sensors, the knock sensor, put water remover and injector cleaner in the gas, changed the spark plugs (old plugs were only 3 months old and looked normal), reset the ecu a few times, and gutted both catalyic converters. After doing all of that it finally idles halfway decent after forcing it to stay running and warm up a bit. But the exhaust smells like an old boat being started for the first time after a long winter and it won't run well enough to drive. I'm out of ideas. What should I check next?

UPDATE: Forgot to mention.. The Subaru dealer pulled the CEL codes and there were a few. One was a knock sensor malfunction, one was something about the catalyic converter, and I don't remember the rest. They said replacing the cats would fix everything. I'm not going to spend the $900 they want for new cats so we gutted them both. And replaced the knock sensor and everything else I mentioned too. Stilll not running well.
* Registered users of the site do not see these ads.

Last edited by Jamil7; 12-26-2010 at 10:29 PM.
Jamil7 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-26-2010, 10:28 PM   #2
Jessekrs123
Scooby Specialist
 
Member#: 236927
Join Date: Jan 2010
Chapter/Region: NESIC
Location: Oakville CT
Vehicle:
2015 BRZ, 93 Legacy,
1984 BRAT

Default

Idle air control valve maybe?
Jessekrs123 is offline   Reply With Quote
Old 12-27-2010, 04:04 PM   #3
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: I do.
Default

One of 4 things...though likely one of three:

Bad: Plugs and/or wires
Bad: Idle Control Valve (search for how to clean that bitch)
Bad: Map sensor (if your car has one)
Bad: Atmospheric Pressure Sensor (if your car has one)

The last two may be wrapped in one if you have a MAF.
obyone is offline   Reply With Quote
Old 03-15-2011, 07:33 PM   #4
Jamil7
Scooby Newbie
 
Member#: 129033
Join Date: Oct 2006
Chapter/Region: TXIC
Location: Amarillo, TX
Vehicle:
. 95 Impreza
. 04 Ninja ZX6RR

Default

Thank you both for the replies and sorry it took me so long to post an update. It did turn out to be the MAF sensor in the end. $20 at the junk yard fixed that problem really quick.
Jamil7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Funk smell coming out of vents!? teiva-boy Interior & Exterior Modification 21 11-24-2007 11:05 PM
Car starts, idles rough and strong sulfer smell coming out of exhaust? team_orion Service & Maintenance 6 12-19-2006 06:09 PM
clicking noise, no power, rough idle, gas smell? sc00bywagon Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 14 06-19-2006 06:07 PM
02 WRX gas smell & rough acceleration ty454 Service & Maintenance 8 04-26-2006 12:49 AM
Low Idle during stopping and out of gear pat3 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 06-25-2005 09:28 PM

All times are GMT -4. The time now is 06:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.