Welcome to the North American Subaru Impreza Owners Club Friday November 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 03-13-2011, 10:28 PM   #1
Scooby Newbie
Member#: 269092
Join Date: Jan 2011
Chapter/Region: RMIC
1995 legacy L

Default water pump leakage, after 2 times replacing

hey everyone, i have a 1995 legacy with the ej22 motor. it had a slight leak coming from the seal from the water pump to the motor when i bought it. i had driven it for 2 months, always checking the coolant level. it wasnt a bad leak, but about one drop every 5 seconds or so.
so then i got the money and replaced the whole front end of the motor, water pump, timing belt, all tensioners and pulleys.
after about 100 miles it started leaking again. about the same rate. i used the paper gasket and some blue silicone gasket maker, "guaranteed not to leak".
so i was like all pissed off and stuff, and finally go the motivation to do it over. this time i used aviation form a gasket. its what i used on my ford and had no problems. not on the subaru though, this time it leaks pretty bad, about two drops a second. i dont really know what i am doing wrong here.
any ideas as to what gasket maker to use, should i use the paper gasket, how long do i need to wait before putting coolant in it?
* Registered users of the site do not see these ads.
bjballing is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-13-2011, 10:36 PM   #2
sue's roo's
Scooby Newbie
Member#: 228787
Join Date: Nov 2009
Chapter/Region: RMIC
Location: victor id
03 wrx
broken 3/4 of the year


Go into Subaru and get a gasket from them. Paper,cork,glue. all that stuff is the incorrect.
From Subaru its a metal gasket. and make sure the surface is very clean
sue's roo's is offline   Reply With Quote
Old 03-14-2011, 01:36 PM   #3
Scooby Newbie
Member#: 183070
Join Date: Jun 2008
Chapter/Region: RMIC
Location: TrueTune
2003 WRX
True Blue


^^Agree! I have a coolant pressure tester here at the shop. We can see where the leak is coming from without running the car. You better find out where all the leaks are before you go tearing into it again. Also, use the correct torque on the WP mounting bolts. If you need any help, let me know!
phattydrummer is offline   Reply With Quote
Old 03-14-2011, 02:02 PM   #4
Scooby Specialist
Member#: 43128
Join Date: Sep 2003
Location: SLC
92 RWD, 96 FWD
05 AWD


Yeah dude something is up. Long ago I did a super quick/ghetto front end replacement on a 91 2.2T engine in a parking lot at dusk. I was working blind so I doubt the surfaces were free from debris, all bolts were hand torqued to rick specs, and not a single leak from the oil or water pump. I suspect something is messed up on the block surface itself if you have used an OEM gasket/Pump before. If not, I highly recommend OEM equipment.

And +1 for running a system pressure test, should be able to find the leak quickly.
scoobydorift is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
water pump fails after 30k miles? scrappy doo Service & Maintenance 13 11-12-2010 10:09 AM
fs/water pump i got 2 brand new luchin Engine/Power/Exhaust 4 03-21-2010 09:19 AM
Need a new OEM water pump for my 2.0/2.5 hybrid toomuch Private 'Wanted' Classifieds 0 12-19-2007 11:25 AM
will 2.0 water pump, belts fit 2.5 block?? Suberman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 11-01-2006 01:58 AM
Why Upgrade Water pump on Supercharged 2.5 rs? (5psi) awd4ever Normally Aspirated with bolt-on Forced Induction Powertrain 6 11-26-2005 11:03 PM

All times are GMT -4. The time now is 11:39 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.