Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-18-2011, 02:41 AM   #1
ChrisNJ69
Scooby Specialist
 
Member#: 178632
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: North NJ
Vehicle:
2004 STI SWAP
68HTA (San Remo Red)

Default 2004 STI swap in a 04 wrx ABS light on and brakes do not work PLEASE HELP

hey guys so i did this hole swap my self not knowing what i was getting my self in to but i did it haha. its a 2004 WRX san remo red with a 2004 STI motor with 35k miles i am on stock 5 speed trans but my questions to you guys are my ABS light is on and my brakes do not work at all speedo don't and i have 3 wires on the pass side by the trans 1 of the wires hook up and the other 2 have no place to hook up and i know one of them is for the dccd and i upgraded my front calipers to 2007 wrx 4 pots.

The parts that came with my swap
2004 STI ECU
2004 STI wiring harness
2004 STI AC heater blower box with front face knobs
wiring harnees also came with engine pay fuse box and in car fuse box witch i used..

Idk what to do with the 3 or 4 wires by the trans i need help i can post pics tomorrow please some one help me


thanks chris
* Registered users of the site do not see these ads.
ChrisNJ69 is offline   Reply With Quote
Old 03-18-2011, 06:51 PM   #2
murrdogg24
Scooby Specialist
 
Member#: 50586
Join Date: Dec 2003
Chapter/Region: SCIC
Location: San Diego
Default

Quote:
Originally Posted by ChrisNJ69
hey guys so i did this hole swap my self not knowing what i was getting my self in to but i did it haha. its a 2004 WRX san remo red with a 2004 STI motor with 35k miles i am on stock 5 speed trans but my questions to you guys are my ABS light is on and my brakes do not work at all speedo don't and i have 3 wires on the pass side by the trans 1 of the wires hook up and the other 2 have no place to hook up and i know one of them is for the dccd and i upgraded my front calipers to 2007 wrx 4 pots.

The parts that came with my swap
2004 STI ECU
2004 STI wiring harness
2004 STI AC heater blower box with front face knobs
wiring harnees also came with engine pay fuse box and in car fuse box witch i used..

Idk what to do with the 3 or 4 wires by the trans i need help i can post pics tomorrow please some one help me

thanks chris
Probably need to bleed your brakes after the 4 pot install.
murrdogg24 is offline   Reply With Quote
Old 03-19-2011, 02:29 AM   #3
ChrisNJ69
Scooby Specialist
 
Member#: 178632
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: North NJ
Vehicle:
2004 STI SWAP
68HTA (San Remo Red)

Default

i did still don't work ABS light is off but brakes do not work
ChrisNJ69 is offline   Reply With Quote
Old 03-19-2011, 01:14 PM   #4
ChrisNJ69
Scooby Specialist
 
Member#: 178632
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: North NJ
Vehicle:
2004 STI SWAP
68HTA (San Remo Red)

Default

did i need to swap the lines and master cylinder to STI?
ChrisNJ69 is offline   Reply With Quote
Old 03-21-2011, 09:54 AM   #5
murrdogg24
Scooby Specialist
 
Member#: 50586
Join Date: Dec 2003
Chapter/Region: SCIC
Location: San Diego
Default

murrdogg24 is offline   Reply With Quote
Old 03-21-2011, 08:20 PM   #6
ChrisNJ69
Scooby Specialist
 
Member#: 178632
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: North NJ
Vehicle:
2004 STI SWAP
68HTA (San Remo Red)

Default

i got the blinkers and windows to work but now my dam blower box don't work haha its prob something dumb but my brakes still don't work if you pump them they work fine its weird
ChrisNJ69 is offline   Reply With Quote
Old 03-29-2011, 01:28 AM   #7
youngW03
Scooby Newbie
 
Member#: 186033
Join Date: Aug 2008
Chapter/Region: SWIC
Location: Albuquerque New Mexico
Vehicle:
2003 gtx30r hyb wagn
PSM

Default air in the line

I just put brembos on my 03 wrx man you just gotta let those suckers air bleed man its the best way that's what it sounds like anyways pumping builds pressure in the line, as for the 3 wires post pics i have a hybrid swap with a 6 speed.
youngW03 is offline   Reply With Quote
Old 04-06-2011, 10:19 PM   #8
ChrisNJ69
Scooby Specialist
 
Member#: 178632
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: North NJ
Vehicle:
2004 STI SWAP
68HTA (San Remo Red)

Default

found out the problem lol i feel like a dumb dumb i had the drive side caliper on the passenger side and the pass side on the driver side i didn't know haha there is nothing on the calipers that say L for left and R for right
ChrisNJ69 is offline   Reply With Quote
Old 04-07-2011, 12:23 AM   #9
slavik.86
Scooby Specialist
 
Member#: 238300
Join Date: Feb 2010
Chapter/Region: NWIC
Location: tacoma wa
Vehicle:
00 2.5rs built
ej255 swap

Default

how did u not not notice that when trying to bleed the brakes with the bleeder screw facing down lol
slavik.86 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 STI SWAP/HARNESS to 04 WRX TRANS-HELP-What wires do what on each. Maverick7531 Transmission (AT/MT) & Driveline 1 06-25-2010 04:55 PM
04 STI DCCD not working please help Cstmboxermotorsports Transmission (AT/MT) & Driveline 3 09-16-2009 05:57 AM
Engine light on and my cars not workin anymore. help wonsin83 Service & Maintenance 14 11-19-2007 10:22 PM
05 Sti Fuel gauge not working please help hilfiger4you Service & Maintenance 5 12-11-2005 12:52 AM
Help...please...ABS light on and I don't know why Cliff Ditchhanger Brakes, Steering & Suspension 6 04-16-2001 09:23 AM


All times are GMT -4. The time now is 07:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.