Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-29-2011, 06:24 PM   #1
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default 2011 WRX turbo issues. . . maybe???

friday afternoon after my re enlistment, i had the day off. i drove to austin to celebrate with the wife, on the way back i'm accelerating on the on ramp to get on the free way. i hit 65 mph and the car just stopped accelerating.

i had the accelerator down but no more acceleration

well i pulled over to listen or look for anything unusual, well NO noises, smells, smoke or anything out of the ordinary

well i bring it to the dealership saturday morning due to the fact that by the time i made it back home the service department was close and well i wasnt leaving my car there. well saturday it gets dropped of and not even looked at, come monday i drive by and they had just pulled it in around 3 and still no one was looking at her and now today being tuesday i call around 4:30.

"appearantly" the service manager tried telling me that subaru was trying to figure out where this "update" supposedly on my ecu at he asked if my car had been modded and i told him no, only 10k miles on my car barely. well the service man. tried to tell me that they are trying to figure out whats up with the ecu. . . . i told them nothing was done to the car and well looks like im waiting another day to figure out whats wrong with my car.

im i'll keep you guys posted, but like i said no mods, only 10k miles and oil level was fine, no burnt smells, knocking or pinging sounds, or smoke from the tail pipe, im thinking the turbo isnt working because it just feels like a car with very low compression, no power and i couldnt accelerate over 60mph and if i floored it, after 2k rpms it just hummed really loud.


second GR WRX and i should of bought an evo . . . . .
* Registered users of the site do not see these ads.
THE_SMURF is offline   Reply With Quote
Old 03-29-2011, 06:44 PM   #2
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

What oil are you running, and at what drain interval? OEM filter?

I just hit 3,100 miles on mine, about to do the second oil change with Pennzoil Ultra 5w-40 + OEM filter. 56 autocross and ProSolo laps already Hopefully no issues with mine either, runs like a top. Going to swap out the gearbox + diff oils now that they are broken-in.
JamesWilson2 is offline   Reply With Quote
Old 03-29-2011, 07:15 PM   #3
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

same oil that your using, except i think its the factory 5w-30 and its changed every 3k miles

the filter is a purel one. . . the gold one from advance auto. . . . im not sure if the turbo feed line clogged up causing the turbo to seize up.

we will see though
THE_SMURF is offline   Reply With Quote
Old 03-29-2011, 08:28 PM   #4
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

Good luck! I never planned on running 5w-30 except for the factory fill....drained it at 700 miles and put the thicker stuff in right away.
JamesWilson2 is offline   Reply With Quote
Old 03-29-2011, 09:06 PM   #5
AwdBoostCreep
Scooby Specialist
 
Member#: 182804
Join Date: Jun 2008
Location: Pensacola, FL
Vehicle:
2006 Gsxr 1000
Turbo

Default

Highly recommend OEM filters but that's my opinion. I've seen cases of warranty cars not being covered due to aftermarket oil filters, when it involves something needing to be oiled.
AwdBoostCreep is offline   Reply With Quote
Old 03-29-2011, 09:21 PM   #6
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

not really aftermarket and it states no where that you must use oem filters to keep your warranty. . . .

but yea i wouldnt be suprised if they try to run some **** like that by me, but as of now it sounds llike they're trying to find something in the ecu. . . .

has any one ever heard of a subaru dealership sending info to SOA to see what was on the ECU?

but when he told me it looked like there was a map some what ereased from the ecu i started lmao cus to think im gonna erease a map of the ecu is just stupid. . . .

subaru is stupid. . . im going to total it out and just go buy a evo . . . .
THE_SMURF is offline   Reply With Quote
Old 03-29-2011, 09:58 PM   #7
Baddmnkey
Scooby Newbie
 
Member#: 211812
Join Date: May 2009
Chapter/Region: MWSOC
Location: NW Chicago
Vehicle:
09 WRX
SSM, mostly stock!

Default

Some shady dealerships will tell you anything to not warranty anything and stick you with the bill but that goes for Subaru and Mitsu...goodluck w/ the evo
Baddmnkey is offline   Reply With Quote
Old 03-29-2011, 10:06 PM   #8
AwdBoostCreep
Scooby Specialist
 
Member#: 182804
Join Date: Jun 2008
Location: Pensacola, FL
Vehicle:
2006 Gsxr 1000
Turbo

Default

I work for subaru, hence why I have seen cases that were not covered due to oil filters.(spin bearings, because it was done at a jiffy lube)

I know our dealership let's a lot of things slide and when it comes to something serious, or on a new car, we normally have to have our subaru rep make the call.

A lot of variables, but 99% of the time they will cover it. If it happens again, they will "goodwill" it another time.

I'm use to seeing bad engines. Turbos arnt all that big for subaru to cover.
AwdBoostCreep is offline   Reply With Quote
Old 03-29-2011, 10:09 PM   #9
Baddmnkey
Scooby Newbie
 
Member#: 211812
Join Date: May 2009
Chapter/Region: MWSOC
Location: NW Chicago
Vehicle:
09 WRX
SSM, mostly stock!

Default

AwdBoost that 1000 gixxer turbo'd gotta be one hell of a ride, lol
Baddmnkey is offline   Reply With Quote
Old 03-29-2011, 10:17 PM   #10
AwdBoostCreep
Scooby Specialist
 
Member#: 182804
Join Date: Jun 2008
Location: Pensacola, FL
Vehicle:
2006 Gsxr 1000
Turbo

Default

284hp out of a t66 turbo on 6 psi with only 450lbs holding it back, is one hell of a ride indeed lol.

Not to get off subject
AwdBoostCreep is offline   Reply With Quote
Old 03-29-2011, 11:50 PM   #11
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

true. . . they once tried to deny my 09 warranty work on my ac due to me having an aftermarket turbo . . . . .

said the turbo screwed with pressure in the AC lines causing the condesnor to stop working

but i know i SHOULD be good, second car from the same dealership and im pretty cool with the manager, and well the US Army legal is free for me and im sure they dont want to deal with that
THE_SMURF is offline   Reply With Quote
Old 03-30-2011, 08:29 AM   #12
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

Quote:
Originally Posted by THE_SMURF View Post
same oil that your using, except i think its the factory 5w-30 and its changed every 3k miles

the filter is a purel one. . . the gold one from advance auto. . . . im not sure if the turbo feed line clogged up causing the turbo to seize up.

we will see though
From TSB 02-101-07:

"The use of Genuine Subaru oil filter is strongly recommended. Many aftermarket oil filters have different filtration capacity and relief valve opening pressure. Those filters may not meet Subaru's requirements and may cause engine problems."

Not saying that's the reason, but personally I use OEM filters until the warranty period is over. That way there is no wiggle room for the dealership to get me on. Use mysubaru.com to log ALL your oil changes. I also keep a copy of all my receipts for all the oil / filters / crush washers I've bought.

As far as the ECU goes, there was a new map that should have been applied before the vehicle even made it to the dealer.
jonklein611 is offline   Reply With Quote
Old 03-30-2011, 09:03 AM   #13
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

I am about to do another oil change before the weekend, need to stock up on OEM filters. I'm in the same boat and don't want to risk any warranty issues with this car, even though it is "stock".

After all of my Pennzoil Ultra Euro 5w-40 is gone, I think the Rotella T6 will be going in, unless I can find a deal on the PU.
JamesWilson2 is offline   Reply With Quote
Old 03-30-2011, 11:02 AM   #14
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

see on my 09 wrx I used the oem.... I have no idea why I didn't this oil change, but I would switch it up some times. the purilator filter I heard is great though........

and I am sticking with the ultra as Lon as the car is stock I ran mobil 1 turbo diesel 5w/30 when I was on e85 on my 09 and it was beautiful.

this next change I will buy the oem filter and I asked about the receipt deal when it comes to keeping records but they were like well there is no telling you actually used them or changed the oil on that date...... so I said screw it.
THE_SMURF is offline   Reply With Quote
Old 03-30-2011, 11:03 AM   #15
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

see on my 09 wrx I used the oem.... I have no idea why I didn't this oil change, but I would switch it up some times. the purilator filter I heard is great though........

and I am sticking with the ultra as Lon as the car is stock I ran mobil 1 turbo diesel 5w/30 when I was on e85 on my 09 and it was beautiful.

this next change I will buy the oem filter and I asked about the receipt deal when it comes to keeping records but they were like well there is no telling you actually used them or changed the oil on that date...... so I said screw it.
THE_SMURF is offline   Reply With Quote
Old 03-30-2011, 11:16 AM   #16
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

Quote:
Originally Posted by THE_SMURF View Post
see on my 09 wrx I used the oem.... I have no idea why I didn't this oil change, but I would switch it up some times. the purilator filter I heard is great though........

and I am sticking with the ultra as Lon as the car is stock I ran mobil 1 turbo diesel 5w/30 when I was on e85 on my 09 and it was beautiful.

this next change I will buy the oem filter and I asked about the receipt deal when it comes to keeping records but they were like well there is no telling you actually used them or changed the oil on that date...... so I said screw it.
If it's logged on mysubaru.com they'd have a hard time arguing against it. If they did I'd kick it up to SOA. They'd have to prove you screwed the pooch on one of the changes to deny your claim.

Or you could do what my dad did for his car, and save all his old filters for the warranty period.

Also your dealer might not care (the sound like a bunch of yoohoos), but record keeping for your own benefit could help for arguments against SOA (not the dealer), and it's super helpful to have a full log of change info when you go to sell the car. Esp if you sell it on the forum / online, people love having paper to back up the history of the car.

You could even log the changes in mysubaru as "done by 3rd party mechanic".
jonklein611 is offline   Reply With Quote
Old 03-30-2011, 12:30 PM   #17
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

well I just got the phone call..........




they said the down pipe was the problem and will be replaced, part got ordered or will be ordered today and I should have my car by Tuesday maybe.....

well I'm going to get my loaner car now.... i bought a limited wrx so let's see what POS I get...... I swear better not be a damn impreza
THE_SMURF is offline   Reply With Quote
Old 03-30-2011, 02:31 PM   #18
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

Quote:
Originally Posted by THE_SMURF View Post
well I just got the phone call..........




they said the down pipe was the problem and will be replaced, part got ordered or will be ordered today and I should have my car by Tuesday maybe.....

well I'm going to get my loaner car now.... i bought a limited wrx so let's see what POS I get...... I swear better not be a damn impreza
Good news!
jonklein611 is offline   Reply With Quote
Old 03-30-2011, 03:19 PM   #19
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

That's great! Maybe the cat failed and got clogged up? Sounds like an easy fix.
JamesWilson2 is offline   Reply With Quote
Old 03-30-2011, 03:26 PM   #20
ptsmalls
Scooby Specialist
 
Member#: 31960
Join Date: Jan 2003
Chapter/Region: South East
Location: TN
Vehicle:
2012 R

Default

Yea - be glad you're getting a loaner. Most dealerships don't have loaners or are short of them. Easy fix FTW
ptsmalls is offline   Reply With Quote
Old 03-30-2011, 04:18 PM   #21
jddssc121
Scooby Specialist
 
Member#: 253302
Join Date: Jul 2010
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2011 G37x

Default

Quote:
Originally Posted by THE_SMURF View Post
not really aftermarket and it states no where that you must use oem filters to keep your warranty. . . .

you are correct. But the warranty does state that you must use parts that meet Subaru specs. Does your aftermarket filter meet the bypass valve psi rating spec?
jddssc121 is offline   Reply With Quote
Old 03-31-2011, 09:01 AM   #22
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

yes....good news some what to know it was something as small as a cat. failing BUT I got to thinking.... all those exhaust gases that had little to no room to flow, what effect would that have on the turbo charger?

would that cause the exhaust/compressor wheel to fail later on down the road or a small amount of damage to the bearings which will become greater over time?

and JDDSSC121, I'm not sure, don't believe they take turbocharged cars into account when testing, but like I said once I get her back next week she will be checked out and a new oil change would be done by the dealership using the oem full synthetic type of oil.

at only 10k miles and after the compression test subaru performed as part of the diagnostic, eveything else was said to be in good working order, after the down pipe was removed the car was said to be running just fine.

I know how sketchy Subaru can be with the little things which is why I'm going to leave ALL and ANY work up to them.

and yea, I ended up with a 2011 base forester, not to bad, alot more comfortable than my wrx and not having all the creeks and noises isnt so bad either lol
THE_SMURF is offline   Reply With Quote
Old 03-31-2011, 06:16 PM   #23
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Don't over think it smurf. Thats all Im going to say.
munkis is offline   Reply With Quote
Old 04-02-2011, 02:03 PM   #24
THE_SMURF
Scooby Specialist
 
Member#: 260624
Join Date: Oct 2010
Chapter/Region: TXIC
Location: TEXAS/Kentucky
Vehicle:
2007 Z06/ZX10R
Black

Default

kind of mean^^^^^^



well i went back and i did not now i had free oil changes, so before i get it back the oil will be changed and my little cover for the bottom will be back on
THE_SMURF is offline   Reply With Quote
Old 04-03-2011, 11:36 AM   #25
Subie808
Scooby Newbie
 
Member#: 278565
Join Date: Apr 2011
Chapter/Region: NESIC
Location: ... moving to SEA!
Vehicle:
2011 WRX hatch
Spahk Silvah

Default

where do you guys order your OEM filters? OEM oil? thanks
Subie808 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Between a 2011 wrx and a 2011 5.0 mustang...need help deciding. 2.5 warranty issues? r00st Factory 2.5L Turbo Powertrain 254 03-12-2011 12:11 PM
2011 WRX HVAC issue...? blindgoldfish z Electrical & Lighting 19 01-01-2011 12:36 PM
02 wrx boost issue/maybe fuel 02WRX78 Built Motor Discussion 0 12-14-2010 03:21 PM
2011 wrx turbo chichiko Newbies & FAQs 13 09-06-2010 11:20 PM
Spy Shots: 2011 Acura RL with maybe RWD and maybe V8 AVANTI R5 Non-Subaru News & Rumors 9 06-13-2008 07:06 PM


All times are GMT -4. The time now is 12:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.