Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-07-2011, 07:43 PM   #1
Pstl_Pete
Scooby Newbie
 
Member#: 171000
Join Date: Feb 2008
Chapter/Region: SCIC
Location: LA, CA
Vehicle:
08 WRX sedan
flat black

Default 08 WRX flashing cruise control light (NO CEL)

This has been an ongoing problem with the car and I'd really like to track down the issue.

The cruise control light flashes after Ive been driving the car for a bit. I had the car at the dealer and they didn't find anything (I dont even know if they looked into the light since they were more concerned with the hill assist light).

My hill assist light is also on but otherwise everything is good, no CEL. The cruise control doesnt work though.

Anyone have a similar problem? Suggestions on how to fix this?
* Registered users of the site do not see these ads.
Pstl_Pete is offline   Reply With Quote
Old 04-07-2011, 09:49 PM   #2
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2012 Forester 2.5X
2002 WRX Sedan

Default

I occasionally get the Hill Assist light (and hill assist does not work). The light will go on for a day or so and then go off. Three times now I have also gotten a CEL (and all the other lights that go on with a CEL, Cruise, TC, Hill Assist, etc).

The CEL scans as a P0852 - Park/Neutral Switch. Based on what I've read, this means I have a bad clutch sensor. Haven't gotten much further into troubleshooting yet, because the light goes away for at least a couple weeks after it gets reset.

Anyone know where this sensor is located, or where to order one? Is it on the clutch pedal assembly? Maybe on the transmission somewhere? I think I might have seen that online. How do you access it? I'd rather just replace the sensor myself if it's an easy plug and play.
xluben is online now   Reply With Quote
Old 04-08-2011, 07:35 AM   #3
4080wrx
Scooby Newbie
 
Member#: 68129
Join Date: Aug 2004
Chapter/Region: HIIC
Location: Osan AB, Korea
Vehicle:
2001 Impreza RSTi
White

Default

Quote:
Originally Posted by Pstl_Pete View Post
This has been an ongoing problem with the car and I'd really like to track down the issue.

The cruise control light flashes after Ive been driving the car for a bit. I had the car at the dealer and they didn't find anything (I dont even know if they looked into the light since they were more concerned with the hill assist light).

My hill assist light is also on but otherwise everything is good, no CEL. The cruise control doesnt work though.

Anyone have a similar problem? Suggestions on how to fix this?
flashing cruise is usually an indication of a temporary problem. what problem you ask? until read the codes there is no telling what. get the code read....

mine flashed recently and when I read it, it turned out to be the front O2 getting a low voltage reading.
4080wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
06 WRX CEL and flashing cruise control light. Mehdik Service & Maintenance 13 12-06-2011 08:49 AM
Check Engine Light and Flashing Cruise Control Light moose00015 Newbies & FAQs 17 05-29-2011 09:16 PM
Flashing Cruise Control but no CEL blindgoldfish z Newbies & FAQs 0 02-06-2011 12:06 PM
check engine light + flashing cruise control light ericmwas Newbies & FAQs 6 08-24-2009 11:21 PM
flashing cruise control with no chip ecasirhc Engine Management & Tuning 0 03-05-2007 05:01 PM


All times are GMT -4. The time now is 10:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.