Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-04-2012, 08:25 PM   #51
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

My wires were kinked due to a factory zip tie or something. My friend (Subaru mechanic) said it was common, he removed it and I've never had the fast blinker again. I think it was by the wiper fluid.
* Registered users of the site do not see these ads.
PearlRex11 is online now   Reply With Quote
Old 11-14-2012, 07:07 PM   #52
reefresco
Scooby Newbie
 
Member#: 337436
Join Date: Nov 2012
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2011 WRX
Satin White Pearl

Default

Big thanks for this write up!! This was the first first 'repair' on my 2 week old new-to-me 2011 white 5 door wrx. the fast blinker was driving me crazy and i was going to take it into the dealership but this is much easier to do myself.
reefresco is offline   Reply With Quote
Old 11-21-2012, 04:54 PM   #53
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2012 Forester 2.5X
2002 WRX Sedan

Default

My 2011 is doing this two years after I got it. Driver's side. I'll have to take a look at the wiring.
xluben is offline   Reply With Quote
Old 12-31-2012, 05:03 PM   #54
scx89
Scooby Specialist
 
Member#: 269388
Join Date: Jan 2011
Chapter/Region: SCIC
Location: SoCal SD / LA
Vehicle:
2011 Impreza WRX
obp

Default

Finally fixed mine. The bulb wasnt screwed in all the way lol..........
scx89 is offline   Reply With Quote
Old 03-18-2013, 04:16 PM   #55
monstruo_
Scooby Newbie
 
Member#: 348050
Join Date: Feb 2013
Default

I also fixed mine, I took the long route and move the airbox. Going to try the vent way if it ever happens again.
monstruo_ is offline   Reply With Quote
Old 09-20-2013, 03:04 PM   #56
Rynobot
Scooby Newbie
 
Member#: 338341
Join Date: Nov 2012
Vehicle:
2007 WRX Wagon
WR Blue

Default

I had the same issue on my 2010 STI. Your method for fixing it did the trick. I've been issue free for about 5 months now.
Rynobot is offline   Reply With Quote
Old 05-21-2014, 04:01 PM   #57
n3o729
Scooby Newbie
 
Member#: 362610
Join Date: Jul 2013
Chapter/Region: MAIC
Vehicle:
2010 STi
WRB

Default

sorry for bringing an old post back but mine started acting up couple weeks ago and it is annoying the hack out of me.

bought my 2010 used so no warranty left for me :/

will try this coming weekend but OP, some pix are not showing. can you send them to me please??? I will PM you my email.

thanks!

Tae
n3o729 is offline   Reply With Quote
Old Yesterday, 07:12 PM   #58
dannyngnX
Scooby Newbie
 
Member#: 303207
Join Date: Dec 2011
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2012 Wrx
Pearl freakin white

Default

^- open hood, and take air intake off to access passenger bulb. then take the bulb off and blow off the dust and it should stop. mine was loose and caused the blinking.


Sent from my iPhone using NASIOC
dannyngnX is offline   Reply With Quote
Old Today, 11:38 AM   #59
ghzdhjian
*** Banned ***
 
Member#: 397229
Join Date: Jul 2014
Default

Sweet, pics always make it easier. I am sure when mine has this issue (which I bet it will) I will refer to your post.

Last edited by ghzdhjian; Today at 11:45 AM.
ghzdhjian is offline   Reply With Quote
Old Today, 01:13 PM   #60
scrapin'
NASIOC Supporter
 
Member#: 44681
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: SouthEastern, PA
Vehicle:
2011 WRX SWP Hatch
www.48hrs.info group lead

Default

FYI for anyone else that finds this thread:

There is a TSB from Subaru on this, I believe they replace a section of the signal harness to fix.

Vehicle: 2011 Subaru Impreza
Nature of Defect:
EXTERIOR LIGHTING:TURN SIGNAL
Bulletin Number:
SB-0708
Bulletin Date:
Jan 2011
Summary:
SUBARU: TURN SIGNALS MAY BLINK TOO FAST DUE TO TENSION IN THE BULB SOCKET WIRING. 2008-2011 IMPREZZA. ( NHTSA ITEM NUMBER - 10038287 )
scrapin' is offline   Reply With Quote
Old Today, 01:16 PM   #61
SoapBox
Scooby Specialist
 
Member#: 204578
Join Date: Mar 2009
Chapter/Region: MAIC
Location: Philadelphia
Vehicle:
S54 M3, N54 135i
In another life: REX8

Default

Vehicle: 2011 Subaru Impreza
Nature of Defect:
EXTERIOR LIGHTING:TURN SIGNAL
Bulletin Number:
SB-0708
Bulletin Date:
Jan 2011
Summary:
SUBARU: TURN SIGNALS MAY BLINK TOO FAST DUE TO TENSION IN THE BULB SOCKET WIRING. 2008-2011 IMPREZA.
SOLUTION: Top-off Blinker Fluid
SoapBox is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just picked up 2011 WRX..will dealer fix rattles? mesarec Newbies & FAQs 33 01-04-2012 01:14 AM
2011 WRX with upgraded suspension that I can check out? boudy New England Impreza Club Forum -- NESIC 11 04-22-2011 08:52 PM
2011 wrx exhaust question agarr19 Factory 2.5L Turbo Powertrain 0 04-14-2011 03:28 PM
FS : GA: **SOLD**2011 WRX OEM Wheels & Tires $900 shipped to the 48 Kontankerous Wheels/Tires 9 04-02-2011 12:37 PM
02 WRX 4EAT Issue: Car won't move in Drive or Reverse when cold. Loud humming too. YinUCSD Transmission (AT/MT) & Driveline 2 10-30-2007 10:02 PM


All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.