Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-21-2002, 12:29 PM   #1
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default MAP sensor DEAD!, neutral Safety Switch DEAD, 1st recorded map kill?

MY00 RS. 36,800 5MT

my neutral safety swtich is dead, causing a bad idle, no biggie covered under warranty, (on order)

but the other day at idle, my car overheated, then shortly after MR CEL came on, and it started idling like crap, stalling and blowing black smoke.

pulled the code, its was Map sensor ckt high input I think, forgot to right it down.

car idles like crap, running extremely rich, doesnt drive bad, but not running good. Classic bad map sensor symptoms.

Its either my MAP sensor or my SAFC took a dump. I know it cant bee a wireing problem for my safc cause all the conecctions are soddered, though I will check them neway.

the thing that gets me is the pressure reading from my SAFC is good, its constant and doesnt fluctuate when the car runs bad.

anyone else have a map die on them.

im supposed to have the car dynod and the safc tuned this saturday too, I gotta get it fixe.

Jay McDade
Lincoln/Mercur/Jaguar Tech.
* Registered users of the site do not see these ads.
munkis is offline   Reply With Quote
Old 07-21-2002, 12:49 PM   #2
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

anyone have the part number for the map sensor?

Jay
munkis is offline   Reply With Quote
Old 07-21-2002, 04:37 PM   #3
EvasionOfTruth
Scooby Specialist
 
Member#: 13282
Join Date: Dec 2001
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2007 FXT
WRB SPB Edition

Default

Well I figured it would be in this pic but I don't see a listing for it.

Buster

EvasionOfTruth is offline   Reply With Quote
Old 07-21-2002, 04:45 PM   #4
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

thanks evasion.

1stsubaruparts.com, has a full oem parts catalog online with keyword searchs, so I didnt need the part number.

its 200.00 bux, wich makes me not happy.

The Map Sensor is in the intake manifold, on the diverside next to the coil pack .

Jay
munkis is offline   Reply With Quote
Old 07-21-2002, 10:17 PM   #5
US2JDM
Scooby Guru
 
Member#: 5893
Join Date: Apr 2001
Chapter/Region: E. Canada
Location: Fairport, NY
Vehicle:
1997 Black GC4
1995 White BK6

Default possible recall?

I heard there was a recall/TSB on MAP sensors on late model 2.5 motors...you might want to check if you fall under that one so you can get it for free...

Good Luck.

-Milan
US2JDM is offline   Reply With Quote
Old 07-22-2002, 07:09 AM   #6
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Thanks Ill check it out.

If its late model 2.5s I dont think mine will fall under it, my rs has a build date of 12/99.

thanks!

Jay
munkis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Won't Start / Neutral Safety Switch neurotic Newbies & FAQs 3 12-21-2005 03:49 AM
Neutral safety switch...? adam555 Transmission (AT/MT) & Driveline 10 12-05-2005 10:25 AM
Neutral Safety Switch dfgu Factory 2.0L Turbo Powertrain 1 11-21-2005 01:23 PM
neutral safety switch code buru6 Service & Maintenance 2 08-16-2004 03:41 PM
neutral safety switch problems w/MT reveler Car Audio, Video & Security 2 10-24-2002 08:02 PM


All times are GMT -4. The time now is 11:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.