Welcome to the North American Subaru Impreza Owners Club Friday November 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-19-2011, 03:29 PM   #101
russ9127
Scooby Newbie
 
Member#: 189531
Join Date: Sep 2008
Chapter/Region: NWIC
Location: Northern California
Vehicle:
2008 WRX Hatch
Silver w/ STi spoiler

Default

Quote:
Originally Posted by Scooby207
Probably the relay but if they replaced it under warranty and the same thing happened then they should probably cover it. When they replaced anything on my last subie it always came with a 1 year warranty. Have you being denied a claim because usually they have some leeway. Hope that helped
Where would I find the relay? In the engine bay? Its been two years and it hasn't started blinking fast yet
* Registered users of the site do not see these ads.
russ9127 is offline   Reply With Quote
Old 12-19-2011, 10:12 PM   #102
joe1
Scooby Newbie
 
Member#: 93518
Join Date: Aug 2005
Chapter/Region: TXIC
Location: Austin TX
Vehicle:
2011 Impreza WRX STI
WR Blue Mica

Default

Quote:
Originally Posted by a2cpc View Post
Sad...a few days ago at a local Subaru dealership I heard one of the service guys tell someone on the phone...We know it wasn't the bulb, we haven't run into this before, but we can replace the wring and socket for $XXX.XX!?! I am not sure if it was this exact problem, but from what I heard I would bet it was. Really sucks because I kind of like this dealership.
At least they didn't say his blinker fluid was low...
joe1 is offline   Reply With Quote
Old 12-20-2011, 01:34 PM   #103
BSOD2600
Scooby Newbie
 
Member#: 126760
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2011 WRX Limited
Black

Default

1) 2011 WRX
2) 4350
3) Right
4)
5) Dealer adjusted wiring harness.
BSOD2600 is offline   Reply With Quote
Old 12-22-2011, 01:05 PM   #104
Wrxhengy
Scooby Newbie
 
Member#: 303297
Join Date: Dec 2011
Default

Quote:
Originally Posted by Wrxhengy
1) 2011 Wrx Hatch
2) 582 miles, 1000 miles, and 1,322.
3) drivers side
4) took it to the dealer 3 times. They only stopped it for a week or so.
1st time they changed the entire headlight, 2nd they rerouted the harness. 3rd they replaced the bulbs. Now at 1,472 miles it's doing it again. I have no idea what to do now.
Ok so now I took it into a different Subaru dealership and they replaced the harness, and headlight again. Now at 3000 miles it's doing it again not only flashing rapidly but also it's not as bright as my right side. I decided to give up on Subaru and put some HID's in. Will that affect my warranty for the headlights?
Wrxhengy is offline   Reply With Quote
Old 12-22-2011, 02:57 PM   #105
CTSparky
Scooby Specialist
 
Member#: 282204
Join Date: May 2011
Chapter/Region: NESIC
Location: Northeast CT
Vehicle:
2011 5 Door STi
Plasma Blue Pearl

Default

1) 2011 PBP STi Hatch
2) 15500.... 6 months
3) Left turn signal (Driver Side)
4) Additional Subaru dealer quotes None yet going in today
5) Resolved at Dealer or fixed it yourself None yet scheduled for service

I'm just kinda bummed...

CTSparky is offline   Reply With Quote
Old 01-24-2012, 02:32 PM   #106
9111
Scooby Newbie
 
Member#: 297004
Join Date: Oct 2011
Location: Bay Area CA.
Vehicle:
2008 WRX

Default

2008 wrx right side blinking fast
Dealer had to reroute wire to fix issues. Fixed today
9111 is offline   Reply With Quote
Old 01-30-2012, 10:51 AM   #107
bicycle_wreck
Scooby Newbie
 
Member#: 226331
Join Date: Oct 2009
Chapter/Region: South East
Location: Knoxville, TN
Vehicle:
2012 WRX Hatch
Dirty Smurf

Default

1) 2012 Wrx Hatch
2) 1106 miles
3) Passenger Side
5) Will take a look at it myself. Just started this morning.
bicycle_wreck is offline   Reply With Quote
Old 02-01-2012, 09:19 PM   #108
exk20z3kid
Scooby Newbie
 
Member#: 307921
Join Date: Jan 2012
Default

1. 2012 Subaru WRX Sedan
2. 700ish miles
3. Passenger side
4. Started blinking really fast and then it went back to normal. It was weird.
exk20z3kid is offline   Reply With Quote
Old 02-01-2012, 10:33 PM   #109
jwongx27
Scooby Newbie
 
Member#: 300323
Join Date: Nov 2011
Default

1.2011 subaru wrx sedan swp
2.100miles
3. both side driver and passenger
4. blinking super fast non stop

im working 12 hours a day and they want me to leave the car a few days...
jwongx27 is offline   Reply With Quote
Old 02-01-2012, 11:22 PM   #110
ndtechie_rx8
Scooby Newbie
 
Member#: 118011
Join Date: Jun 2006
Chapter/Region: Tri-State
Vehicle:
2011 WRX Limited
World rally blue

Default

Quote:
Originally Posted by jwongx27
1.2011 subaru wrx sedan swp
2.100miles
3. both side driver and passenger
4. blinking super fast non stop

im working 12 hours a day and they want me to leave the car a few days...
Took my dealer an hour to fix the issue. They knew the fix and went right to work on it.
ndtechie_rx8 is offline   Reply With Quote
Old 02-03-2012, 11:20 AM   #111
cheenew
Scooby Newbie
 
Member#: 148306
Join Date: May 2007
Location: NorCal
Vehicle:
2011 STi
DGM

Default

1. 2011 Subaru WRX STi
2. Initially @ ~1100, intermittent. Currently @ ~4900
3. Driver's side
4. NA
5. Finally got around to looking at it. Loosened battery tie down, turned signal on and fiddled with connector (going to turn signal). Could see changes (blinking fast to slow). Probably a electrical contact issue.
cheenew is offline   Reply With Quote
Old 02-04-2012, 02:15 PM   #112
AWD Freak
Scooby Specialist
 
Member#: 262593
Join Date: Oct 2010
Chapter/Region: MWSOC
Default

Was told by the master tech last night that the wires going into the turn signal need to be straight. Any bends in the wire will cause the wires to be pulled when parts move slightly when hitting bumps. Subaru doesn't like replacing the lights any more and that is the only way to get the new wire harness.
AWD Freak is offline   Reply With Quote
Old 02-13-2012, 07:19 PM   #113
wrxftw619
Scooby Newbie
 
Member#: 308008
Join Date: Jan 2012
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2012 WRX Sedan
Plasma Blue Pearl

Default

it's evident in the '12 wrx as well. I have 400 miles on mine and it's already blinking fast. got an appointment tomorrow to get it fixed. wanted to do it myself but would rather not get blamed if anything else goes bad
wrxftw619 is offline   Reply With Quote
Old 02-13-2012, 10:55 PM   #114
Yoshii
*** Banned ***
 
Member#: 286384
Join Date: Jun 2011
Chapter/Region: TXIC
Location: Houston
Default

1) 2012 WRX
2) 550
3) Right
4) Told me it was a recall and bring it in when convenient.
5) Have to see tomorrow, just happened today.
Yoshii is offline   Reply With Quote
Old 02-13-2012, 10:55 PM   #115
Yoshii
*** Banned ***
 
Member#: 286384
Join Date: Jun 2011
Chapter/Region: TXIC
Location: Houston
Default

1) 2012 WRX
2) 550
3) Right
4) Told me it was a recall and bring it in when convenient.
5) Have to see tomorrow, just happened today.
Yoshii is offline   Reply With Quote
Old 02-14-2012, 07:18 PM   #116
L8Braker
Scooby Newbie
 
Member#: 297987
Join Date: Oct 2011
Location: North Carolina
Vehicle:
2011 WRX-Limited
Blue Pearl

Default

1) 2011 Wrx Sedan
2) 5012
3) Drivers side
5) Straightened wires, issue corrected for now.
L8Braker is offline   Reply With Quote
Old 02-14-2012, 09:46 PM   #117
HeroCrank
Scooby Specialist
 
Member#: 301089
Join Date: Nov 2011
Chapter/Region: NESIC
Location: MAINE
Vehicle:
2011 WRX 5 door
TP stage 2

Default

My Car:
1) 2011 WRX
2) 2400 miles
3) Left
4) Charlies Subaru
5) Dealer said it was a bulb/ Warranty
HeroCrank is offline   Reply With Quote
Old 02-16-2012, 07:46 PM   #118
malloy
Scooby Newbie
 
Member#: 307872
Join Date: Jan 2012
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2013 WRX
DGM

Default

2008 WRX 42,000 miles left blinks fast then slow then fast haven't brought it in im just gonna change the bulbs!
malloy is offline   Reply With Quote
Old 02-20-2012, 05:52 PM   #119
Ptown_finezT
Scooby Newbie
 
Member#: 308190
Join Date: Jan 2012
Chapter/Region: TXIC
Location: pasadena,tx
Vehicle:
2012 wrx hatch
dgm,2010 swp legacy prem.

Default

1) 2012 wrx hatch
2) 155 miles
3) driver side
4) gillman subaru
5) recall,fixed right up
Ptown_finezT is offline   Reply With Quote
Old 02-21-2012, 05:09 PM   #120
piecemealBHC
Scooby Specialist
 
Member#: 106248
Join Date: Jan 2006
Chapter/Region: NESIC
Location: New Hampshire
Vehicle:
2015 WRX CWP
2000 RS 2.5

Default

1) 2011 hatch
2)~15000 miles
3) passenger front

Fixed myself by rerouting wires.
piecemealBHC is offline   Reply With Quote
Old 02-27-2012, 08:41 PM   #121
bretthejet26
Scooby Newbie
 
Member#: 311192
Join Date: Feb 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2011 WRX Sedan
OBP

Default

2011
drivers side
1500 miles. happend on 2 occasions. now with 3200 miles hasnt happend since
bretthejet26 is offline   Reply With Quote
Old 03-08-2012, 02:13 PM   #122
RockyMtnGT
Scooby Newbie
 
Member#: 127953
Join Date: Oct 2006
Chapter/Region: RMIC
Vehicle:
2012 WRX
Ice Silver Metallic

Default

1) 2012 wrx hatch
2) 555 miles
3) Both sides (intermittently)
4) Mike Shaw Subaru (CO)
5) I can easily fix it, but I am bringing to the dealer on Saturday- They are also fixing the rattling door cards/speakers and the hatch plastic that rattles. I have better things to do, at least while it is under warranty
RockyMtnGT is offline   Reply With Quote
Old 03-15-2012, 01:08 PM   #123
mark729
Scooby Newbie
 
Member#: 149138
Join Date: May 2007
Chapter/Region: MWSOC
Location: Elgin엘진/IL
Vehicle:
11 WRX STi
Lightning Red

Default

2011 Sti.
31000 miles
Driver side since this morning.
Will take her to dealer.
mark729 is offline   Reply With Quote
Old 04-07-2012, 11:31 PM   #124
Allen Horton
Scooby Newbie
 
Member#: 315961
Join Date: Apr 2012
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2008 WRX
Dark gray metallic

Default

I am also relieved that I am not the only one. 2008 WRX, just had my front left go out today. Im not taking off my whole front end just for a bulb. WARRANTY!!! Have they devised a permanent fix? Or at least why they seem to g out so often?
Allen Horton is offline   Reply With Quote
Old 04-07-2012, 11:32 PM   #125
Allen Horton
Scooby Newbie
 
Member#: 315961
Join Date: Apr 2012
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2008 WRX
Dark gray metallic

Default

Sorry, 2008 WRX, 18500 miles, Front left. Will take to dealer on monday.
Allen Horton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signal problem 08 wrx !kid Electrical & Lighting 21 01-17-2013 02:59 PM
FS : 08-11 STi LED Turn Signal Mirrors WRX Conversion bustedstuff210 Exterior/Styling 9 02-21-2012 01:24 AM
2001 Outback Fast Driver's Side Turn Signal steelheadbum Newbies & FAQs 1 11-03-2010 06:22 AM
Fast Turn Signal Handsdown Electrical & Lighting 15 12-03-2008 12:03 PM
Help: Right turn signal flashing twice as fast... Silver04DE Electrical & Lighting 10 09-09-2004 10:06 AM


All times are GMT -4. The time now is 08:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.