Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-21-2012, 08:27 PM   #1
tibug
Scooby Specialist
 
Member#: 273906
Join Date: Feb 2011
Chapter/Region: NESIC
Location: Nonsense Poopy Pants!
Vehicle:
2003 Outback
RUST

Default What O2 sensor will ACTUALLY FIT my '99 Impreza 2.2?

Hey guys, I've been having a mess of trouble lately with O2 sensors and harnesses between my two Subarus. Right now, I'm trying to find the right front sensor for my 1999 Impreza Outback Sport 2.2l 5MT. I ordered a Denso from Amazon that claimed proper fitment. This one right here:

Denso 234-3091 Oxygen Sensor : Amazon.com : AutomotiveDenso 234-3091 Oxygen Sensor : Amazon.com : Automotive

It has a 3 pin triangle shaped connector as opposed to my square 4 pin clip. I double checked the part number and checked the specific sensor I received to make sure it was the one advertised...everything matches up...except the O2 sensor to the car.

I could keep ordering stuff, but I was wondering if anyone had a definitive idea on which one I need.

Edit: I'm currently running with no O2 sensor connected. Car runs normal as far as I can tell-I've heard other people say it will make it run like ****.
* Registered users of the site do not see these ads.
tibug is offline   Reply With Quote
Old 09-21-2012, 09:15 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Uncle Scotty is offline   Reply With Quote
Old 09-22-2012, 12:25 AM   #3
tibug
Scooby Specialist
 
Member#: 273906
Join Date: Feb 2011
Chapter/Region: NESIC
Location: Nonsense Poopy Pants!
Vehicle:
2003 Outback
RUST

Default

Thank you! I found some pictures of that one and the connector looks like the one I need. Much appreciated.
tibug is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.