Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-18-2013, 07:07 PM   #2751
fl4tpower
Scooby Specialist
 
Member#: 282664
Join Date: May 2011
Chapter/Region: MAIC
Location: Yorktown, Virginia
Vehicle:
2011 STi ltd Stage 2
Obsidian Black Pearl

Default

Yea I don't know if I'll hit the max duty cycle on the injectors with. Don't want that at all. Not looking to do any more engine mods soon so I'm debating.
* Registered users of the site do not see these ads.
fl4tpower is offline   Reply With Quote
Old 02-18-2013, 07:11 PM   #2752
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

I would think your tuner could tune it like that just fine...... Actually this sounds like a question you should ask him, would net you the best answer for sure.
PearlRex11 is online now   Reply With Quote
Old 02-18-2013, 07:17 PM   #2753
fl4tpower
Scooby Specialist
 
Member#: 282664
Join Date: May 2011
Chapter/Region: MAIC
Location: Yorktown, Virginia
Vehicle:
2011 STi ltd Stage 2
Obsidian Black Pearl

Default

Yea I did. He said its up to me either way. He could tune it with or without the new pump. Just seeing if there was any other benefits to getting it. Thanks
fl4tpower is offline   Reply With Quote
Old 02-18-2013, 07:58 PM   #2754
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Quote:
Originally Posted by fl4tpower View Post
Yea I did. He said its up to me either way. He could tune it with or without the new pump. Just seeing if there was any other benefits to getting it. Thanks
Not until you do more mods
Celery GT-5 is online now   Reply With Quote
Old 02-18-2013, 08:08 PM   #2755
fl4tpower
Scooby Specialist
 
Member#: 282664
Join Date: May 2011
Chapter/Region: MAIC
Location: Yorktown, Virginia
Vehicle:
2011 STi ltd Stage 2
Obsidian Black Pearl

Default

Yea that's not happening any time soon. I'm very happy with the cars performance now. Thanks for the input guys.
fl4tpower is offline   Reply With Quote
Old 02-20-2013, 09:47 AM   #2756
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

Can someone do me a solid and figure out what this piece is? I think it slips onto that bolt in the 2nd pic, right next to the dead pedal, but the thing keeps falling off.

https://www.icloud.com/photostream/#A4GgZLKuJ5UKDg
Asharus is offline   Reply With Quote
Old 02-20-2013, 12:57 PM   #2757
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

Quote:
Originally Posted by Asharus View Post
Can someone do me a solid and figure out what this piece is? I think it slips onto that bolt in the 2nd pic, right next to the dead pedal, but the thing keeps falling off.

https://www.icloud.com/photostream/#A4GgZLKuJ5UKDg
Mine came off a while ago and I lost it haha. Never have replaced it
tcoffin014 is offline   Reply With Quote
Old 02-20-2013, 12:58 PM   #2758
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

so am i right to assume that the spot pictured is where its supposed to be?
Asharus is offline   Reply With Quote
Old 02-20-2013, 02:35 PM   #2759
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

That's what it looks like. Mine looked a little different I think but maybe yours is cracked or something
tcoffin014 is offline   Reply With Quote
Old 02-20-2013, 02:35 PM   #2760
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

Maybe ask subtle solutions if you're really worried about it, since they make a replacement.
_davin is offline   Reply With Quote
Old 02-20-2013, 02:45 PM   #2761
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

hmm yeah, its probably broken. i remember my shop had that whole area torn apart when they were installing my gauges.
Asharus is offline   Reply With Quote
Old 03-01-2013, 04:58 PM   #2762
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

yay
Celery GT-5 is online now   Reply With Quote
Old 03-07-2013, 07:34 PM   #2763
Project Z
Scooby Newbie
 
Member#: 346192
Join Date: Feb 2013
Location: Pa
Vehicle:
2012 Wrx
Plasma blue

Default

I am very curious about a rear tow hook for my 2012 wrx 5-door and if anyone knows anything about it plz message me back? I'm also new to this website so I'm not sure how to use it yet.
Project Z is offline   Reply With Quote
Old 03-07-2013, 08:09 PM   #2764
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
Imperial White

Default

One came with the car, the little square piece pops out and you screw it in.

Unless youre after an aftermarket version, then hit up teh googles
SWP is Sexy is offline   Reply With Quote
Old 03-07-2013, 08:46 PM   #2765
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

Yeah, owner's manual yo...
_davin is offline   Reply With Quote
Old 03-22-2013, 08:08 PM   #2766
Only1Wrx
Scooby Newbie
 
Member#: 300799
Join Date: Nov 2011
Chapter/Region: NWIC
Location: Arlington, WA
Vehicle:
2011 Impreza WRX
Blue Pearl MR

Default

This morning my car would not start when I first turned the key. It revved and wanted to start. The second time I turned the key it started. This just happened again right now and this would be about the 6th time total within 2 years. (Spaced out about every 4 months it happens). Any ideas? Would it be my starter?
Only1Wrx is offline   Reply With Quote
Old 03-22-2013, 08:19 PM   #2767
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

sometimes you need to hold the key longer than other cars..my car sounds unhappy when I start it in the cold.

you should probably check the battery before the starter
Celery GT-5 is online now   Reply With Quote
Old 03-22-2013, 09:40 PM   #2768
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

If it was the battery it wouldn't start at all.
What do you mean by revved and wanted to start? Unless you're saying that you just turn the key and let go of it to start your car, in which case I'm surprised it usually starts at all and like Celery said you have to hold it down for a second.
_davin is offline   Reply With Quote
Old 03-22-2013, 10:17 PM   #2769
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Quote:
Originally Posted by _davin View Post
If it was the battery it wouldn't start at all.
What do you mean by revved and wanted to start? Unless you're saying that you just turn the key and let go of it to start your car, in which case I'm surprised it usually starts at all and like Celery said you have to hold it down for a second.
Batteries die slowly, first it will be hard to start and then eventually it won't start at all. If it's having a charging issue sometimes it will only stay on if you keep the revs up for a while, not that common though. Just check the voltage to start with and go from there.
Celery GT-5 is online now   Reply With Quote
Old 03-22-2013, 10:21 PM   #2770
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

Quote:
Originally Posted by Celery GT-5 View Post
Batteries die slowly, first it will be hard to start and then eventually it won't start at all. If it's having a charging issue sometimes it will only stay on if you keep the revs up for a while, not that common though. Just check the voltage to start with and go from there.
OK you just said revs too, wtf are you talking about. Are you saying while it's running? If the car dies while it's running due an electrical issue it's the alternator.
_davin is offline   Reply With Quote
Old 03-22-2013, 10:26 PM   #2771
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Quote:
Originally Posted by _davin View Post
OK you just said revs too, wtf are you talking about. Are you saying while it's running? If the car dies while it's running due an electrical issue it's the alternator.
I had an issue with my Dakota where I left my headlights on to light up a basketball court and after that it wouldn't stay on unless u held the revs up for a few mins. I found out after I got rid of it that it was a just a bad battery. Alternator failure is the opposite, it will start and then die after you drive it for a while because it's running entirely off the battery.
Celery GT-5 is online now   Reply With Quote
Old 03-22-2013, 11:06 PM   #2772
xabre1200
Scooby Specialist
 
Member#: 259591
Join Date: Oct 2010
Location: San Francisco, California
Vehicle:
2011 WRX sedan
WR Blue

Default

Deno if anyone is also having this issue but I noticed it in my 2011 WRX that if I accidentally lug my car a little bit like if I'm in a parking lot and I'm moving around at 1mph trying to find a spot that when I try and start up my car it hesitates before it fully turns over. I've been able to replicate this problem pretty much every time which is starting to make me worry.

If my car starts up funny I can turn it off and when I try and start it up the second time there is no hesitation and it starts right up.

Any ideas on what this might be? I was thinking maybe a dirty MAF sensor?
xabre1200 is offline   Reply With Quote
Old 03-22-2013, 11:16 PM   #2773
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Quote:
Originally Posted by xabre1200 View Post
Deno if anyone is also having this issue but I noticed it in my 2011 WRX that if I accidentally lug my car a little bit like if I'm in a parking lot and I'm moving around at 1mph trying to find a spot that when I try and start up my car it hesitates before it fully turns over. I've been able to replicate this problem pretty much every time which is starting to make me worry.

If my car starts up funny I can turn it off and when I try and start it up the second time there is no hesitation and it starts right up.

Any ideas on what this might be? I was thinking maybe a dirty MAF sensor?
Have you guys tried giving the fuel pump a few seconds to prime in the on position before cranking?
Celery GT-5 is online now   Reply With Quote
Old 03-22-2013, 11:26 PM   #2774
xabre1200
Scooby Specialist
 
Member#: 259591
Join Date: Oct 2010
Location: San Francisco, California
Vehicle:
2011 WRX sedan
WR Blue

Default

Quote:
Originally Posted by Celery GT-5 View Post
Have you guys tried giving the fuel pump a few seconds to prime in the on position before cranking?
Yeah I thought I was cranking too quickly so I'd let my fuel pump prime for about 5 seconds before cranking but when I feel like I lugged my car a tiny bit before parking it, the car is going to hesitate when starting...

The car cranks and you can hear it start but when you hear the engine strain a little bit before it starts.
xabre1200 is offline   Reply With Quote
Old 03-22-2013, 11:30 PM   #2775
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

one time I launched my car and after I slowed down the idle got all bouncy
Celery GT-5 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differences of 2011 wrx motor and 2011 sti motor stpkenton Factory 2.5L Turbo Powertrain 3 03-06-2012 11:03 AM
Differences of 2011 wrx motor and 2011 sti motor stpkenton Newbies & FAQs 3 05-12-2011 09:27 PM
2011 Subaru shifter fitment! All TWM Shifters still fit! TWM Performance Vendor Announcements 14 02-28-2011 03:27 PM
iPod 3g DLO Jam Jacket (clear) and Radtech 3g Indigo Podsleev 10gb/15gb agentmaxwell Private 'For Sale' Classifieds 1 05-24-2006 07:41 PM
Attn: Clayton, Ben and all others involved in the 6MT discussion. sherifx Mid West Subaru Owners Club Forum -- MWSOC 1 07-31-2002 03:00 AM


All times are GMT -4. The time now is 09:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.