Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-10-2013, 06:25 PM   #3276
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

yeah i get little oddities when I'm cruising too..but its been better...weird
* Registered users of the site do not see these ads.
Celery GT-5 is online now   Reply With Quote
Old 09-10-2013, 08:55 PM   #3277
rwfloberg
Scooby Newbie
 
Member#: 327538
Join Date: Jul 2012
Chapter/Region: MAIC
Location: La Plata MD
Vehicle:
2012 WRX (307/344)
SWP

Default

Im coming up on brakes. How noticeable is getting stainless steel lines? Also, are most of you getting rotors on first pad change, or simply pads. Ive always done just pads in the past, but under light braking I get a minor wheel shimmy.
rwfloberg is offline   Reply With Quote
Old 09-10-2013, 08:58 PM   #3278
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

my pads are still good at 60k, what mileage are you at?
Asharus is offline   Reply With Quote
Old 09-10-2013, 09:00 PM   #3279
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Celery GT-5 is online now   Reply With Quote
Old 09-10-2013, 09:34 PM   #3280
rwfloberg
Scooby Newbie
 
Member#: 327538
Join Date: Jul 2012
Chapter/Region: MAIC
Location: La Plata MD
Vehicle:
2012 WRX (307/344)
SWP

Default

35k
Maybe im being a little ambitious with brake change lol
rwfloberg is offline   Reply With Quote
Old 09-10-2013, 09:41 PM   #3281
Louie
Scooby Guru
 
Member#: 43393
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Middle River
Vehicle:
2011 STi
WRB

Default

Quote:
Originally Posted by rwfloberg View Post
Im coming up on brakes. How noticeable is getting stainless steel lines? Also, are most of you getting rotors on first pad change, or simply pads. Ive always done just pads in the past, but under light braking I get a minor wheel shimmy.
SS lines are good.. Less pedal squish... Master cylinder brace is a good pedal feel mod
Louie is offline   Reply With Quote
Old 09-10-2013, 09:58 PM   #3282
Dka67
Scooby Specialist
 
Member#: 296721
Join Date: Oct 2011
Chapter/Region: SCIC
Location: Montebello
Vehicle:
11 5door
SWP

Default

Quote:
Originally Posted by Louie View Post

SS lines are good.. Less pedal squish... Master cylinder brace is a good pedal feel mod
This^. And Oil!
Dka67 is offline   Reply With Quote
Old 09-10-2013, 10:03 PM   #3283
Louie
Scooby Guru
 
Member#: 43393
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Middle River
Vehicle:
2011 STi
WRB

Default

Quote:
Originally Posted by rwfloberg View Post
35k
Maybe im being a little ambitious with brake change lol
Btw, I replaced my brakes at 5k miles
Louie is offline   Reply With Quote
Old 09-10-2013, 11:11 PM   #3284
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

Quote:
Originally Posted by rwfloberg View Post
35k
Maybe im being a little ambitious with brake change lol
nah, just depends on driving conditions. im about 80% highway and im really good at engine braking / not tailgaiting so i dont use the brakes much.
Asharus is offline   Reply With Quote
Old 09-10-2013, 11:14 PM   #3285
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

i want to do the brakes just because they feel crappy lol
Celery GT-5 is online now   Reply With Quote
Old 09-11-2013, 06:39 AM   #3286
Louie
Scooby Guru
 
Member#: 43393
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Middle River
Vehicle:
2011 STi
WRB

Default

Quote:
Originally Posted by Asharus View Post

nah, just depends on driving conditions. im about 80% highway and im really good at engine braking / not tailgaiting so i dont use the brakes much.
...because you use your feet to slow your 3300lb sled to a stop? Just kidding. I wish I has more highway miles on mine
Louie is offline   Reply With Quote
Old 09-11-2013, 12:10 PM   #3287
rwfloberg
Scooby Newbie
 
Member#: 327538
Join Date: Jul 2012
Chapter/Region: MAIC
Location: La Plata MD
Vehicle:
2012 WRX (307/344)
SWP

Default

Im probably 75% highway

Loui do you think the stainless steel lines are worth the $100? Mines a DD seen a drag strip twice. Im willing to spend the money if its a worthwhile upgrade, but if its just a marginal upgrade Id rather spend $100 elsewhere
rwfloberg is offline   Reply With Quote
Old 09-13-2013, 10:08 AM   #3288
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

I just had to go talking about how my blinker was fixed. I've noticed it do the fast blinking a couple of times but only right when I turn it on then it goes to normal. Maybe the bulb is actually going out this time
tcoffin014 is offline   Reply With Quote
Old 09-13-2013, 10:31 AM   #3289
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
Imperial White

Default

Did you have the dealership replace the wiring already? That was a very common problem, happened to mine within 1k and I just took it into the dealership and they had it fixed within an hour
SWP is Sexy is offline   Reply With Quote
Old 09-13-2013, 10:35 AM   #3290
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

i wiggled it and its been fine for over 2 years lol
Celery GT-5 is online now   Reply With Quote
Old 09-13-2013, 10:47 AM   #3291
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

mine started acting up after about 3 months or less. i read about the harness issue here and took it in and told them about it. all they did was replace the bulb though, no problems since.
Asharus is offline   Reply With Quote
Old 09-13-2013, 10:48 AM   #3292
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

btw that was the only warranty work theyve performed on the car, besides the weak fuel door spring. now im at 60k miles
Asharus is offline   Reply With Quote
Old 09-15-2013, 10:02 PM   #3293
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

got some conti DW's ftw

they seem way better for highway cruising

also currently reading 27.9mpg after about 200 miles of driving
Celery GT-5 is online now   Reply With Quote
Old 09-16-2013, 12:15 AM   #3294
xabre1200
Scooby Specialist
 
Member#: 259591
Join Date: Oct 2010
Location: San Francisco, California
Vehicle:
2011 WRX sedan
WR Blue

Default

Wanna update you guys on my car. About 2 weeks ago I took my car into the dealership to diagnose a funny whirling noise I was hearing in my transmission. Dealership found it was a misaligned part in the tranny, fixed it and sent me along my way. That night I noticed my clutch creaking as I let the clutch up from the floor though not when I pressed it down. I had a similar issue a year ago where I had a defective throw out bearing and had that warrantied.

I brought my car back to the dealership and they called me the next day saying I've got a defective pressure plate and theyre going to need to basically do the same thing they did on my car a year ago.

I'm glad that they're going to give me a new clutch and all but I'm worried about this happening again in a year. Is my car just being a lemon or do I just have some massive bad luck. They say my clutch wear is normal and told me they were both manufacture defects... any one have any insight? I'm just worried about this happening again and my car not being under warranty in a few years.
xabre1200 is offline   Reply With Quote
Old 09-16-2013, 01:44 AM   #3295
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by xabre1200 View Post
Wanna update you guys on my car. About 2 weeks ago I took my car into the dealership to diagnose a funny whirling noise I was hearing in my transmission. Dealership found it was a misaligned part in the tranny, fixed it and sent me along my way. That night I noticed my clutch creaking as I let the clutch up from the floor though not when I pressed it down. I had a similar issue a year ago where I had a defective throw out bearing and had that warrantied.

I brought my car back to the dealership and they called me the next day saying I've got a defective pressure plate and theyre going to need to basically do the same thing they did on my car a year ago.

I'm glad that they're going to give me a new clutch and all but I'm worried about this happening again in a year. Is my car just being a lemon or do I just have some massive bad luck. They say my clutch wear is normal and told me they were both manufacture defects... any one have any insight? I'm just worried about this happening again and my car not being under warranty in a few years.
I've heard that a lot of people have been having clutch related issues. I know mine had to be replaced under warranty due to slipping when taking of and squeaking due to the excessive amount pressure needed to press my clutch in. I hope mine lasts me longer than another 25k.
PearlRex11 is offline   Reply With Quote
Old 09-16-2013, 02:38 AM   #3296
xabre1200
Scooby Specialist
 
Member#: 259591
Join Date: Oct 2010
Location: San Francisco, California
Vehicle:
2011 WRX sedan
WR Blue

Default

Quote:
Originally Posted by PearlRex11 View Post
I've heard that a lot of people have been having clutch related issues. I know mine had to be replaced under warranty due to slipping when taking of and squeaking due to the excessive amount pressure needed to press my clutch in. I hope mine lasts me longer than another 25k.
Yeah it's a real shame. I'm worried about this issue in the long run especially since it's the 2nd time it's happened to me.
xabre1200 is offline   Reply With Quote
Old 09-16-2013, 06:07 PM   #3297
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

I had the squeak too. The first time they replaced the throw out bearing and clutch fork. They said it was wearing weird. The second time the replaced the clutch fork, master cylinder, slave cylinder? (maybe), and I bought an aftermarket clutch kit with flywheel, clutch disk, pressure plate and throw out bearing. It was doing fine for a while after all of that. Now it's starting to squeak again. I have no idea what it is but I'm starting to think it's just one of those weird things that has no cure for now. I'm just hoping it won't ruin my car. I have 45000 miles. I just want to sell my car and get an 07 sti
tcoffin014 is offline   Reply With Quote
Old 09-16-2013, 06:20 PM   #3298
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Car is misfiring again
Celery GT-5 is online now   Reply With Quote
Old 09-16-2013, 06:51 PM   #3299
rsutton1223
Scooby Specialist
 
Member#: 280744
Join Date: Apr 2011
Chapter/Region: South East
Location: Alpharetta, GA
Vehicle:
2009 CTSV 6MT 537whp
Black Raven

Default

You guys need to mod more. No issues here.
rsutton1223 is offline   Reply With Quote
Old 09-16-2013, 07:10 PM   #3300
corvid
Scooby Specialist
 
Member#: 300097
Join Date: Nov 2011
Default

Quote:
Originally Posted by Celery GT-5 View Post
Car is misfiring again
Same.
corvid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differences of 2011 wrx motor and 2011 sti motor stpkenton Factory 2.5L Turbo Powertrain 3 03-06-2012 11:03 AM
Differences of 2011 wrx motor and 2011 sti motor stpkenton Newbies & FAQs 3 05-12-2011 09:27 PM
2011 Subaru shifter fitment! All TWM Shifters still fit! TWM Performance Vendor Announcements 14 02-28-2011 03:27 PM
iPod 3g DLO Jam Jacket (clear) and Radtech 3g Indigo Podsleev 10gb/15gb agentmaxwell Private 'For Sale' Classifieds 1 05-24-2006 07:41 PM
Attn: Clayton, Ben and all others involved in the 6MT discussion. sherifx Mid West Subaru Owners Club Forum -- MWSOC 1 07-31-2002 03:00 AM


All times are GMT -4. The time now is 01:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.