Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-16-2013, 07:46 PM   #3301
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by rsutton1223 View Post
You guys need to mod more. No issues here.
Strangely enough you're probably right lol
* Registered users of the site do not see these ads.
PearlRex11 is offline   Reply With Quote
Old 09-16-2013, 07:49 PM   #3302
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

did it just start today? mine has been fine for a while
Celery GT-5 is online now   Reply With Quote
Old 09-16-2013, 07:50 PM   #3303
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Quote:
Originally Posted by PearlRex11 View Post
Strangely enough you're probably right lol
seriously removing all the stupid emission nonsense would probably help a lot

my new 1994 cherokee with 190700 miles idles totally smooth..lol
Celery GT-5 is online now   Reply With Quote
Old 09-16-2013, 07:56 PM   #3304
corvid
Scooby Specialist
 
Member#: 300097
Join Date: Nov 2011
Default

Started like usual, with little hints here and there, followed harsh shuddering/bucking this weekend.
corvid is offline   Reply With Quote
Old 09-16-2013, 08:14 PM   #3305
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

weak...
Celery GT-5 is online now   Reply With Quote
Old 09-17-2013, 01:35 AM   #3306
xabre1200
Scooby Specialist
 
Member#: 259591
Join Date: Oct 2010
Location: San Francisco, California
Vehicle:
2011 WRX sedan
WR Blue

Default

Damn I'm thinking about either waiting for the next gen WRX to come out or possibly go... BMW :O
xabre1200 is offline   Reply With Quote
Old 09-17-2013, 01:48 AM   #3307
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
Imperial White

Default

As long as you're not switching to something German to avoid maintenance problems
SWP is Sexy is offline   Reply With Quote
Old 09-17-2013, 08:07 PM   #3308
corvid
Scooby Specialist
 
Member#: 300097
Join Date: Nov 2011
Default

hey celery what size tires did you get? Ill probably end up getting the DWS in 235, unless DW is adequate for snow, which I doubt.
corvid is offline   Reply With Quote
Old 09-17-2013, 08:14 PM   #3309
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

just got a set of DWS tires myself, stock size

my OEMs lasted 60k miles.
Asharus is offline   Reply With Quote
Old 09-17-2013, 08:17 PM   #3310
corvid
Scooby Specialist
 
Member#: 300097
Join Date: Nov 2011
Default

cant have summer tires around here, too cold let alone snow and ice, although they were nice while I had them
corvid is offline   Reply With Quote
Old 09-17-2013, 08:39 PM   #3311
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Quote:
Originally Posted by corvid View Post
hey celery what size tires did you get? Ill probably end up getting the DWS in 235, unless DW is adequate for snow, which I doubt.
stock size 235/45-17

The S in DWS stands for snow so no the DW will not cut it


Quote:
Originally Posted by Asharus View Post
just got a set of DWS tires myself, stock size

my OEMs lasted 60k miles.
my stock tires still had a lot of tread overall but the inner edges were worn pretty bad, all the way through the tread in some cases, my brother's shop thinks it was shock wear, probably from the OEM shocks with drop springs not dampening the bumps properly because the alignment was in spec despite me installing my konis. The tires probably only have 16-20k on them since I have snow tires also.
Celery GT-5 is online now   Reply With Quote
Old 09-17-2013, 08:46 PM   #3312
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
Imperial White

Default

60k? Damn, I'm at 30k and starting to think I'll need to replace them sometime next year. I haven't even tracked it
SWP is Sexy is offline   Reply With Quote
Old 09-17-2013, 09:27 PM   #3313
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

60k on a 2011 has to be mostly highway miles I would think
Celery GT-5 is online now   Reply With Quote
Old 09-18-2013, 12:27 AM   #3314
honestabe
Scooby Specialist
 
Member#: 261730
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX hatch
WRB

Default

Do you guys notice that on some days your car runs noticeably different than on other days? Maybe it's the colder temps out here on the east coast recently, today it just seemed like the car ran with a bit more zip. Not using A/C is prbly also part of it.
honestabe is online now   Reply With Quote
Old 09-18-2013, 01:11 AM   #3315
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
Imperial White

Default

Quote:
Originally Posted by honestabe View Post
Do you guys notice that on some days your car runs noticeably different than on other days? Maybe it's the colder temps out here on the east coast recently, today it just seemed like the car ran with a bit more zip. Not using A/C is prbly also part of it.
SWP is Sexy is offline   Reply With Quote
Old 09-18-2013, 01:13 AM   #3316
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

I've noticed it. I don't think mine is because of the weather though. I've looked at the outside temp and haven't noticed that being the difference. Can't put my finger on what it is.
PearlRex11 is offline   Reply With Quote
Old 09-18-2013, 08:59 AM   #3317
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

Quote:
Originally Posted by Celery GT-5 View Post
stock size 235/45-17

The S in DWS stands for snow so no the DW will not cut it




my stock tires still had a lot of tread overall but the inner edges were worn pretty bad, all the way through the tread in some cases, my brother's shop thinks it was shock wear, probably from the OEM shocks with drop springs not dampening the bumps properly because the alignment was in spec despite me installing my konis. The tires probably only have 16-20k on them since I have snow tires also.

same here, still had plenty of tread at 60k, except my front right tire was worn on the inside. it was an alignment issue, too much positive camber.

Quote:
Originally Posted by Celery GT-5 View Post
60k on a 2011 has to be mostly highway miles I would think
Yep about 80/20 highway, 100 miles round trip 5 days a week

Quote:
Originally Posted by corvid View Post
cant have summer tires around here, too cold let alone snow and ice, although they were nice while I had them
im in NY and i braved 2 winters on my OEM summers. worked just fine, just dont drive like a madman when there's snow/ice on the road. i remember flooring it from a stop one time with traction control off last year just to see what happens. the car just went to redline in first gear w/o moving an inch, lol
Asharus is offline   Reply With Quote
Old 09-18-2013, 09:37 AM   #3318
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

the awd will get you going but you really don't have much control with the summer tires if you have to stop or turn suddenly.
Celery GT-5 is online now   Reply With Quote
Old 09-18-2013, 09:53 AM   #3319
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
349awhp/366tq @19psi E85

Default

Quote:
Originally Posted by Celery GT-5 View Post
the awd will get you going but you really don't have much control with the summer tires if you have to stop or turn suddenly.
yep, i had one incident at a stop sign. i was moving very slowly, prob 10mph or less, not even tailgating, prob at least 5 carlengths behind the lead car.

the car woudlnt stop, i had to veer into the oncoming traffic lane to avoid rear ending the car at the stop sign.

good thing there were no cars heading the opposite direction...

it was one of those days when i got caught out in the snow. it wasnt snowing when i left to pick up my AR15 and the entire trip took 1 hour.
Asharus is offline   Reply With Quote
Old 09-18-2013, 10:02 AM   #3320
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

snow tires ftw
Celery GT-5 is online now   Reply With Quote
Old 09-19-2013, 01:04 PM   #3321
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

Quote:
Originally Posted by Asharus View Post

same here, still had plenty of tread at 60k, except my front right tire was worn on the inside. it was an alignment issue, too much positive camber.
I had the same problem. My front right tire wore through to the band at about 40k miles. It was from the negative camber. I noticed when it started to wobble lol. So I got new tires and alignment and got them to max out the negative camber in the front haha. Definitely won't help tire wear but it does help turn in quite a bit.
tcoffin014 is online now   Reply With Quote
Old 09-19-2013, 01:07 PM   #3322
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

yeah I apparently have maximum negative camber too lol

I think I'm going to go unbolt my muffler and hoon around

then go back to stock and sell the dual tip that no one likes lol
Celery GT-5 is online now   Reply With Quote
Old 09-19-2013, 11:09 PM   #3323
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

Quote:
Originally Posted by Celery GT-5 View Post
yeah I apparently have maximum negative camber too lol

I think I'm going to go unbolt my muffler and hoon around

then go back to stock and sell the dual tip that no one likes lol
Haha I did that before I got my exhaust. Be careful though I blew out the tow hook cover and reflector from the exhaust blowing right on it haha but that was right before i had the bumper repainted from some lady backing into me so they added those in too when they fixed it
tcoffin014 is online now   Reply With Quote
Old 09-19-2013, 11:14 PM   #3324
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Sounds pretty good with no muffler but the warm up idle is just unacceptable lol.

Idk now I miss my dual tip. I think the peer pressure got to me, I might just put it back.. Stock is too quiet
Celery GT-5 is online now   Reply With Quote
Old 09-19-2013, 11:24 PM   #3325
corvid
Scooby Specialist
 
Member#: 300097
Join Date: Nov 2011
Default

so...whats the consensus on breaking a new wrx? babying it for the first 1000 vs varying speeds and no cruise control vs driving it like you stole it for the first 1000
corvid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differences of 2011 wrx motor and 2011 sti motor stpkenton Factory 2.5L Turbo Powertrain 3 03-06-2012 11:03 AM
Differences of 2011 wrx motor and 2011 sti motor stpkenton Newbies & FAQs 3 05-12-2011 09:27 PM
2011 Subaru shifter fitment! All TWM Shifters still fit! TWM Performance Vendor Announcements 14 02-28-2011 03:27 PM
iPod 3g DLO Jam Jacket (clear) and Radtech 3g Indigo Podsleev 10gb/15gb agentmaxwell Private 'For Sale' Classifieds 1 05-24-2006 07:41 PM
Attn: Clayton, Ben and all others involved in the 6MT discussion. sherifx Mid West Subaru Owners Club Forum -- MWSOC 1 07-31-2002 03:00 AM


All times are GMT -4. The time now is 06:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.