Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-18-2011, 11:46 AM   #626
BullyWRX
Scooby Specialist
 
Member#: 258756
Join Date: Sep 2010
Chapter/Region: South East
Location: Wilimgton, NC
Vehicle:
2011 WRX
SWP

Default

Chan, call RA and tell them what happened, and that you need them to send you just one. I'm sure they'll help you out!
* Registered users of the site do not see these ads.
BullyWRX is offline   Reply With Quote
Old 12-20-2011, 10:40 AM   #627
Kyleemerson
Scooby Newbie
 
Member#: 275069
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Jersey Shore
Vehicle:
2011 WRX Stage 2+
WRB

Default

Just got a call from the service department of Subaru. This is what he told me. "the car has two catalytic converters and something went wrong with the first one which also messed up the second one" don't know why or anything he seemed like he didn't know much but he told me he is overnighting two new catalytic converters.
Kyleemerson is offline   Reply With Quote
Old 12-20-2011, 04:46 PM   #628
Callsign_Jester
Scooby Newbie
 
Member#: 234761
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2012 Mustang 5.0

Default

one probably fell apart and it's guts went down the line and clogged the second
Callsign_Jester is offline   Reply With Quote
Old 12-20-2011, 06:47 PM   #629
NineBreaker
Scooby Newbie
 
Member#: 237756
Join Date: Feb 2010
Location: AZ
Vehicle:
2011 2.5i Sedan
DGM

Default

Anyone notice an "fogging" or discoloration on their headlights? I haven't really cleaned them with anything specific aside from the soap at the DIY car wash station in town. Wondering if it's just my OCD getting to me or if something is wrong.
NineBreaker is offline   Reply With Quote
Old 12-20-2011, 10:07 PM   #630
Kyleemerson
Scooby Newbie
 
Member#: 275069
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Jersey Shore
Vehicle:
2011 WRX Stage 2+
WRB

Default

^that's exactly what happen when they took out the first cat they flipped it over and a bunch of crap fell out. It's funny a rep. from japan was their along with another rep. and they searched everything on my car. Diagnosed it to see if my ecu was flashed and everything....thank god I didn't get it tuned like I was planning. And I've noticed the same thing with my headlights even when I first got my car they would fog up and get all hazy and it's really annoying.
Kyleemerson is offline   Reply With Quote
Old 12-21-2011, 01:44 AM   #631
DGMFTW
Scooby Newbie
 
Member#: 302870
Join Date: Dec 2011
Chapter/Region: South East
Location: Fort Walton Beach,Fl
Vehicle:
2012 DGM WRX 5dr
2006 CBR 600RR

Default

I've got a 2012 I've had now for about 3 weeks. It's been really strange weather here and I've noticed in my headlights as well. Thats a recipe for.... No good. Isn't that how the inside of your headlight gets all yellow over time?
DGMFTW is offline   Reply With Quote
Old 12-21-2011, 02:15 AM   #632
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

I noticed it to. A light rub with "plastix" takes it right off and looks good as new. I believe it has a uv protection in it as well. Like $6 for a nice size bottle at walmart. I think mothers or another company makes it.
PearlRex11 is offline   Reply With Quote
Old 12-21-2011, 02:05 PM   #633
Callsign_Jester
Scooby Newbie
 
Member#: 234761
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2012 Mustang 5.0

Default

I don't have any of that going on with mine (factory HID's).
Callsign_Jester is offline   Reply With Quote
Old 12-21-2011, 02:11 PM   #634
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

the lights allow some condensation inside by design. I don't see any discoloration
Celery GT-5 is online now   Reply With Quote
Old 12-21-2011, 02:39 PM   #635
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Mine isn't due to condensation. I've tried wiping it with regular glass cleaner or soap and it won't come off. If I use the "plastix" it wipes right off.
PearlRex11 is offline   Reply With Quote
Old 12-23-2011, 06:36 PM   #636
NineBreaker
Scooby Newbie
 
Member#: 237756
Join Date: Feb 2010
Location: AZ
Vehicle:
2011 2.5i Sedan
DGM

Default

Quote:
Originally Posted by Celery GT-5 View Post
the lights allow some condensation inside by design. I don't see any discoloration
This might be it... I've rubbed it with my finger and wet news paper and nothing, seems to come and go..

Gotta be condensation, hadn't noticed it until we started getting a little more rain/snow.
NineBreaker is offline   Reply With Quote
Old 12-23-2011, 06:48 PM   #637
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

yeah I noticed condensation inside my lights when i first got the car about a year ago...there are is a thread about it I think or at least some posts
Celery GT-5 is online now   Reply With Quote
Old 12-23-2011, 09:50 PM   #638
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

I thought mine was condensation too, but someone I knew had that plastix stuff and he tried it out on my car. It took it right off. If it doesn't come off for you then you might want to try it out. If it comes out on its own then it must be condensation. Mine only did it on the higher part of the lens. I have had it happen again recently and it worked again for me. It also restores headlights that have minor yellowing, worked on my fiances headlights.
PearlRex11 is offline   Reply With Quote
Old 12-23-2011, 10:38 PM   #639
Kyleemerson
Scooby Newbie
 
Member#: 275069
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Jersey Shore
Vehicle:
2011 WRX Stage 2+
WRB

Default

I just used compound and it took it right out.
Kyleemerson is offline   Reply With Quote
Old 12-23-2011, 10:50 PM   #640
08fg2
Scooby Newbie
 
Member#: 281219
Join Date: Apr 2011
Chapter/Region: MAIC
Location: harrisonburg
Vehicle:
2012 wrx hatchback
satin white pearl

Default

Car through a Cel after giving a friend a ride. About 3rd gear it bogged and just through the light on.... Sage 2 Wrx...
08fg2 is offline   Reply With Quote
Old 12-23-2011, 11:06 PM   #641
08fg2
Scooby Newbie
 
Member#: 281219
Join Date: Apr 2011
Chapter/Region: MAIC
Location: harrisonburg
Vehicle:
2012 wrx hatchback
satin white pearl

Default

Reflashed the ecu again and it fired up as it did the first time I Reflashed. Took it a while to start up. then was bogging down in neutral as if it was about to stall and now perfect. Weird stuff..
08fg2 is offline   Reply With Quote
Old 12-24-2011, 12:09 AM   #642
BullyWRX
Scooby Specialist
 
Member#: 258756
Join Date: Sep 2010
Chapter/Region: South East
Location: Wilimgton, NC
Vehicle:
2011 WRX
SWP

Default

Quote:
Originally Posted by 08fg2 View Post
Reflashed the ecu again and it fired up as it did the first time I Reflashed. Took it a while to start up. then was bogging down in neutral as if it was about to stall and now perfect. Weird stuff..
Log that mess, and send it to your tuner. See if he can get you sorted out.
BullyWRX is offline   Reply With Quote
Old 12-24-2011, 12:11 AM   #643
08fg2
Scooby Newbie
 
Member#: 281219
Join Date: Apr 2011
Chapter/Region: MAIC
Location: harrisonburg
Vehicle:
2012 wrx hatchback
satin white pearl

Default

Will do that tomorrow. Hope it's nothing serious
08fg2 is offline   Reply With Quote
Old 12-24-2011, 12:13 AM   #644
BullyWRX
Scooby Specialist
 
Member#: 258756
Join Date: Sep 2010
Chapter/Region: South East
Location: Wilimgton, NC
Vehicle:
2011 WRX
SWP

Default

^^^^^^Me too. That would blow ass!
BullyWRX is offline   Reply With Quote
Old 12-24-2011, 01:01 AM   #645
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by Kyleemerson
I just used compound and it took it right out.
Yeah. Hard to explain. Kind of a haze over it. It looks like its just fogged on mine but it won't wipe off with normal car wash soap or glass cleaner.
PearlRex11 is offline   Reply With Quote
Old 12-27-2011, 04:09 PM   #646
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

$71.38 (includes shipping) to replace my missing mud flap.

Yaye or nay? Better than $175 for a whole new set, I guess.
chanomatik is offline   Reply With Quote
Old 12-27-2011, 04:10 PM   #647
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

So I've read that a front mount intercooler with stock everything else causes more turbo lag. What about a larger top mount intercooler? Stock WRX ones are so tiny!
chanomatik is offline   Reply With Quote
Old 12-27-2011, 05:10 PM   #648
BullyWRX
Scooby Specialist
 
Member#: 258756
Join Date: Sep 2010
Chapter/Region: South East
Location: Wilimgton, NC
Vehicle:
2011 WRX
SWP

Default

Quote:
Originally Posted by chanomatik View Post
So I've read that a front mount intercooler with stock everything else causes more turbo lag. What about a larger top mount intercooler? Stock WRX ones are so tiny!
Are you gonna go with a larger turbo setup down the road? If not, a nice top mount will do the trick + a retune.

$72 for 1 freaking mudflap? Suck it! It's almost half the price of 4!
BullyWRX is offline   Reply With Quote
Old 12-27-2011, 05:17 PM   #649
patrick10
Scooby Newbie
 
Member#: 234145
Join Date: Jan 2010
Chapter/Region: South East
Location: Eastern, NC
Vehicle:
2012 SWP STi

Default

If you were to ever get protuned, your tuner would most likely recommend that you upgrade your TMIC because it can only handle 21-22 psi before the endtanks blow off.
As far as FMIC or TMIC for the VF52, I've seen both. There are threads saying the increased lag is so minimal with the FMIC, that it's recommended if you plan to upgrade other power adders in the future.
Other threads, like the FAQ, say it is unnecessary to have a FMIC with the stock turbo. And back when wrx's had TD04's, I would agree, but now I believe it's personal preference.
Also, in humid states people have upgraded their stock TMIC's with FMIC's because of the terrible, increased heat soak. There are also members' threads where aftermarket TMIC's have been replaced with FMIC's and have had better results for DD.
patrick10 is offline   Reply With Quote
Old 12-27-2011, 05:23 PM   #650
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Quote:
Originally Posted by BullyWRX View Post
Are you gonna go with a larger turbo setup down the road? If not, a nice top mount will do the trick + a retune.

$72 for 1 freaking mudflap? Suck it! It's almost half the price of 4!
I know, right?!

Quote:
Originally Posted by patrick10 View Post
If you were to ever get protuned, your tuner would most likely recommend that you upgrade your TMIC because it can only handle 21-22 psi before the endtanks blow off.
As far as FMIC or TMIC for the VF52, I've seen both. There are threads saying the increased lag is so minimal with the FMIC, that it's recommended if you plan to upgrade other power adders in the future.
Other threads, like the FAQ, say it is unnecessary to have a FMIC with the stock turbo. And back when wrx's had TD04's, I would agree, but now I believe it's personal preference.
Also, in humid states people have upgraded their stock TMIC's with FMIC's because of the terrible, increased heat soak. There are also members' threads where aftermarket TMIC's have been replaced with FMIC's and have had better results for DD.
Coo. Thanks for the input. The reason I ask is because I really don't plan on on power mods beyond a full exhaust. I already have a dp and tune. However, I would LOVE to have a sleeper WRX sedan with a 2.5i hood, so FMIC would be necessary. I know a guy with a 2.5i that I've already swapped trunks with, so a hood swap might be possible.

If I don't go with the hood swap, I was thinking a Process West TMIC would be nice to kind of fill out the engine bay, but that's just me being more of a cosmetic brat than anything else.
chanomatik is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differences of 2011 wrx motor and 2011 sti motor stpkenton Factory 2.5L Turbo Powertrain 3 03-06-2012 11:03 AM
Differences of 2011 wrx motor and 2011 sti motor stpkenton Newbies & FAQs 3 05-12-2011 09:27 PM
2011 Subaru shifter fitment! All TWM Shifters still fit! TWM Performance Vendor Announcements 14 02-28-2011 03:27 PM
iPod 3g DLO Jam Jacket (clear) and Radtech 3g Indigo Podsleev 10gb/15gb agentmaxwell Private 'For Sale' Classifieds 1 05-24-2006 07:41 PM
Attn: Clayton, Ben and all others involved in the 6MT discussion. sherifx Mid West Subaru Owners Club Forum -- MWSOC 1 07-31-2002 03:00 AM


All times are GMT -4. The time now is 08:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.