Welcome to the North American Subaru Impreza Owners Club Friday March 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 06-05-2011, 04:54 AM   #1
junior1023
Scooby Newbie
 
Member#: 223393
Join Date: Sep 2009
Chapter/Region: RMIC
Location: Colorado Springs
Vehicle:
2002 WRX
World Rally Blue

Default Just hit 140,000 miles on my bugeye

Feels bad man
* Registered users of the site do not see these ads.
junior1023 is offline  
Old 06-05-2011, 05:01 AM   #2
hoodwinked
Scooby Newbie
 
Member#: 273540
Join Date: Feb 2011
Chapter/Region: SCIC
Location: Sunny CA
Vehicle:
03 bugeye wrx
PSM

Default

look on the bright side, at least shes still running
hoodwinked is offline  
Old 06-05-2011, 05:05 AM   #3
junior1023
Scooby Newbie
 
Member#: 223393
Join Date: Sep 2009
Chapter/Region: RMIC
Location: Colorado Springs
Vehicle:
2002 WRX
World Rally Blue

Default

Quote:
Originally Posted by hoodwinked View Post
look on the bright side, at least shes still running
Its true . But when I first bought the car it had 127,xxx and a ton of problems came with that. Timing belt seized in the first month. Then after 6 weeks of repaired (got screwed on the repair) THEN a friend of mine and I had to replace the transmission. Add in a busted wheel bearing and I've dealt with enough lol. Im always petrified of something happening to it. Seeing those miles just go up and up just adds to the stress of it.
junior1023 is offline  
Old 06-05-2011, 05:55 AM   #4
kiyanichenko
Scooby Newbie
 
Member#: 185603
Join Date: Jul 2008
Chapter/Region: SCIC
Location: carlsbad, CA
Vehicle:
2002 stock wrx
wrb

Default

Yea i got 142,000. Ive done alot of maintenance, and replaced alot of parts already. Still have problems, but thats because i treat her pretty roughly. Engine and tranny still run strong though!
kiyanichenko is offline  
Old 06-05-2011, 11:35 AM   #5
sourcandy
Scooby Newbie
 
Member#: 212410
Join Date: May 2009
Location: Houston, TX
Default

I hit 130k on mine. Done alot of basic maintenance and repair. Getting ready to replace all the rubber hoses under the hood with some better stuff.
Changed all filters and fluids
two new front axles
all the brakes
suspension
fuel pump
Clutch/Flywheel
Timing belt and idlers
Plugs
Belts

still have a leak from the rear diff and the valve covers that needs to be adressed and a valve that needs shimming.

Runs like a bat outta hell though
sourcandy is offline  
Old 06-05-2011, 12:50 PM   #6
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

168k on mine!
WhiteBgeye02 is offline  
Old 06-05-2011, 12:54 PM   #7
Zanders
Scooby Newbie
 
Member#: 284793
Join Date: Jun 2011
Location: Seattle Area
Vehicle:
2002 Impreza WRX
Silver

Default

Mine has 194,000+ on it. Ran like a champ, but I decided to replace engine and trans. Thought it was time :-)
Zanders is offline  
Old 06-05-2011, 12:58 PM   #8
Anthonydinatale
*** Banned ***
 
Member#: 273143
Join Date: Feb 2011
Chapter/Region: MWSOC
Location: Mundelein, IL
Vehicle:
2004 WRX
WRB

Default

160,000 on my 04 wrx runs good
Anthonydinatale is offline  
Old 06-05-2011, 01:46 PM   #9
seanathanq83
Scooby Guru
 
Member#: 173241
Join Date: Feb 2008
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2002 s256 twinscroll
now with one more gear

Default

man she is just getting broken in lol, i just rolled 155k last night, i believe i have been running on a downed cylinder for about 12-15k, and she is still doing just fine
seanathanq83 is offline  
Old 06-05-2011, 01:48 PM   #10
scoobay
Scooby Newbie
 
Member#: 110158
Join Date: Mar 2006
Location: Broward County
Vehicle:
2004 WRX Wagon
WRB

Default

148k on my 04 wagon - feels great!
scoobay is offline  
Old 06-05-2011, 04:14 PM   #11
Dan Mascioli
Scooby Newbie
 
Member#: 228738
Join Date: Nov 2009
Location: Media, Pa
Vehicle:
2002 WRX sport wagon
silver

Default

Got you all beat '02 WRX wagon with 228K. original clutch, pesky check engine comes on intermiitently and burns oil, adding quart every 1500 to 2K. Dealer serviced, wow just tallied up all my service records , almost $7K! Totally stock,no mods.
Dan Mascioli is offline  
Old 06-05-2011, 04:41 PM   #12
RSTimpreza
*** Banned ***
 
Member#: 144808
Join Date: Mar 2007
Chapter/Region: TXIC
Location: Spring, TX
Vehicle:
2003 WRX
Sonic Yellow

Default

160k here
RSTimpreza is offline  
Old 06-05-2011, 09:06 PM   #13
jason02wrx
Scooby Newbie
 
Member#: 222893
Join Date: Sep 2009
Chapter/Region: NESIC
Location: Rowley, MA
Vehicle:
2012 WRX Hatch SWP
2002 WRB Bugeye

Default

274,574 on my 02. Been Stage 2 since 65k and beat the snot out of her on a daily basis since I broke it in. One clutch replacement, two timing belts/water pumps and a radiator. Couldn't have asked for a better car! And she still runs mid 13's on the OE snail!
jason02wrx is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just hit 30,000 miles mrubino83 Brakes, Steering & Suspension 5 07-13-2004 09:01 AM
just hit 60,000 miles on my '02 wrx FloridaWRX General Community 20 06-30-2004 09:38 AM
So I just hit 10,000 miles MattDell Member's Car Gallery 17 04-11-2002 08:47 PM


All times are GMT -4. The time now is 07:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.