Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-23-2002, 07:43 PM   #1
wrxdriven
Scooby Newbie
 
Member#: 8056
Join Date: Jul 2001
Vehicle:
2002 WRX
black

Default Need Help with LINK ECU tuning

I have STI injectors, Supra Fuel Pump, Fuel Pressure Regulator, MRT Intake, MRT FMIC, HKS Carbon Titanium Exhaust, LINK ECU I have an ok hadle on how to tune the chip but i just want to make sure i don't mess anything up. I still have a few problems any input will help.

When i start the car i have to turn the key twice to get it started and hold it for quite awhile.

Second, I am using a lot of gas (is that just because of the fuel pump? What Gas Mileage are you getting?)

Lastly, The motor gets very hot to the touch. The link reads only about 90-94 degrees on average but the motor just seems much hotter than normal. What can i do to fix these problems or is this normal?
* Registered users of the site do not see these ads.
wrxdriven is offline   Reply With Quote
Old 07-23-2002, 07:52 PM   #2
JenisonWRX
Scooby Specialist
 
Member#: 6049
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Jenison.Doomhammer
Vehicle:
02 WRX & 99 RS
Black

Default

Hey ... while I don't have the upgraded pump and injectors ...

here are my comments

1. wait for the pump to pressurize ... you can hear it. We've talked about this before. Turn the key to the first position ... then wait. Then start the car.

2. I just got 320 miles on 1 tank with a autox in there as well. thats about 24 MPG> i have a MPG and Link thread around here somenwhere ... though not many seem to be interested in saving gas

3. heat wrap your DP and turbo
JenisonWRX is offline   Reply With Quote
Old 07-23-2002, 07:57 PM   #3
SFastWRX
Scooby Specialist
 
Member#: 13379
Join Date: Dec 2001
Location: Los Angeles
Vehicle:
2002 WRX
I am Oz

Default

To fix the car starting issue, turn the key on, but don't start for 5 or 10 seconds to give the Link time to boot. Should start fairly quickly then.

Some on the board are getting decent mileage, but I'm definitely not, because I'm running pig rich anytime there's boost to keep my knk values down. I believe this is due to some combination of at least 3 factors - crappy 91 octane CA gas, fuel hitting the pistons, and/or the turbo (FP upgraded) pushing hot air into the system. I will see if the third is a factor tomorrow when I pick my car up from Suby Specialties, as they're installing my MRT FMIC today and tomorrow and I should get significantly better cooling of the intake air over the stock IC. Would have done it myself, but I'm lacking a plasma cutter or the patience to go through a hundred cutting disks with my angle grinder.

As for the hot engine issue, I dunno, but if your coolant temps aren't getting any higher, it could just be your imagination.

HTH
SFastWRX is offline   Reply With Quote
Old 07-23-2002, 09:36 PM   #4
WRX_ONLY
Vendor
 
Member#: 13455
Join Date: Dec 2001
Location: Southern California
Vehicle:
2002 WRX
Sliver

Default Sweet Ride

SFastWRX,
Just saw yer ride at SS that MRT FMIC is all business...Steve was busy working that bumper beam can't wait to see how it turns out.



Areg
WRX_ONLY is offline   Reply With Quote
Old 07-23-2002, 10:12 PM   #5
christoph1371
Scooby Specialist
 
Member#: 1090
Join Date: Mar 2000
Location: CA
Default

for detaied info pm skywalker on link tuning
chris
christoph1371 is offline   Reply With Quote
Old 07-23-2002, 10:26 PM   #6
SFastWRX
Scooby Specialist
 
Member#: 13379
Join Date: Dec 2001
Location: Los Angeles
Vehicle:
2002 WRX
I am Oz

Default Re: Sweet Ride

Quote:
Originally posted by WRX_ONLY
SFastWRX,
Just saw yer ride at SS that MRT FMIC is all business...Steve was busy working that bumper beam can't wait to see how it turns out.



Areg
Me too, Areg! Thanks for the compliment on my ride. Brett M and crew make a really nice piece. I just talked to Steve a little while ago, sounds like he's having "fun" hacking away on that beam. Hopefully the reduced pressure drop will let the turbo breathe just a bit easier and the larger core will remove enough heat that I'll be able to take some fuel out of rows 7 & 8 on my link when it's done. If not, I may have to consider upgrading the turbo again to something with a little bigger exhaust housing.
SFastWRX is offline   Reply With Quote
Old 07-24-2002, 03:30 PM   #7
wrxdriven
Scooby Newbie
 
Member#: 8056
Join Date: Jul 2001
Vehicle:
2002 WRX
black

Default Thanks everyone

Thank you for the input. If anyone else has any suggestions i would love to hear them.

THanks
wrxdriven is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with link EM PowderMan420 North West Impreza Club Forum -- NWIC 3 09-23-2005 02:11 PM
Need Help With Link ECU Locally fukamoto Vancouver Impreza Club Forum -- VIC 9 11-08-2004 06:35 PM
need help with link+ for 2.5 sideways slut Engine Management & Tuning 15 12-25-2002 04:34 AM
Help with LINK ECU Info kaos200 Engine Management & Tuning 15 08-01-2002 03:22 AM
I Need Help With my ECU / S-AFC TSDScooby General Forum Archive 1 03-25-2001 12:26 AM


All times are GMT -4. The time now is 06:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.