Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Care & Detailing

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-01-2011, 06:11 PM   #1
camerong
Scooby Newbie
 
Member#: 225101
Join Date: Sep 2009
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2006 WRX TR
OBP

Default Paint job gone bad???

Hey guys. Just got a couple pics of my car and ive noticed in certain lighting and while I wash the car you can see this. Im not sure if its from a bad wax job that got left on there and destroyed the paint? I have no idea really because Im not a paint guy. If there is anybody here that is into paint jobs or knows about this kind of stuff Id really appreciate any feedback or input. Thanks again!

Here is how it looks during the day normally:



This is while washing it:









* Registered users of the site do not see these ads.
camerong is offline   Reply With Quote
Old 07-01-2011, 07:04 PM   #2
cmiller219
Scooby Specialist
 
Member#: 187179
Join Date: Aug 2008
Chapter/Region: HIIC
Location: Honolulu, HI
Vehicle:
14 STi
@cmiller219

Default

Looks like you have ALOT of iron on ur car. Get some Ironx and or something like it from a detailer shop and try that.
cmiller219 is offline   Reply With Quote
Old 07-01-2011, 08:32 PM   #3
SnaP
Scooby Newbie
 
Member#: 135339
Join Date: Dec 2006
Chapter/Region: NESIC
Location: Winsted, Connecticut
Vehicle:
2011 Impreza WRX STi
Dark Grey Metallic

Default

clay bar than collinite it
SnaP is offline   Reply With Quote
Old 07-02-2011, 12:18 AM   #4
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

Quote:
Originally Posted by cmiller219 View Post
Looks like you have ALOT of iron on ur car. Get some Ironx and or something like it from a detailer shop and try that.
....curious. What indicators do see in these pictures that lead you to believe those streaks were caused by ferrous contamination?

OP, IMO that looks like some sort of chemical staining either from something someone applied/spilled on the car at one point or from run-off under a tree, parking garage, roof, bridge, etc. The finish also looks fairly void of any product.

Are you dead set on doing something about it yourself? If so, are planning to work by hand or do you have detailing equipment/supplies (i.e. buffer, pads, polishes, etc.)? It may be worth it to you to simply take the car to a professional and have them inspect, advise and/or see what they can do. This may or may not be correctable but some things like this you simply don't know until you start trying different things.
Kean is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Badge painting gone bad. mdungelman Interior & Exterior Modification 25 04-27-2007 04:17 PM
bad paint job... !? Team SSSS Interior & Exterior Modification 18 03-07-2006 11:27 PM
MY02 WRX - Bad Factory Paint Job ? Kenneth2000 Warranty Issues & SOA Problems 15 08-10-2002 05:54 PM
First paint job bad they're doing it again shippy1 Warranty Issues & SOA Problems 11 04-19-2002 03:24 PM
my bumper + bad driver = paint job suby ej25 Interior & Exterior Modification 3 01-14-2001 03:21 PM


All times are GMT -4. The time now is 03:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.