Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-21-2011, 11:29 AM   #126
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Burnaby, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Default

Nice video. Very nice!
* Registered users of the site do not see these ads.
Ken is offline   Reply With Quote
Old 10-21-2011, 04:03 PM   #127
jagan323
Scooby Newbie
 
Member#: 282909
Join Date: May 2011
Vehicle:
2006 WRX STI
OBP

Default

Nice video, congrats on the car! =D
jagan323 is offline   Reply With Quote
Old 10-21-2011, 09:16 PM   #128
Loomin
Scooby Guru
 
Member#: 118113
Join Date: Jun 2006
Chapter/Region: VIC
Vehicle:
98' Stagea 260RS
Autech Ver.

Default

nice! sounds good minus the loose belt lol! fired right up i love it when that happens!
Loomin is offline   Reply With Quote
Old 10-21-2011, 09:41 PM   #129
Ricewagon
Scooby Specialist
 
Member#: 59703
Join Date: Apr 2004
Chapter/Region: VIC
Location: Vancouver
Vehicle:
2003 GGA
wrb

Default

Congrats!
Ricewagon is offline   Reply With Quote
Old 10-22-2011, 03:04 AM   #130
kinleong106
Scooby Specialist
 
Member#: 169595
Join Date: Jan 2008
Chapter/Region: VIC
Location: Burnaby B.C.
Vehicle:
10 SoBaLo Estea-ai
09 CBR 600RR

Default

Des! Come to AB tomorrow after SI ok? I need to see this!
kinleong106 is offline   Reply With Quote
Old 10-22-2011, 03:50 AM   #131
dTos
Scooby Newbie
 
Member#: 279977
Join Date: Apr 2011
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2011 STi
WRB

Default

HELLS YEAH!!! That thing sounds awesome!!
dTos is offline   Reply With Quote
Old 10-22-2011, 12:37 PM   #132
2010 WRX Limited
Scooby Specialist
 
Member#: 217458
Join Date: Jul 2009
Chapter/Region: VIC
Location: Langley BC
Vehicle:
2010 WRX Limited

Default

nicely done. Can't wait to see it. Hopefully next Friday is a clear night....
2010 WRX Limited is offline   Reply With Quote
Old 10-22-2011, 01:04 PM   #133
fukkeneh240
Scooby Newbie
 
Member#: 252966
Join Date: Jul 2010
Default

oh wow. Congrats on finally getting it done Desmond.
fukkeneh240 is offline   Reply With Quote
Old 10-22-2011, 02:56 PM   #134
cp77
Scooby Newbie
 
Member#: 237464
Join Date: Feb 2010
Location: Poco
Vehicle:
2009 WRX STI
Dark Metallic Grey

Default

Congrats, that looked like a ton of work. Very Cool Ride.
cp77 is offline   Reply With Quote
Old 10-22-2011, 11:22 PM   #135
Keenah
Scooby Specialist
 
Member#: 133754
Join Date: Dec 2006
Chapter/Region: SCIC
Location: In my house
Vehicle:
1998 RSTi
All blue, all blue baby

Default

I'm posting your video on the iWire facebook page! Congrats, really cool you've got a good group of people to come support you!
Keenah is offline   Reply With Quote
Old 10-23-2011, 12:31 AM   #136
Studebaker83
Scooby Specialist
 
Member#: 169443
Join Date: Jan 2008
Chapter/Region: VIC
Location: Langley, BC
Vehicle:
2008 WRX with VF-52
World Rally Blue

Default

Awesome swap man.
Studebaker83 is offline   Reply With Quote
Old 10-23-2011, 04:15 AM   #137
jchretien
Scooby Specialist
 
Member#: 217235
Join Date: Jul 2009
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
1999 FoLEsTa EsTe-Ai
Canyon Red

Default



probably one of the only foresters around that need the extra ramps haha
jchretien is offline   Reply With Quote
Old 10-23-2011, 02:32 PM   #138
pope_face
Scooby Specialist
 
Member#: 274373
Join Date: Feb 2011
Chapter/Region: VIC
Location: Van City, BC
Vehicle:
1997 Impreza OBS
Blue - "Mishka"

Default

Lol, smooth...

How's the engine running? Heading out to Rocket now that you've got your alignment?
pope_face is offline   Reply With Quote
Old 10-28-2011, 08:06 PM   #139
jchretien
Scooby Specialist
 
Member#: 217235
Join Date: Jul 2009
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
1999 FoLEsTa EsTe-Ai
Canyon Red

Default

Well, the saga continues. Apparently aircare cannot communicate with my ECU, says my car isnt running. Hopefully some ecutek will take care of that.

meanwhile, renew temp insurance to get compression and leakdown tests to make sure I'm not failing. Dont wanna have to get Rocket to fix a bunch of stuff.
jchretien is offline   Reply With Quote
Old 10-28-2011, 08:18 PM   #140
Woodenhorse
Scooby Newbie
 
Member#: 263215
Join Date: Nov 2010
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2002 WRX Wagon
WRB

Default

Did you tell them it's a japanese ECU?

I thought JDM cars didn't use ODB2.
Woodenhorse is offline   Reply With Quote
Old 10-28-2011, 08:21 PM   #141
jchretien
Scooby Specialist
 
Member#: 217235
Join Date: Jul 2009
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
1999 FoLEsTa EsTe-Ai
Canyon Red

Default

mcwc has the same ecu, same engine. His passes...
jchretien is offline   Reply With Quote
Old 10-28-2011, 08:34 PM   #142
Woodenhorse
Scooby Newbie
 
Member#: 263215
Join Date: Nov 2010
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2002 WRX Wagon
WRB

Default

Hmm...did he have to let them know that his is a JDM ECU?

Or do you suspect its an issue with the internal wiring?
Woodenhorse is offline   Reply With Quote
Old 10-28-2011, 09:07 PM   #143
mcwc
Scooby Specialist
 
Member#: 196262
Join Date: Dec 2008
Chapter/Region: VIC
Location: Vancouver
Vehicle:
1999 RSTi, Silver
1990 240DL, Gold

Default

I have a V7 JDM with ECUTek. I didn't tell the Aircare tech anything. I just drove in and have them plug in their reader. A visible cat, no CEL and 4 readiness monitors set and I get a pass.

Subaru started implementing OBDII in the V7 JDM cars. The V7 JDM ECU has the OBDII port for diagnostics but it doesn't implement the full OBDII test suite that the USDM cars have. IIRC, the V8 JDM ECU is fully OBDII compliant.

Now, I don't know the reason why jchretien's ECU didn't pass Aircare. An OBDII code reader reads his ECU just fine. It could be that it was stuck in learning mode (according to Kin's Tactrix cable) or ECUTek is needed to make it spit out enough data to Aircare's reader to pass the OBD test or the same voodoo magic that RR did to my car.

Last edited by mcwc; 10-29-2011 at 09:25 PM.
mcwc is online now   Reply With Quote
Old 10-28-2011, 09:16 PM   #144
Woodenhorse
Scooby Newbie
 
Member#: 263215
Join Date: Nov 2010
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2002 WRX Wagon
WRB

Default

Thanks...that was one of the things hadn't figured out when I was contemplating doing a v7 jdm STI swap on my bugeye.
Woodenhorse is offline   Reply With Quote
Old 10-29-2011, 08:43 PM   #145
mcwc
Scooby Specialist
 
Member#: 196262
Join Date: Dec 2008
Chapter/Region: VIC
Location: Vancouver
Vehicle:
1999 RSTi, Silver
1990 240DL, Gold

Default

Oh Yeah!!!

mcwc is online now   Reply With Quote
Old 10-29-2011, 08:54 PM   #146
(98)RSti
Scooby Newbie
 
Member#: 266726
Join Date: Dec 2010
Chapter/Region: VIC
Vehicle:
1998 RS Coupe
black

Default

whoa... what did u guys do? did the ecutek flash did the trick? or was it something else???
(98)RSti is offline   Reply With Quote
Old 10-29-2011, 09:12 PM   #147
rs420
surf ninja
Moderator
 
Member#: 157784
Join Date: Aug 2007
Chapter/Region: VIC
Location: victoria baby
Vehicle:
02 swapped bugeye
anthricite

Default

Was it a loose pin in a connector? Or what did you guys do???
Congrats
rs420 is offline   Reply With Quote
Old 10-29-2011, 09:23 PM   #148
mcwc
Scooby Specialist
 
Member#: 196262
Join Date: Dec 2008
Chapter/Region: VIC
Location: Vancouver
Vehicle:
1999 RSTi, Silver
1990 240DL, Gold

Default

It wasn't a loose connector at the ECU.

I drove in and the tester plugged in their reader. The screen read "please check if engine is running" and audibly, the engine was running. Eventually, an "Supervisor Override" dialog popped up on the screen. The supervisor put in their override and that was it, a pass.

I don't know what the Supervisor Override did but it pulled out the same info my Innova 3100 OBDII code reader pulled out and as shown on the inspection report.

Last edited by mcwc; 10-29-2011 at 09:31 PM.
mcwc is online now   Reply With Quote
Old 10-29-2011, 09:50 PM   #149
bikergreen
Scooby Specialist
 
Member#: 192157
Join Date: Oct 2008
Chapter/Region: VIC
Location: Vancouver
Vehicle:
04 STI Wagon
JBP

Default

Quote:
Originally Posted by jchretien View Post
Well, the saga continues. Apparently aircare cannot communicate with my ECU, says my car isnt running. Hopefully some ecutek will take care of that.

meanwhile, renew temp insurance to get compression and leakdown tests to make sure I'm not failing. Dont wanna have to get Rocket to fix a bunch of stuff.
I just had the exact same issue with my V9 with ecutec!! so annoying, still waiting to find a solution.
bikergreen is offline   Reply With Quote
Old 10-29-2011, 09:54 PM   #150
bikergreen
Scooby Specialist
 
Member#: 192157
Join Date: Oct 2008
Chapter/Region: VIC
Location: Vancouver
Vehicle:
04 STI Wagon
JBP

Default

Quote:
Originally Posted by mcwc View Post
It wasn't a loose connector at the ECU.

I drove in and the tester plugged in their reader. The screen read "please check if engine is running" and audibly, the engine was running. Eventually, an "Supervisor Override" dialog popped up on the screen. The supervisor put in their override and that was it, a pass.

I don't know what the Supervisor Override did but it pulled out the same info my Innova 3100 OBDII code reader pulled out and as shown on the inspection report.
I need this to happen to me, I had the same thing when I went then the tester did the drive test and I failed that by a small amount... What did RR do?
bikergreen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What do you guys think of a SPT intake? What do you have? chomponthis231 Newbies & FAQs 28 07-07-2009 09:01 AM
Well, I think we know what the OTHER half of the battle is... Asinine Off-Topic 8 02-02-2009 09:32 AM
Ok, I finished the first draft of Sharky's wedding sermon. What do you think? Asinine Off-Topic 98 02-09-2006 12:01 PM
So I removed the front bumper and the two "slide" clips cracked. Now what? Scott4DMny Interior & Exterior Modification 1 01-29-2006 05:23 PM
What do you guys think of the front end of my car? joefocker20 Member's Car Gallery 13 01-29-2003 07:09 PM


All times are GMT -4. The time now is 06:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.