Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-29-2002, 02:31 AM   #1
SONofSAM
Scooby Specialist
 
Member#: 8407
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: gabage island, NEW YORK
Unhappy Engine Light turn ON...what to do!

My Engine light turn on after i had clean/steam my engine...
i try disconnect the battery 2 time's for like 20-30 mins and runs my car around my block for like 3 time's...then i find out when i shift from second to third gears! the engine light turn on right away Blink Blink... and i feel the car is little choke when everytime i step on the gas pedal...
do you guys think this is a big problem! should i run couple more time's and see's the light still turn on!

please educate me a bit!
thanks guys,
* Registered users of the site do not see these ads.
SONofSAM is offline   Reply With Quote
Old 07-29-2002, 10:55 AM   #2
SONofSAM
Scooby Specialist
 
Member#: 8407
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: gabage island, NEW YORK
Default

anyone know!
SONofSAM is offline   Reply With Quote
Old 07-29-2002, 12:13 PM   #3
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

Sounds like a misfire. Blinking CEL's are indicative of a misfire and if you just steam cleaned your engine you could've gotten some water into your plug wire boots or worse fried the coil pack. You'll either need to pull the code from your local autozone and get to the dealer and buy parts, hoping I'm right. Or just take it into the dealer and ask for some help (most dealers will allow a tech to take a "quick" look at a car before scheduling service).
BOY is offline   Reply With Quote
Old 07-29-2002, 09:34 PM   #4
stentorian
Scooby Specialist
 
Member#: 12959
Join Date: Dec 2001
Chapter/Region: MWSOC
Location: Raymore, MO
Vehicle:
2008 Scion xB
White

Default

Blinking CEL = Misfire
stentorian is offline   Reply With Quote
Old 07-30-2002, 09:37 AM   #5
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

Any updates? It it still misfiring? I'm wondering if over the past few days the coil/wires/plugs have dried out.
BOY is offline   Reply With Quote
Old 07-30-2002, 11:10 AM   #6
SONofSAM
Scooby Specialist
 
Member#: 8407
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: gabage island, NEW YORK
Default

Quote:
Originally posted by BOY
Any updates? It it still misfiring? I'm wondering if over the past few days the coil/wires/plugs have dried out.
Hey,

i find out this morning, that my one of my spark plug wire full of water...i have to take the spark plug out have them dry out and disconnect the battery for like 30 mins...then afterward i plug everything back in, and start the car...Guess what!
the Engine light turn off.
what a breath taking!
Anyway thanks for the some info you guys give me!
And chris, i'm still down to the installfest this coming weekend...
SONofSAM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Check Engine light on & Cruise Control Light Blinking STiURBO Southern California Impreza Club Forum -- SCIC 21 03-15-2007 01:54 AM
Got the CE light - P0037 - Any suggestions on what to do? curveslayer Factory 2.0L Turbo Powertrain 3 01-07-2007 01:36 PM
Check engine light on and cruise control light flashing mpadovano Factory 2.5L Turbo Powertrain 6 01-23-2005 02:04 PM
question on what to do about fog lights izhazissuez Electrical & Lighting 2 08-04-2003 03:54 AM
Engine vibrating, check engine light on codemunky Service & Maintenance 2 09-15-2002 07:50 AM


All times are GMT -4. The time now is 12:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.