Welcome to the North American Subaru Impreza Owners Club Sunday August 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Bay Area Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Bay Area Impreza Club Forum -- BAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-29-2002, 11:55 AM   #1
SONofSAM
Scooby Specialist
 
Member#: 8407
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: gabage island, NEW YORK
Unhappy ATTN: Bill or Chris

Is there anyway you can help me!
My Engine light turn on after i had clean/steam my engine ( I did cover some of the parts that can't be wet/steam)...
i even try disconnect the battery 2 time's for like 20-30 mins and runs my car around my block for like 3 time's...when i shift from 2nd to 3th gears and step on the gas pedal and i felt the car is little choke (not much! but very little)...the engine light turn on right away Blink Blink...
do you guys think this is a big problem! should i run couple more time's and see's the light still turn on!
Since my car is 96 1.8 model, can you guys pull the code out.
when will be the next installfest!

please educate me a bit!
thanks guys,
* Registered users of the site do not see these ads.
SONofSAM is offline   Reply With Quote
Old 07-29-2002, 12:12 PM   #2
christoph1371
Scooby Specialist
 
Member#: 1090
Join Date: Mar 2000
Location: CA
Default

We can pull the code, sure. I will be busy the next few nights. Try and swing by this weekend.

Does the light come on immediatly after reset?
christoph1371 is offline   Reply With Quote
Old 07-29-2002, 12:28 PM   #3
SONofSAM
Scooby Specialist
 
Member#: 8407
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: gabage island, NEW YORK
Default

Quote:
Originally posted by christoph1371
Does the light come on immediatly after reset?
Nope, maybe a few mins when the car is operate...then light starting to blink...

thanks Chris i swing by this weekend...
SONofSAM is offline   Reply With Quote
Old 07-29-2002, 03:25 PM   #4
Catfish
Scooby Newbie
 
Member#: 1322
Join Date: Apr 2000
Location: Silicon Valley
Vehicle:
2000 2.5RS Sedan
72 Datsun 240Z

Default You have water in some of your connectors.

It will eventually evaporate but you'll have problems until it does and it may take a week or so for that to happen. Best bet is to check the connectors, starting with the ones you didn't cover before the steam cleaning and dry them out. A hairdryer works great, or if you don't have one simply leaving them unplugged for a few hours might do the trick. Don't forget to check your sparkplug wires as well.

This is why it is so important to make sure you properly cover any electrical connectors (and unplug the battery) prior to any kind of steam/water cleaning.
Catfish is offline   Reply With Quote
Old 07-29-2002, 03:30 PM   #5
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

Dude, you know its against the rules to post this in so many forums.

Anyways Id say find all the electrical connectors you can dry them out. I usually take a paper towel and rip a small section so I can stick it in the connector.
ciper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATTN: Bill or anyone else in parts... Stime187 South East Region Forum 0 06-10-2003 01:17 PM
Attn: Bill or Jerry Snowman South East Region Forum 3 10-22-2002 04:18 PM
Attn: Bill & Chris, my 1st request for non-Subie stuff sjt Bay Area Impreza Club Forum -- BAIC 2 03-21-2002 03:20 PM
Bill or Chris? (or anyone else for that matter...) ryball Bay Area Impreza Club Forum -- BAIC 0 02-04-2002 04:41 PM
Attn: Bill and Chris Andrew Bay Area Impreza Club Forum -- BAIC 1 10-29-2001 01:15 PM


All times are GMT -4. The time now is 02:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.