Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2011, 02:54 AM   #1
bmxpunk
Scooby Specialist
 
Member#: 89599
Join Date: Jun 2005
Chapter/Region: RMIC
Location: middle of nowhere, wyoming
Vehicle:
1995 almost 22B:)
red

Default EJ20g wired 95 intermit run/fuel pump relay clicking

Very strange problem.
My 95 impreza is wired as an wrx with an ej20g and I am currently running Rob's 550 tune. Car ran fine for 2 years, and I recently started stripping the wiring harness of anything not needed (cruise control, airbag, radio) as this is a rally car.

The car ran perfectly for 1.5 months after stripping the harness then one day at the dairy queen drive up window a relay under the dash (later found to be the fuel pump relay) starts clicking and the car dies and won't start.

Got the car back to my house and it started and idled for 5 minutes then the clicking and returned and it would die. I turned the key to start it again and the wastegate solenoid starts clicking, and the fuel pump won't run. Does this for the next few minutes while I continue to try starting. Then the fuel pump runs, car starts, idles, dies, and the wastegate solenoid starts clicking again.

I have the entire harness out of the car tonight and I have been going through each circuit testing continuity and they all seem to be perfect.

the systems that I stripped off the harness came off complete so I don't have any powers or grounds that aren't accounted for. Anyone have any ideas?
* Registered users of the site do not see these ads.
bmxpunk is offline   Reply With Quote
Old 08-15-2011, 07:21 AM   #2
peanutswagon
Scooby Newbie
 
Member#: 197057
Join Date: Dec 2008
Chapter/Region: MAIC
Location: Collegeville, Pa
Vehicle:
1997 98 Foz V3 swap
Black

Default

Bump for my man. Good question
peanutswagon is offline   Reply With Quote
Old 08-15-2011, 08:20 AM   #3
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

ground the main and fp relay straight to the car, see what taht gives you
eg33GC is offline   Reply With Quote
Old 08-15-2011, 09:06 AM   #4
suberdave
NASIOC Supporter
 
Member#: 101865
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
88 GL-10 STi
silver

Default

Sounds like a grounding problem... you have to test it in the car, not on the bench. try doing voltage drops not resestance checks, to check the wiring.

-=Suberdave=-
suberdave is offline   Reply With Quote
Old 09-18-2011, 12:15 PM   #5
bmxpunk
Scooby Specialist
 
Member#: 89599
Join Date: Jun 2005
Chapter/Region: RMIC
Location: middle of nowhere, wyoming
Vehicle:
1995 almost 22B:)
red

Default

I sent my ecu to omahasubaru to try out while I redid some of my wiring. His car started to do the same thing once he plugged in my computer. So now we have to figure out if something went wrong in the ecu.

In the mean time, does anyone know where I can get replacement terminals for the subaru connectors? I have all of the wiring out of the car and I want to replace some of my spliced wires with just 1 piece of wire.
bmxpunk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need fuel pump and fuel pump relay 4/18/10 raceckr MWSOC Private Classifieds 1 04-18-2010 03:05 AM
Fuel Pump Relay Control and Airconditioner Cut Relay Control modifiedauto Newbies & FAQs 0 09-19-2007 08:43 PM
Fuel Filter replacement - where is fuel pump relay? SeenDubAYouAreEx Newbies & FAQs 4 07-11-2007 09:29 PM
STi ver3 to 2000 RS: Fuel pump relay wire? DeusExMachina Subaru Conversions 8 10-05-2006 08:37 AM
2.5RS no spark...fuel pump relay clicking polak13 Normally Aspirated Powertrain 8 01-26-2006 03:25 PM


All times are GMT -4. The time now is 10:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.