Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-29-2011, 12:02 AM   #1
04stinugget
Scooby Specialist
 
Member#: 236332
Join Date: Jan 2010
Chapter/Region: SCIC
Location: san diego
Vehicle:
200 wrx sti swap
sonic yellow

Default dash harness question 04 sti swapped 03

alright guys have a few weird little issues with my bugeye.

It's an 03 wrx 5 spd with a full 2004 harness. Dash swapped as well and column controls to. The problems are when I turn off the lights my dash lights come on. When I turn on the lights my dash lights go off. Headlights/taillights/turn signals/hazards all work just fine however. When I turn on my windsheild wipers nothing happens but the sprayer button works just fine. I can use the hvac controls to select face feet defrost and all options but I cannot turn on the blower. which makes for one very slow to warm up car in the morning. the switches hvac controls and dash all worked correctly before I had motor and tranny issues. the harness motor and tranny are all brand new but not my electrical is all crazy. Any ideas?

If anyone has a full wiring diagram for a 2004 sti dash I can figure it all out on my own but I haven't been able to find a diagram yet.

gimme some thoughts boys!
thanks
Evan
* Registered users of the site do not see these ads.
04stinugget is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS/FT : TN :*Going back to stock* 02 wrx harness to 04 Sti complete swap Bug_i_Sti Engine/Power/Exhaust 0 03-01-2011 07:09 PM
04 STI SWAP/HARNESS to 04 WRX TRANS-HELP-What wires do what on each. Maverick7531 Transmission (AT/MT) & Driveline 1 06-25-2010 04:55 PM
04 sti to 03 wrx cluster swap? wrxsubiemod Subaru Conversions 3 11-22-2008 12:54 AM
03 wrx to 04 sti swap icr_03 Subaru Conversions 3 02-18-2008 10:18 AM
04 STI --> 03 WRX trunk swap??? speelnik Mid West Subaru Owners Club Forum -- MWSOC 1 08-09-2003 10:10 PM


All times are GMT -4. The time now is 12:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.