Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-31-2011, 02:09 AM   #1
STi MAN86
Scooby Newbie
 
Member#: 287906
Join Date: Jul 2011
Location: Australia
Vehicle:
2006 STi
Black

Default About to run in my rebuilt motor... What oils to use?

Ok it's time for my car to be alive again...

Got my self some Penrite 15w-40 running in oil http://www.penriteoil.com.au/product...running_in_oil

That I will be using for the 1st 100km and then put another batch of the new same oil for the next 500-900km

What oil should I use after that? Full synthetic oil or semi synthetic and what weight?

Motor is a 2.5L new block with stock rods and CP pistons with oil rings mod

Cheers
* Registered users of the site do not see these ads.

Last edited by STi MAN86; 08-31-2011 at 02:21 AM.
STi MAN86 is offline   Reply With Quote
Old 08-31-2011, 02:20 AM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

i wouldnt use any syn oil in it for 4000-5000km
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OT: Looking for an inexpensive generator to run a full sized fridge. What do I need? GodWhomIsMike Off-Topic 18 08-31-2011 12:51 PM
What clutch to run in my LGT 05subiegtwagon Transmission (AT/MT) & Driveline 1 08-01-2011 10:44 PM
New Hybrid motor, What oil to use? ryan_west06 Built Motor Discussion 25 03-30-2011 12:55 PM
Clutch about to go in my '02 WRX, what to do Animsteve Transmission (AT/MT) & Driveline 8 05-12-2010 01:22 PM
type of fuse to run in my power line? vincent-h Car Audio, Video & Security 10 01-21-2006 02:53 AM


All times are GMT -4. The time now is 07:27 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.