Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-14-2014, 11:47 AM   #5951
94-1.8
Scooby Newbie
 
Member#: 311660
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Everett WA
Vehicle:
98 2.5rs
WRB

Default

Quote:
Originally Posted by WRXgabeSTi View Post
Removed my A/C today. (hasn't worked for 4+ years) Ran into a snag when my alternator tensioner bolt snapped! Luckily I had the spare tire tie down bolt, which fit perfectly for anyone who runs into this problem Get to show off the radiator now !
How does that even happen???
* Registered users of the site do not see these ads.
94-1.8 is offline   Reply With Quote
Old 01-14-2014, 03:04 PM   #5952
WRXgabeSTi
Scooby Specialist
 
Member#: 239606
Join Date: Feb 2010
Chapter/Region: NWIC
Location: What the hell is Puyallup?
Vehicle:
03' Bugeye Stage 2
Matte black 250k+

Default

Quote:
Originally Posted by 94-1.8 View Post
How does that even happen???
Just an old worn out bolt. My car has 263k miles.
WRXgabeSTi is offline   Reply With Quote
Old 01-14-2014, 03:11 PM   #5953
jdm05
Scooby Specialist
 
Member#: 180155
Join Date: May 2008
Chapter/Region: NWIC
Location: washington
Vehicle:
e85 05 wrx
PSM

Default

Took car to Pia for egt check need new probe
jdm05 is offline   Reply With Quote
Old 01-14-2014, 03:49 PM   #5954
WRXgabeSTi
Scooby Specialist
 
Member#: 239606
Join Date: Feb 2010
Chapter/Region: NWIC
Location: What the hell is Puyallup?
Vehicle:
03' Bugeye Stage 2
Matte black 250k+

Default

Quote:
Originally Posted by jdm05 View Post
Took car to Pia for egt check need new probe
I'd just get rid of the egt. Not needed.

Put a bolt in the hole, and ask PIA for a resistor to stick in the plug Will cost ya like 2$

Last edited by WRXgabeSTi; 01-14-2014 at 04:13 PM.
WRXgabeSTi is offline   Reply With Quote
Old 01-14-2014, 04:49 PM   #5955
19-chief
Scooby Newbie
 
Member#: 301893
Join Date: Nov 2011
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
2005 92x Aero
DBM

Default

.....

Last edited by 19-chief; 01-14-2014 at 04:51 PM. Reason: wrong thread
19-chief is offline   Reply With Quote
Old 01-14-2014, 06:07 PM   #5956
jdm05
Scooby Specialist
 
Member#: 180155
Join Date: May 2008
Chapter/Region: NWIC
Location: washington
Vehicle:
e85 05 wrx
PSM

Default

^^^ for my defi gauges OCD about having something that doesn't work correctly.
jdm05 is offline   Reply With Quote
Old 01-14-2014, 06:08 PM   #5957
rawwmc1099
Scooby Newbie
 
Member#: 296984
Join Date: Oct 2011
Chapter/Region: South East
Vehicle:
2012 Impreza WRX
Ice Silver Metallic

Default

The simplest thing possible while under warranty, changed to a K&N air filter.
rawwmc1099 is offline   Reply With Quote
Old 01-14-2014, 06:24 PM   #5958
WRXgabeSTi
Scooby Specialist
 
Member#: 239606
Join Date: Feb 2010
Chapter/Region: NWIC
Location: What the hell is Puyallup?
Vehicle:
03' Bugeye Stage 2
Matte black 250k+

Default

Quote:
Originally Posted by jdm05 View Post
^^^ for my defi gauges OCD about having something that doesn't work correctly.
Ah, gauges are a different story. I just view via AP. I'm cheap. lmao.
WRXgabeSTi is offline   Reply With Quote
Old 01-14-2014, 06:57 PM   #5959
jdm05
Scooby Specialist
 
Member#: 180155
Join Date: May 2008
Chapter/Region: NWIC
Location: washington
Vehicle:
e85 05 wrx
PSM

Default

Yep lol
jdm05 is offline   Reply With Quote
Old 01-15-2014, 08:53 PM   #5960
Jaybfox4
Scooby Newbie
 
Member#: 316662
Join Date: Apr 2012
Chapter/Region: NWIC
Vehicle:
2002 Subaru WRX
Aspen White

Default

Been trying to find my boost leak for the last two days. Finally found the cracked hose right above the turbo and the bottom corner of the intercooler. Replaced it and hoping that solved my problem. Cant have any boost leaks, just really want to get my car tuned!!!
Jaybfox4 is offline   Reply With Quote
Old 01-15-2014, 09:05 PM   #5961
eastwoodsn352
Scooby Newbie
 
Member#: 334442
Join Date: Oct 2012
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
2008 WRX STI
Silver

Default

Put on my Nameless Performance Track Pipe. It sounds AMAZING. So Brutal. Shifting around 3-3.5k and not WOT (still doing my engine break-in.) Ignore that sexy leg you see in the video


Cobb downpipe, 3" non resonated mid-pipe, and the Nameless track pipe.
eastwoodsn352 is offline   Reply With Quote
Old 01-16-2014, 12:01 AM   #5962
gmhl10
Scooby Newbie
 
Member#: 158695
Join Date: Sep 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2013 GVB STi
World Rally Blue

Default

Just cleaned up bird poop from my car again. How is it that the bird (probably a goose or duck by the size of it) always seems to hit right in the gap where the hood and hood scoop gap is. Sucks cleaning it out of there. And once again, it happened when I was parked under nothing but the sky. What luck. Bird has it out for me.
gmhl10 is offline   Reply With Quote
Old 01-16-2014, 12:39 AM   #5963
ck_wagon
Scooby Newbie
 
Member#: 292102
Join Date: Aug 2011
Default

Fixed some camber bolts and camber plates for the front end. Fixed 2 small coolant "weeps".
ck_wagon is offline   Reply With Quote
Old 01-16-2014, 09:26 PM   #5964
DAS97sport
Scooby Specialist
 
Member#: 284143
Join Date: May 2011
Chapter/Region: NWIC
Location: Eastern Washington
Vehicle:
1998 Impreza 2.5RS
Acadia Green

Default

Uncovered the beautiful thing and pulled the transmission out so I can put it into the legacy. Having a fifth gear again will be nice
DAS97sport is offline   Reply With Quote
Old 01-16-2014, 09:52 PM   #5965
i5racer
Scooby Newbie
 
Member#: 308167
Join Date: Jan 2012
Chapter/Region: NWIC
Location: Shoreline, WA
Vehicle:
1998 Impreza L
Black

Default

Quote:
Originally Posted by DAS97sport View Post
Uncovered the beautiful thing and pulled the transmission out so I can put it into the legacy. Having a fifth gear again will be nice
#thestruggle
i5racer is offline   Reply With Quote
Old 01-16-2014, 10:08 PM   #5966
Oblivion
Scooby Newbie
 
Member#: 208588
Join Date: Apr 2009
Chapter/Region: NWIC
Location: Maple Valley, WA
Vehicle:
2005 WRX STi
Black

Default

Last month, I paid it off. Just now, bought a v3 AccessPort. Time for some HP mods!
Oblivion is offline   Reply With Quote
Old 01-16-2014, 10:43 PM   #5967
Amazing Asian
Scooby Specialist
 
Member#: 259589
Join Date: Oct 2010
Chapter/Region: NWIC
Location: Port Orchard, WA
Vehicle:
05 Saabaru 9-2X
Deep Blue Metallic

Default

Quote:
Originally Posted by Oblivion View Post
Last month, I paid it off. Just now, bought a v3 AccessPort. Time for some HP mods!
I love installing the title mod too!
Amazing Asian is online now   Reply With Quote
Old 01-16-2014, 10:51 PM   #5968
Oblivion
Scooby Newbie
 
Member#: 208588
Join Date: Apr 2009
Chapter/Region: NWIC
Location: Maple Valley, WA
Vehicle:
2005 WRX STi
Black

Default

Quote:
Originally Posted by Amazing Asian View Post
I love installing the title mod too!
Feels good. Hopefully the car holds up for another 100k or so
Oblivion is offline   Reply With Quote
Old 01-16-2014, 11:07 PM   #5969
Breezio
Scooby Specialist
 
Member#: 234357
Join Date: Jan 2010
Location: Forest Grove, OR
Vehicle:
2009 WRX
Sportwagen zum einbauen!

Default

Changed the oil for the last time before the motor goes under the knife...
Breezio is offline   Reply With Quote
Old 01-17-2014, 01:01 AM   #5970
decal lap
Scooby Newbie
 
Member#: 359737
Join Date: Jun 2013
Chapter/Region: NWIC
Location: Bremerton, Washington
Vehicle:
2005 Impreza OBS
Platinum Silver Metallic

Default

Put on some new 19" BBS LM Reps with all new rubber. 19x8.5 in front and 19x9.5 in rear. 235/35/19 on all fours. I know it's 50/50 that some say don't do it and some say to do it. I like it and believe it will be ok. If not, lesson learned.
decal lap is offline   Reply With Quote
Old 01-17-2014, 01:34 AM   #5971
NWsoobie
Scooby Specialist
 
Member#: 289516
Join Date: Jul 2011
Chapter/Region: NWIC
Location: PNW
Vehicle:
2012 WRX
ISM

Default

Quote:
Originally Posted by decal lap View Post
Put on some new 19" BBS LM Reps with all new rubber. 19x8.5 in front and 19x9.5 in rear. 235/35/19 on all fours. I know it's 50/50 that some say don't do it and some say to do it. I like it and believe it will be ok. If not, lesson learned.
Your fine as long as your rubber is on point. Also let's see some pics.
NWsoobie is offline   Reply With Quote
Old 01-17-2014, 01:40 AM   #5972
decal lap
Scooby Newbie
 
Member#: 359737
Join Date: Jun 2013
Chapter/Region: NWIC
Location: Bremerton, Washington
Vehicle:
2005 Impreza OBS
Platinum Silver Metallic

Default

Quote:
Originally Posted by NWsoobie View Post
Your fine as long as your rubber is on point. Also let's see some pics.
Yeah I'm running all the same size all around. Nittos. I will take some pics tomorrow when it's light out and post em.
decal lap is offline   Reply With Quote
Old 01-17-2014, 07:28 PM   #5973
decal lap
Scooby Newbie
 
Member#: 359737
Join Date: Jun 2013
Chapter/Region: NWIC
Location: Bremerton, Washington
Vehicle:
2005 Impreza OBS
Platinum Silver Metallic

Default

Here are some pics of the new wheels. Need to lower it just not sure how I want to do it yet.




decal lap is offline   Reply With Quote
Old 01-17-2014, 08:11 PM   #5974
i5racer
Scooby Newbie
 
Member#: 308167
Join Date: Jan 2012
Chapter/Region: NWIC
Location: Shoreline, WA
Vehicle:
1998 Impreza L
Black

Default

Installed junkyard starter and it works like a champ, much unlike the one it replaced
i5racer is offline   Reply With Quote
Old 01-17-2014, 09:39 PM   #5975
silverton
Scooby Newbie
 
Member#: 331131
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 2.5RS
STM

Default

Needed to reboot a front axle. Decided to just leave it out.
silverton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your Subie Today? Version 3 TrickNipple North West Impreza Club Forum -- NWIC 3796 09-07-2011 02:52 AM
What did you do to your Subie Today? Version 2 Smoke North West Impreza Club Forum -- NWIC 1978 05-21-2010 12:43 AM
What did you do to your Suby today? BREWPUBEAVER North West Impreza Club Forum -- NWIC 1197 11-01-2009 12:06 PM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM


All times are GMT -4. The time now is 08:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.