Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-24-2014, 12:11 AM   #6001
Dusten
Scooby Newbie
 
Member#: 190891
Join Date: Oct 2008
Chapter/Region: NWIC
Location: Marysville, Wa
Vehicle:
2013 WRX Limited
Plasma Blue

Default

Got hit in a parking lot. Awesome
* Registered users of the site do not see these ads.
Dusten is offline   Reply With Quote
Old 01-24-2014, 12:28 AM   #6002
sway162
Scooby Newbie
 
Member#: 377557
Join Date: Jan 2014
Chapter/Region: NWIC
Location: Tacoma, WA
Vehicle:
2014 SJ XT Premium
Crystal Black Silica

Default

Anyone wanna install lowering springs/rear sway bar on my SJ?? =) I will of course pay....I just don't have the space, time, tools and patience to do this like I used to back in the day.
sway162 is offline   Reply With Quote
Old 01-24-2014, 08:03 AM   #6003
kingfuzz
Scooby Specialist
 
Member#: 354354
Join Date: Apr 2013
Default

Haha maybe someone wants to help install my spacer/lift kit too. I dont even have a garage...
kingfuzz is offline   Reply With Quote
Old 01-24-2014, 03:18 PM   #6004
silverton
Scooby Newbie
 
Member#: 331131
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 2.5RS
STM

Default

Quote:
Originally Posted by Teedub21 View Post
Looks sweet! Good luck getting that bumper back on. I had a hell of a time with the tabs at the fender on the driver's side. One bent a bit and isn't perfectly flush. Apparently it is pretty common. Just pissed me off since my car was two weeks old and I'd just pulled the bumper to install my Hellas.
I've had my bumper off a few times. I don't think the driver side is ever going to be flush again without a new fender.

I passed emissions! OBD2 testing is dumb. Can have every emissions related component on the vehicle removed, but as long as the computer thinks everything is operating normal, PASS! lol
silverton is offline   Reply With Quote
Old 01-24-2014, 08:21 PM   #6005
RedMonkey999
Scooby Specialist
 
Member#: 191476
Join Date: Oct 2008
Chapter/Region: NWIC
Location: Olympia, WA
Vehicle:
2002 2.5RS AW
2007 FXT OBP

Default

Threw my new EZ30R on a stand so I can get started not working on it.

Also picked up my new shoes:
RedMonkey999 is offline   Reply With Quote
Old 01-25-2014, 07:41 PM   #6006
Dusten
Scooby Newbie
 
Member#: 190891
Join Date: Oct 2008
Chapter/Region: NWIC
Location: Marysville, Wa
Vehicle:
2013 WRX Limited
Plasma Blue

Default

Traded it in


Last edited by Dusten; 01-25-2014 at 10:58 PM.
Dusten is offline   Reply With Quote
Old 01-25-2014, 08:12 PM   #6007
Nick_P_
Scooby Newbie
 
Member#: 343384
Join Date: Jan 2013
Chapter/Region: NWIC
Location: Olympia, WA
Vehicle:
2003 Impreza wrx
Black

Default

Got my subie tuned today at PIA!
Nick_P_ is offline   Reply With Quote
Old 01-25-2014, 08:52 PM   #6008
SuperScubi
Scooby Specialist
 
Member#: 233407
Join Date: Dec 2009
Chapter/Region: NWIC
Location: Kirkland, WA
Vehicle:
2004 Aspen White STi
PIA Tune 347whp 327tq

Default

Quote:
Originally Posted by Nick_P_ View Post
Got my subie tuned today at PIA!
What did you put down?

I re-tuned at MPS yesterday. Still at 380whp
SuperScubi is online now   Reply With Quote
Old 01-26-2014, 01:27 AM   #6009
pincheturbo
Scooby Newbie
 
Member#: 341386
Join Date: Dec 2012
Chapter/Region: NWIC
Location: Lacey, Wash
Vehicle:
2006 STi
SGM RS#00

Default

Quote:
Originally Posted by Dusten View Post
Got hit in a parking lot. Awesome
Quote:
Originally Posted by Dusten View Post
Traded it in





bigger hood scoop
pincheturbo is offline   Reply With Quote
Old 01-26-2014, 02:49 AM   #6010
jtoler3
Scooby Newbie
 
Member#: 327408
Join Date: Jul 2012
Chapter/Region: NWIC
Location: Canby
Vehicle:
2013 WRX
SWP

Default

Quote:
Originally Posted by Teedub21 View Post
Looks sweet! Good luck getting that bumper back on. I had a hell of a time with the tabs at the fender on the driver's side. One bent a bit and isn't perfectly flush. Apparently it is pretty common. Just pissed me off since my car was two weeks old and I'd just pulled the bumper to install my Hellas.
[IMG][/IMG]
Odd, mine went on just fine! It was easier than I had even anticipated lol. I'll also be taking it off again when I get my Hellas 😜
jtoler3 is offline   Reply With Quote
Old 01-26-2014, 11:35 AM   #6011
Dusten
Scooby Newbie
 
Member#: 190891
Join Date: Oct 2008
Chapter/Region: NWIC
Location: Marysville, Wa
Vehicle:
2013 WRX Limited
Plasma Blue

Default

Quote:
Originally Posted by pincheturbo View Post



bigger hood scoop
I was working the deal when it got hit. Damage was minor. Dealer agreed to take car with damage for the same trade amount.
Dusten is offline   Reply With Quote
Old 01-26-2014, 11:20 PM   #6012
I'mFineW/Slow
Scooby Specialist
 
Member#: 260395
Join Date: Oct 2010
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2004 Impreza 2.5 RS
Blue

Default

I can no longer wait for it to be warm enough for summer-ish tires.

Huge thank you/shout out to the guys at Seattle Wheel Service for the powdercoat job. Every wheel looks immaculate, they gave me a deal on mounting/balancing tires form my old wheels, and they held the wheels while the fate (totaled or not) of my car was unknown.

Color is prismatic's dark sparkle grey





I'mFineW/Slow is offline   Reply With Quote
Old 01-26-2014, 11:49 PM   #6013
Wyldcat89
Scooby Newbie
 
Member#: 245725
Join Date: May 2010
Chapter/Region: NWIC
Location: Sherwood, OR
Vehicle:
2014 Forester
Ice Silver Metallic

Default

really like that color! they did a great job.
Wyldcat89 is offline   Reply With Quote
Old 01-27-2014, 12:27 AM   #6014
Amazing Asian
Scooby Specialist
 
Member#: 259589
Join Date: Oct 2010
Chapter/Region: NWIC
Location: Port Orchard, WA
Vehicle:
05 Saabaru 9-2X
Deep Blue Metallic

Default

+1 to Seattle wheel service. Had a wheel that was bent and they fixed it like new with no paint scuffs or peeling afterwards!
Amazing Asian is online now   Reply With Quote
Old 01-27-2014, 11:03 PM   #6015
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

Here is what I have been working on the last few days. Wrapping some interior parts. I still have more to do but I like the outcome so far.
ImNOrobo is offline   Reply With Quote
Old 01-28-2014, 07:17 PM   #6016
Shecker141
Scooby Newbie
 
Member#: 368756
Join Date: Sep 2013
Chapter/Region: NWIC
Location: Snoqualmie valley, washington
Vehicle:
2005 2.5rs
San remo red

Default

Looking for a new rear driver side mud flap because someone stole just one mud flap, not all 4, but just one....
Shecker141 is offline   Reply With Quote
Old 01-28-2014, 07:45 PM   #6017
rustmonkey
Scooby Newbie
 
Member#: 262703
Join Date: Nov 2010
Location: Bremerton WA
Vehicle:
2006 STi
SGM

Default

Got a call from PIA on the status of my baby, cracked oil pick up tube! Got it before it fell completely off! Engine is healthy! YES!
rustmonkey is offline   Reply With Quote
Old 01-28-2014, 10:30 PM   #6018
pocket_doc
Scooby Newbie
 
Member#: 339921
Join Date: Dec 2012
Chapter/Region: SCIC
Location: San Diego
Default

Quote:
Originally Posted by Shecker141 View Post
Looking for a new rear driver side mud flap because someone stole just one mud flap, not all 4, but just one....
That's just mean. Sorry to hear that.
pocket_doc is offline   Reply With Quote
Old 01-28-2014, 10:39 PM   #6019
94-1.8
Scooby Newbie
 
Member#: 311660
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Everett WA
Vehicle:
98 2.5rs
WRB

Default

Quote:
Originally Posted by Shecker141 View Post
Looking for a new rear driver side mud flap because someone stole just one mud flap, not all 4, but just one....
You sure it didn't just fall off? I hear hey do that a lot.
94-1.8 is offline   Reply With Quote
Old 01-28-2014, 11:01 PM   #6020
Shecker141
Scooby Newbie
 
Member#: 368756
Join Date: Sep 2013
Chapter/Region: NWIC
Location: Snoqualmie valley, washington
Vehicle:
2005 2.5rs
San remo red

Default

Quote:
Originally Posted by 94-1.8 View Post
You sure it didn't just fall off? I hear hey do that a lot.
yeah because all the washers and bolts and stuff and still there like they we're put back in, and mine are pretty flexible and I don't know how it would have broken off
Shecker141 is offline   Reply With Quote
Old 01-28-2014, 11:55 PM   #6021
gmhl10
Scooby Newbie
 
Member#: 158695
Join Date: Sep 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2013 GVB STi
World Rally Blue

Default

Quote:
Originally Posted by 94-1.8 View Post
You sure it didn't just fall off? I hear hey do that a lot.
+1... that's what happened to me. Luckily, I found it and I put it back on.
gmhl10 is offline   Reply With Quote
Old 01-29-2014, 01:04 AM   #6022
Breezio
Scooby Specialist
 
Member#: 234357
Join Date: Jan 2010
Location: Forest Grove, OR
Vehicle:
2009 WRX
Sportwagen zum einbauen!

Default

RA's mounting solution leaves something to be desired. It's nice that they can be 'torn off' without damaging anything else, but it's just not always secure. I've had several bolts pull through, thankfully haven't lost a flap. Now I run metal fender washers instead of their plastic washer setup. Of course this means that if one gets yanked on a curb again, might not be so pretty...
Breezio is offline   Reply With Quote
Old 01-29-2014, 11:23 AM   #6023
Oblivion
Scooby Newbie
 
Member#: 208588
Join Date: Apr 2009
Chapter/Region: NWIC
Location: Maple Valley, WA
Vehicle:
2005 WRX STi
Black

Default

Quote:
Originally Posted by Breezio View Post
RA's mounting solution leaves something to be desired. It's nice that they can be 'torn off' without damaging anything else, but it's just not always secure. I've had several bolts pull through, thankfully haven't lost a flap. Now I run metal fender washers instead of their plastic washer setup. Of course this means that if one gets yanked on a curb again, might not be so pretty...
I'm not sure if it just came loose or what, but I had one of the bolts on the rear drivers-side flap chew through the side mounting hole in the bumper, leaving a very small crack in the part of the bumper that resides in the wheel-well I ended up removing both rear flaps and leaving the front two on, because I can't seem to find the OEM plugs that went in those mounting holes Maybe my stupid self threw them away or something when I installed them years ago.

Not dissing RA, they make a fine product, but I don't think I'll be adding new flaps anytime soon.
Oblivion is offline   Reply With Quote
Old 01-29-2014, 03:00 PM   #6024
silverton
Scooby Newbie
 
Member#: 331131
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 2.5RS
STM

Default

Quote:
Originally Posted by Shecker141 View Post
Looking for a new rear driver side mud flap because someone stole just one mud flap, not all 4, but just one....
You sure you didn't back in to a curb or something? I guess someone could have given it a good yank, but you gotta remove the tire to get at the hardware.
silverton is offline   Reply With Quote
Old 01-29-2014, 03:53 PM   #6025
Shecker141
Scooby Newbie
 
Member#: 368756
Join Date: Sep 2013
Chapter/Region: NWIC
Location: Snoqualmie valley, washington
Vehicle:
2005 2.5rs
San remo red

Default

Well the weird part is is that all the hard wear is still there perfectly in place and nothing is broken
Shecker141 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your Subie Today? Version 3 TrickNipple North West Impreza Club Forum -- NWIC 3796 09-07-2011 02:52 AM
What did you do to your Subie Today? Version 2 Smoke North West Impreza Club Forum -- NWIC 1978 05-21-2010 12:43 AM
What did you do to your Suby today? BREWPUBEAVER North West Impreza Club Forum -- NWIC 1197 11-01-2009 12:06 PM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM


All times are GMT -4. The time now is 07:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.