Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-14-2011, 01:41 AM   #1
DinoGuan
Scooby Specialist
 
Member#: 42233
Join Date: Aug 2003
Chapter/Region: SCIC
Location: San Diego
Vehicle:
04 WRX waGGon
WRB

Default Boost Creep Fuel Cut?

So I seem to have all the ingredients for your typical boost creep situation:
2004 STi vf43
Short ram intake, big TMIC.
Catless 3" bellmouth turboback.

4th and 5th gear is hitting fuel cut after WOT for ~2 or 3 seconds.
1-3 are fine, except I did hit cut in 3rd climbing a big hill.

I now have P0244, wastegate solenoid input high.

The perfect storm for boost creep right?
I know there are 900,000 threads on boost creep.
However my logs are showing that fuel cut is not occurring at peak boost, nor at the same boost level every time. Is there another boost limit the oem ecu looks at, perhaps based on boost error? Or what else would cause the ecu to cut fuel?
Boost error is a bit high, peak is around -5.77.

I've also increased the fuel cut limit to 35.5 at 14.7atmospheric.
atmospheric reads 14.65psi.
One of my logs shows 33.23psi right when fuel was cut, another shows 34.39. Boost is solid and slowly tapering down/basically holding solid.
Both times Wastegate duty cycle is ~33% and slowly rising.
Here you can see it cut hard right at #53.


I'm new to open source tuning, and all the magical stuff the stock ECU does to make our subarus run so fantastically. Thanks in advance for any help on this.

Also, there is over 100% injector duty cycle... hows that work? Stock injectors (afaik, purchased powertrain for swap).

-Andrew
* Registered users of the site do not see these ads.
DinoGuan is offline   Reply With Quote
Old 09-20-2011, 01:35 PM   #2
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: F L O R I D A
Vehicle:
2002 USDM WRX
WRB

Default

34.39 - 14.7 = 19.69

datalog would be nice.
jaxscuby is offline   Reply With Quote
Old 09-22-2011, 10:35 AM   #3
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

Have you thought about trying a hybrid boost control setup to try to eliminate the creep? Here are some links to some info on it.
http://forums.nasioc.com/forums/show....php?t=2135421
http://forums.nasioc.com/forums/showthread.php?t=602674

-Chris
GrimmSpeed is offline   Reply With Quote
Old 09-22-2011, 11:49 AM   #4
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: F L O R I D A
Vehicle:
2002 USDM WRX
WRB

Default

need to get hotside ported at wastegate.
probably need larger wastegate..
jaxscuby is offline   Reply With Quote
Old 09-22-2011, 01:19 PM   #5
DinoGuan
Scooby Specialist
 
Member#: 42233
Join Date: Aug 2003
Chapter/Region: SCIC
Location: San Diego
Vehicle:
04 WRX waGGon
WRB

Default

Thanks guys,

I love the hybrid BC setup. I would love to go to that some day, but I did a long long run up a really big hill here, and got the wastegate duty cycle down to 0% and I hit 22psi, so I know I need to give the wastegate some porting love. But it only does it on really long pulls, normal flat pulls is still around 19psi. And my boost cut is set for 22.

I'm just still confused why I hit fuel cut before when I was still a couple PSI below fuel cut. I've done a lot of tweaking to the boost map to get rid of some silly boost error values. Target boost was set to 13.5 psi, and initial wastegate duty was set to 55, Turbo Dynamics was just slammed at -20 integral and -3 proportional trying desperately to lower boost to the target, anyway, it was a silly map.

I suppose my plan is to just port the wastegate, throw my gm 3-port back in, maybe go with a fancier hybrid system like GrimmSpeed showed, and see if that does it.
DinoGuan is offline   Reply With Quote
Old 09-29-2011, 04:39 PM   #6
Bamofo
Scooby Specialist
 
Member#: 159743
Join Date: Sep 2007
Location: Plymouth Ma
Vehicle:
07 STI Limited
TurboMike Tuned 2.35

Default

its not that... your injector duty cycle is at 114%... thats the ECU that shutting off your injectors...
Bamofo is offline   Reply With Quote
Old 10-08-2011, 10:46 PM   #7
mxturboracer86
Scooby Specialist
 
Member#: 82398
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2013 SXL
555 Motorsports

Default

the ECU will not shut the car off, i've seen calculated as high as 130% injector duty cycle, to solve your boost creep problem all you need is to resolve the tuning and boost control settings and you will have no issues.

Feel free to PM me
mxturboracer86 is offline   Reply With Quote
Old 05-09-2012, 11:30 AM   #8
doc.alfa
Scooby Newbie
 
Member#: 248329
Join Date: Jun 2010
Location: Denmark
Vehicle:
2007 Forester
Silver

Default

Quote:
Originally Posted by mxturboracer86 View Post
the ECU will not shut the car off, i've seen calculated as high as 130% injector duty cycle, to solve your boost creep problem all you need is to resolve the tuning and boost control settings and you will have no issues.

Feel free to PM me

I have seen these old thread and i have about the same problem, i dont now up is fuel cut or boost creep. my car have slight engine fall outs with wot most in 4/5 gear
i have log with romraider and when these fall out comes my injector duty cycle hits around 105%, with boost about 1,1bar. I have tries to raise the fuel pressure to have the duty to fall but it dint work.
can any help me here in Denmark
Many Thanks
Søren
forester xt 2006
with GT28 turbo stock injectors
doc.alfa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost Creep/Fuel Cut 07 WRX Stage 2 Catted Downpipe ads87 Newbies & FAQs 3 09-16-2010 12:54 PM
Turboback for an STi (Don't buy one) = horrible boost creep and fuel cut 300blueballs Factory 2.5L Turbo Powertrain 166 12-09-2007 03:47 PM
Hesitation @ high RPM, low boost, and Fuel Cut K.Linchpin Factory 2.0L Turbo Powertrain 4 09-17-2006 09:07 PM
How to increas boost without fuel cut w/A.P. c'dalerider Factory 2.0L Turbo Powertrain 6 11-17-2005 10:45 AM
Max boost & Fuel Cut Questions... Hassassin Tri-State Area Forum 3 11-26-2002 09:39 AM


All times are GMT -4. The time now is 12:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.