Welcome to the North American Subaru Impreza Owners Club Sunday July 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-14-2011, 06:14 PM   #1
Drunk Lemon
Scooby Newbie
 
Member#: 257547
Join Date: Sep 2010
Location: Wake Forest, NC
Vehicle:
1993 Impreza
White

Default ej20 major help needed

Well i purchased a jdm ej20g late last year and practically just now completely finished everything due to lack of tools and weather from not being able to be garaged. the car i swapped it into is a 1993 impreza L, my issue is that everything works, the engine cranks, sounds great with good compression, but wont turn on, i'm getting no spark, when i bought the motor they gave me the wiring harness but no ecu, i had assumed i didnt need it and could just use the ej18 harness and ecu, and i was going to/am going to use an smt6 piggyback, but for some reason i cant get that to work for some stupid reason, now before anybody gets all smart and calls me an idiot i'm 17 and this is the first car i've ever bought let alone swapped or anything, and i'm still learning. i feel like i'm not getting spark because the ej18 ecu reads a diffrent number of teeth per crankshaft turn than the jdm ej20 ecu, therefore the ecu is refusing to send any signal to spark the cylinder etc. i need to know whether or not i need to somehow source an ej20 ecu with harness or what, i cant do standalone because its too expensive with my finances, this has been a budget build for the most part but i havent cut any corners with the swap. i've tried to do research but i cant come up with anything, if anybody has gone through the same thing or can help me please do.

i have now done more research to determine its an electrical problem, i have purchased a 93 jdm ej20 z4 ecu, and i somehow need to source the connector from the engine harness to the ecu side, i have been told if i dont get a dash harness? then my dash will be completely useless, come today i just found out i have a fuel leak, at this point i'm really not sure what to do, if theres anybody who can help me out or has any tips on what i need to do about any of the above issues or lives in or near north carolina and is willing to help it would be really appreciated, i am new to this so i probably sound like an idiot, but like i said i'm not really sure what to do anymore
* Registered users of the site do not see these ads.
Drunk Lemon is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-14-2011, 07:57 PM   #2
Subbiespeed
Scooby Specialist
 
Member#: 276493
Join Date: Mar 2011
Chapter/Region: TXIC
Location: TX
Vehicle:
2005 STI
WRB

Default

ur not an idiot and im kinda impressed actually im 25 and this has been an fun and expensive. i have a ej20g in my rs so i can try and help. first off i have power fc running my car but ive had a hard time finding someone to tune it and plan on getting rid of it once i get it fixed(ill mention what happened in a min) my setup consist of just the ej20g engine harness mixed with my rs harness and my rs harness is plugged into the power fc... the engine side of it is merged into my rs which was working fine until about a foot of it grounded out about 6 inches from my powerfc and considering all the testing ive done its turned out that my pin on the powerfc has burned up(trying to fix it if not then i guess i have to buy hydra , which seems to be a favorite to tune along with aem) haven't heard of anyone using the z4 but either way the merging is a pain in the ass and this is the hardest swap ive ever seen or done and u can't use ur ej18 ecu as far as i know(ur in for a ride regardless and in the next couple of years ur in for a rollercoaster and an expensive swap fun but expensive...my best friend had 7gs in it and ive put another 2 in it but i have alotta upgrades just not 9gs worth...lol...its def probably the wiring and the ecu...so best bet is either find someone on here to try and talk u through the wiring or talk to east coast swappers and tell them what ur wanting to do and have them merge the harness(probably like 500 im guessing to merge the harness thats my guess anyway...i don't know the difference between ur harness and mine but if its similar then i take pics and send them to u(i have no probably helping in anyway i can...im in va by the way). send some pics my way of the swap and wiring. not alotta people have this swap so its hard to find someone to work on it and the subaru performance shop in my area didn't even know what kinda motor i had in mind just an fyi i know this is big so ill stop and hopefully someone else can help out
Subbiespeed is offline   Reply With Quote
Old 09-14-2011, 08:22 PM   #3
Drunk Lemon
Scooby Newbie
 
Member#: 257547
Join Date: Sep 2010
Location: Wake Forest, NC
Vehicle:
1993 Impreza
White

Default

thanks man, i really appreciate the support and stuff, basically this has pretty much been a budget build, i have bought alot of stuff from ebay, like exhaust, etc.but i definitely have not cut any corners, to be quite honest, i have comtemplated just selling everything and just buying something like a reg dd until i save up, i just wanted this so bad as soon as i got the car, as soon as i got it i knew what i wanted to do, its just become extremely frustrating because its been around a year now that i've been working on it, and come so close to it starting and then it not, its just hard to feel motivated after putting forth so much money and effort and have no outcome (driveable car). though even if i did sell it, i'm sure i wouldnt get anywhere near what i paid for the car plus all the money i've put into it since its not running, which is a little over 3k not including the 500 i paid for the car, not including blood sweat and tears haha, i just need to weigh my options and see what i need to do, merging the harness seems like the best thing to do, logically, not finacially, i'll just see if i can find anybody around here on the forums that can maybe help me or atleast guide me in the right direction, if you know of anyone down here please just point them my way haha

Last edited by Drunk Lemon; 09-14-2011 at 08:33 PM.
Drunk Lemon is offline   Reply With Quote
Old 09-14-2011, 11:58 PM   #4
Subbiespeed
Scooby Specialist
 
Member#: 276493
Join Date: Mar 2011
Chapter/Region: TXIC
Location: TX
Vehicle:
2005 STI
WRB

Default

trust me i know the feeling my buddy got the car about 5 and a half years ago and we started the build bout 6 months after and dropping the motor was no issue or even rebuilding the tranny with stronger gears only problem ive had with the car is wiring and i know have all of it cleaned up minus some gauges by the steering wheel and then a wire shorted out and the one that shorted out just happen to be the one that controls the fuel pump, ignition coil and i think its the power for the standalone so im hoping someone can fix it and get it going again and i might have to sell mine due to a kid on the way which i don't wanna due cuz of all the time and money in it...cars very quick though and before i started having fuel issues i beat a carrera 4s on low boost (15 psi with a mbc) and basic tune...if u can come up with the money buy a dd and just keep it as a project because thats what it is. ive been working on cars before i can drive one and the one thing u should learn is u never drive a car as ur dd that ur building because its not exactly reliable in a sense u have no idea whats gonna go wrong
Subbiespeed is offline   Reply With Quote
Old 09-15-2011, 09:07 AM   #5
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

There's probably an issue with the way you have wired the ignition coils (if you're using a coil-on-plug 1989-1996 style EJ20G).

The crank trigger wheels are the same between the USDM EJ18 and the JDM EJ20G so that's not the problem.
Marnix is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major Help Needed a.m.k Engine Management & Tuning 2 08-11-2008 03:23 PM
major help needed 2 problems with car..!! please all look.. evol04gt Service & Maintenance 13 04-24-2008 12:39 AM
calling gurus, major help needed! v8eaterWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 09-28-2006 09:38 AM
NEED MAJOR HELP LAYLOW Interior & Exterior Modification 3 06-06-2001 02:14 PM
Need Major Help bruno Car Audio, Video & Security 1 03-12-2001 02:10 AM


All times are GMT -4. The time now is 06:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.