Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-16-2011, 06:54 AM   #1
Elemento1991
Scooby Newbie
 
Member#: 265265
Join Date: Nov 2010
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2004 RSti
Midnight Blue

Default Heavy vibration under acceleration, possible issues?

About a week ago my car (04 wrx) started getting a light vibration around 35-55 mph. I figured it was just my exhaust hitting my unibody because it does that at certain engine speeds.

Yesterday when I went to make a pass I dropped to 2nd and got on it. The problem is now alot more severe. It vibrates heavily when under acceleration, mildly in neutral, and it smooths out when down gearing down hills.

I put the car on stands yesterday and the drive shaft is fine and the motor mounts are tight. The only thing I noticed is the front right axle boot is ripped, it had to happen in the past two weeks because I just put a new suspension set up on the car. I thought that torn boots usually effected turning and not the spinning motion of the axles.

Could this be the source of my issue, are there any other things I should check out?
* Registered users of the site do not see these ads.
Elemento1991 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
heavy vibration under load!!! please help ride918 Transmission (AT/MT) & Driveline 10 04-03-2012 09:36 PM
97 OBS vibration under acceleration only. darksc00by Transmission (AT/MT) & Driveline 3 07-05-2011 11:35 AM
Heavy vibration under braking cdvma Brakes, Steering & Suspension 57 09-17-2006 02:32 PM
Vibration under acceleration vinceGC8 Factory 2.0L Turbo Powertrain 4 11-22-2005 04:26 AM
Rattling under acceleration... possibly clutch? mpaone Service & Maintenance 5 05-09-2003 06:17 PM


All times are GMT -4. The time now is 10:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.