Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-17-2011, 03:46 PM   #1
fantasticfour
Scooby Newbie
 
Member#: 215453
Join Date: Jun 2009
Chapter/Region: SCIC
Vehicle:
2000 2.0RSTi
Aspen White

Default Little help with a noise from the engine..

Not sure this belongs here but oh well...
A little background. It's a 2000 RS with a EJ20K swap. Stock turbo, stock intake, stock downpipe.

When I accelerate up past 3-3.5k rpm, I get a weird "whomp" sound. This is my first turbo car so I'm not familiar with this. I know the "whoosh" of the blowoff valve, but this sounds like something else. For anyone more familiar with N/A motors, it's similar to the sound of an aftermarket intake.
Anyway, it comes on and off really quickly depending on how fast I rev past 3k rpm. But if I can hit the throttle just right, with the right amount of load, I can almost prolong the noise until it's almost like a hum.

I've been told it's the sound of the wastegate. Can anyone confirm this?
Also, I had an Apexi cone intake at first and I thought that's what it was, but I switched it to a K&N panel filter and it seems like it's quieted down a bit.

Thanks in advance.
* Registered users of the site do not see these ads.
fantasticfour is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New ticking noise from the engine.. Ashr Normally Aspirated Powertrain 1 07-21-2009 06:52 PM
Squeek Noise Help!...atleast its not from the engine BoostedAWD Factory 2.0L Turbo Powertrain 9 05-20-2006 09:56 PM
Humming noise from the engine bay??! sizzflair Newbies & FAQs 9 04-21-2006 06:03 PM
Weird on and off whining noise from the engine bay WITH THE CAR OFF. JM530 Car Audio, Video & Security 6 03-21-2006 08:29 AM
Help: Popping noise from the engine bay STi_Drift Engine Management & Tuning 6 08-12-2004 05:05 PM


All times are GMT -4. The time now is 02:10 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.