Welcome to the North American Subaru Impreza Owners Club Saturday August 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Tri-State Area Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Tri-State Area Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-13-2012, 03:37 AM   #1
SoYoLo
Scooby Newbie
 
Member#: 326333
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2011 STi
Blue

Default noises from driver side piller

hey all im new to the community had the subhi only for 4 months now since i bought the car my driver side piller makes alot of noise as i hit bumps and etc. any of you owners getting similar noise if so what can i do to fix it?
* Registered users of the site do not see these ads.
SoYoLo is offline   Reply With Quote
Old 10-13-2012, 09:27 AM   #2
itr.#1446
Scooby Newbie
 
Member#: 162447
Join Date: Oct 2007
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
03 Wrx
Sonic yellow

Default

I have noticed mine does the same but previous owner put a gauge pod on it so I figured it was from that. I'm also getting wind noise on my drivers side window and not the passenger :/
itr.#1446 is offline   Reply With Quote
Old 10-13-2012, 12:14 PM   #3
Bjay51d
Scooby Newbie
 
Member#: 294228
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: Ctl jerz
Vehicle:
05 Forester XT
OBP

Default

it's a subie thing my forester does it also

I just fixed my wind noise by running 5/16 clear hose inside of my indow weather strip.It works like a charm.Theres a DIY thread on subaruforesters.org
Bjay51d is offline   Reply With Quote
Old 10-13-2012, 01:53 PM   #4
itr.#1446
Scooby Newbie
 
Member#: 162447
Join Date: Oct 2007
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
03 Wrx
Sonic yellow

Default

If you can find the link post it up
itr.#1446 is offline   Reply With Quote
Old 10-13-2012, 03:26 PM   #5
njwrx10
Scooby Specialist
 
Member#: 169265
Join Date: Jan 2008
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2011 STI
SWP

Default

Hey Man. I had the same issue, but was able to fix it. What you do is buy some Felt that has tape on one side (Bought this at AC Moore. A fabric store) .

Take off the pillar covers, and you will notice on the bottom of the pillar there are female ends that fit into male ends on the dash. This is where its rubbing and making noise.

So what i did was but the felt tape on the female and male ends and all around the bottom, and the noise went away. You cant see the felt after to put it back in. Ill try and take pics, but that is where the noise is coming from.

Good Luck
njwrx10 is offline   Reply With Quote
Old 10-13-2012, 05:38 PM   #6
Bjay51d
Scooby Newbie
 
Member#: 294228
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: Ctl jerz
Vehicle:
05 Forester XT
OBP

Default

Quote:
Originally Posted by itr.#1446 View Post
If you can find the link post it up
http://www.subaruforester.org/vbulle...49/index2.html post 26 has pics of what i did...
Bjay51d is offline   Reply With Quote
Old 10-13-2012, 07:09 PM   #7
singincanary
Will mod for Guinness
Moderator
 
Member#: 77921
Join Date: Dec 2004
Chapter/Region: Tri-State
Location: Orange County, New York
Vehicle:
'02 Foz
'07 'beca, '08 OBXT

Default

That's a good fix for the frameless windows but the newer cars have framed windows so I'd doubt the tubing will make a difference for the OP.
singincanary is offline   Reply With Quote
Old 10-14-2012, 11:26 PM   #8
my name is joe
Scooby Specialist
 
Member#: 171412
Join Date: Feb 2008
Chapter/Region: Tri-State
Location: SQC
Default

I took off the whole driver pillar but there's still a rattle coming inside the dash. Lol its annoying but something to get used to i guess
my name is joe is offline   Reply With Quote
Old 10-15-2012, 10:43 AM   #9
njwrx10
Scooby Specialist
 
Member#: 169265
Join Date: Jan 2008
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2011 STI
SWP

Default

Yea, there are a lot of rattles in this car. I have a 2012 Sti hatch.

I use to have a 2005 WRX, and it did not have this many rattles.

It use to bother me, but I have learned to live with it since I can't figure them all out. I believe I have one in the dash that comes and goes, but there is no way to fix them. I mean there is, but its not worth messing with the dash.
njwrx10 is offline   Reply With Quote
Old 10-15-2012, 10:48 PM   #10
SoYoLo
Scooby Newbie
 
Member#: 326333
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2011 STi
Blue

Default

thanks for the tips guys
SoYoLo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.