Welcome to the North American Subaru Impreza Owners Club Saturday August 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-03-2002, 10:29 PM   #1
K Rock Impreza
Scooby Specialist
 
Member#: 19104
Join Date: May 2002
Location: MID-A Ninja
Vehicle:
2003 VW Jetta 1.8t
silver

Question Did I blow my MAF in my 1997L ?

Earlier today I was outside working on my friend's car and I saw that he had a yellow cone intake filter. Being the person that I am, I wanted things to match the yellow in the engine bay. I asked him if we could trade since, he agreed. We switched them and it looked nice and thought nothing of it. I then continued to work on his car. After I was done I wanted to hear how it would sound if it changed at all. I started the car, it sounded different, I waited a bit and then...POOF THE CAR DIES ...now my brother and his friend said that they saw white smoke/powder come from the MAF. I went over to take a look and it smelled kinda funny. Like something shorted out. I started it again and it made the same sound it made before (undescribable) but no smoke/powder. THE CAR DIES AGAIN. It still smelled funny. I may be retarded but is this a sign of a blown MAF, could something be wrong with the altenator because I did replace the battery for the first time? Can someone help me?
* Registered users of the site do not see these ads.
K Rock Impreza is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-04-2002, 10:47 AM   #2
K Rock Impreza
Scooby Specialist
 
Member#: 19104
Join Date: May 2002
Location: MID-A Ninja
Vehicle:
2003 VW Jetta 1.8t
silver

Default

no one?
K Rock Impreza is offline   Reply With Quote
Old 08-04-2002, 07:34 PM   #3
US2JDM
Scooby Guru
 
Member#: 5893
Join Date: Apr 2001
Chapter/Region: E. Canada
Location: Fairport, NY
Vehicle:
1997 Black GC4
1995 White BK6

Default

if the car does not stay started...you may have other issues.

I've heard from guys who've had a blown MAF that the ECU will go into 'limp home' mode and just not rev above 3500...but it should still run.

-Milan
US2JDM is offline   Reply With Quote
Old 08-05-2002, 11:13 AM   #4
jabrams
Scooby Newbie
 
Member#: 16384
Join Date: Mar 2002
Location: Pittsburgh
Vehicle:
99 Impreza RS
Aspen white

Default

My 99RS Wouldn't stay running with a blown MAF. If it is the
MAF you should be able to disconnect it and the car should run in
" limp mode". If there was oil on the filter it could have blown
the MAF. Never heard of the smoke before.

Hope this helps

Jabrams
jabrams is offline   Reply With Quote
Old 08-05-2002, 12:37 PM   #5
IggDawg
Celebrity Guest Star
 
Member#: 10648
Join Date: Sep 2001
Chapter/Region: NESIC
Location: Sort of Boston, MA
Vehicle:
1998 Acura CL... D:
Mostly kind of red

Default

Whats this whole MAF recall thing I keep hearing about? can you make use of that to get a new one? I just got my '97 L, and the TS had a MAP sensor so I never paid attention. Anyone know about this?

-IggDawg
IggDawg is offline   Reply With Quote
Old 08-05-2002, 05:51 PM   #6
US2JDM
Scooby Guru
 
Member#: 5893
Join Date: Apr 2001
Chapter/Region: E. Canada
Location: Fairport, NY
Vehicle:
1997 Black GC4
1995 White BK6

Default

I think the MAF recall only covers '99 and above.
US2JDM is offline   Reply With Quote
Old 08-10-2002, 05:40 PM   #7
wrxtuner02
Scooby Specialist
 
Member#: 22700
Join Date: Aug 2002
Chapter/Region: MAIC
Location: West Virginia
Vehicle:
TRD FJ Crusier SE
76 MG Midget Special

Angry

The exact smae thing just happened to my 02 WRX. I was leaving my neighborhood and just as i came under boost the car died and wouldn't restart. i thought it was the fuel pump but it was still spraying the cylinders for startup. i checked the MAF and the center of the fingerlike attachment is gone. i unplugged it and it would start but i get a CEL. im gonna replace it tommorrow.
wrxtuner02 is offline   Reply With Quote
Old 08-13-2002, 10:04 PM   #8
K Rock Impreza
Scooby Specialist
 
Member#: 19104
Join Date: May 2002
Location: MID-A Ninja
Vehicle:
2003 VW Jetta 1.8t
silver

Default

thanks for the help guys
K Rock Impreza is offline   Reply With Quote
Old 08-13-2002, 10:09 PM   #9
K Rock Impreza
Scooby Specialist
 
Member#: 19104
Join Date: May 2002
Location: MID-A Ninja
Vehicle:
2003 VW Jetta 1.8t
silver

Default

Oh, one more thing. wrxtuner02, can you let me know what happens when you replace the "finger like thing" I'm sure that it'll start up but i just want to make sure that it is just the MAF.
K Rock Impreza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i hear blow off valves in my sleep bobsrex Off-Topic 2 01-12-2004 10:28 AM
Blow out today in my 2 week old car Jeff92029 General Community 15 11-05-2003 10:43 AM
Keep my stusds in my snows? slowme Brakes, Steering & Suspension 11 10-03-2002 03:00 PM
What's wrong with my system in my WRX? WRXThis Car Audio, Video & Security 7 10-23-2001 12:52 PM
I should just stick my thumb in my a... dada21 Mid West Subaru Owners Club Forum -- MWSOC 6 05-03-2001 07:36 AM


All times are GMT -4. The time now is 03:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.