Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Canada Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Canada Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-05-2002, 12:25 AM   #1
subaru_owner
Scooby Newbie
 
Member#: 20761
Join Date: Jul 2002
Chapter/Region: W. Canada
Location: Moose Jaw, SK
Vehicle:
2000 Impreza 2.5RS
Aspen White

Question What's going on with my car?

Hi all......my car is making a pinging sound whenever I accelerate slowly in third gear.......what's going on?........all I have for mods is a custom exhaust and a ganz flow intake with K&N filter.....could it be running to lean/rich?........let me know what you all think..........thanks

Jay:
* Registered users of the site do not see these ads.
subaru_owner is offline   Reply With Quote
Old 08-05-2002, 01:45 PM   #2
markus
Scooby Specialist
 
Member#: 438
Join Date: Oct 1999
Chapter/Region: W. Canada
Location: St. Albert, AB, Canada
Vehicle:
2004 STi
White on Gold

Default

Sounds like bad gas to me. I would recommend going to Esso and filling up with some 92 Octane, or buying a canister of octane boost if you tank is already full.
markus is offline   Reply With Quote
Old 08-09-2002, 06:44 PM   #3
subaru_owner
Scooby Newbie
 
Member#: 20761
Join Date: Jul 2002
Chapter/Region: W. Canada
Location: Moose Jaw, SK
Vehicle:
2000 Impreza 2.5RS
Aspen White

Default

I always use 92 octane gas in my car.......every tank since I bought it......also Mobil 1 synthetic 5w30 every oil change...
subaru_owner is offline   Reply With Quote
Old 08-10-2002, 12:14 AM   #4
Scoobie Newbie
Scooby Specialist
 
Member#: 4184
Join Date: Feb 2001
Location: Bust the deal, face the wheel
Vehicle:
2004 WRX
World Rally Blue,Moonroof

Default

Have you tried different brands of gas? I've also read that octane boosters aren't good for our cars.
Scoobie Newbie is offline   Reply With Quote
Old 08-10-2002, 01:26 AM   #5
markus
Scooby Specialist
 
Member#: 438
Join Date: Oct 1999
Chapter/Region: W. Canada
Location: St. Albert, AB, Canada
Vehicle:
2004 STi
White on Gold

Default

You might want to get the plugs checked. Im not expert, but it may be plug fouling too.

Also, that last time I brought my wife's Legacy in for service, they found that three of the stock Subie plug wires we shot with excessively high resistance.

I'd suggest a service and bring the "pinging" issue to their attention. At least that way you're covered should anything go wrong and the try to claim you didn't bring it to their attention so they might not honour your warranty.

My 2 cents.

MB
markus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
local dealer doesn't know what's going on with my car CosmoTheCat Off-Topic 72 06-21-2008 12:13 PM
What's going on with my tires LSPR_MTU Tire & Wheel 6 05-17-2006 03:11 PM
What's going on with my transfer case? ELLCAPITAN Transmission (AT/MT) & Driveline 4 02-19-2005 05:41 PM
who can tell me what's going on with my video card? (pics and video inside) Mapplex Off-Topic 26 05-08-2004 12:56 PM
What is going on with my car? WRXerRacer Warranty Issues & SOA Problems 5 07-13-2003 10:42 PM


All times are GMT -4. The time now is 06:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.